5.4 engine miss no power - Ford F150 Forum - Community of Ford Truck Fans



5.4 engine miss no power

Reply
 
 
 
Thread Tools Search this Thread
Old 06-28-2010, 01:03 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 5.4 engine miss no power

my nitemare begun with the check engine lite . o2 sensor stuck high .I found gas seapage around o2 sensor and #7 exhaust port . replaced 02 and # 7 injector (stuck open dripping when removed) . engine ran good ,low power and knocking noise. Remove left head inspect valves,all seating and all straight. Removed pan and found #7 rod bent. replaced piston and rod. Reassemble with NEW OEM cam phasers ,chain guides,chain adjusters and timing solenoids. still runs rough low power.I then replaced remaining injectors. still the same. Received code PO174 system too lean bank 2 . Compression test was good from 160 to 170 psi.Ther is a slight poping through the air cleaner after running 20 mins. Also i hooked up a vacuum guage and the reading would not stay steady . meaning a mechanical problem. i rechecked the cam timing twice ,it's right on. Also I have battery voltage at the timing solenoids ,both wires. Any help would be gratefully appreciated .I am lost at this point . Thanks Hoser
Hoser is offline   Reply With Quote
Old 06-28-2010, 01:10 PM   #2
Member
 
Join Date: Apr 2010
Location: Everywhere
Posts: 4,124
Thanks: 0
Thanked 12 Times in 4 Posts
Default

Hoser the first thing you should have done was check the cop's (coil over plugs).
westtnfx4 is offline   Reply With Quote
Old 06-29-2010, 12:25 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by westtnfx4 View Post
Hoser the first thing you should have done was check the cop's (coil over plugs).
all the coil packs graphed out fine on the modis scope. any other ideas ,this is making me crazy !! thanks
Hoser is offline   Reply With Quote
Old 06-29-2010, 12:31 PM   #4
Member
 
Join Date: Apr 2010
Location: Everywhere
Posts: 4,124
Thanks: 0
Thanked 12 Times in 4 Posts
Default

You never stated you checked those ...I am still leaning towards the cops tho...
westtnfx4 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
North Central: 2009-2014 XLT Ford OEM Tow Mirrors yamahatim 2009 - 2014 Part Sales 9 05-03-2016 04:40 PM
Texas: 2012 F150 FX4 Ecoboost - Loaded OptimiStick 2009 - 2014 Truck Sales 5 04-11-2016 03:43 PM
Changed vct solenoids at 151k engine tick went away redfishtd 2004 - 2008 Ford F150 21 12-31-2015 12:25 AM
No Power and stutter at 45-50 again??? vegasdom 2004 - 2008 Ford F150 3 09-07-2015 01:01 AM
2000 5.4 leaking oil at crossover/Im Matthewb 1997 - 2003 Ford F150 0 09-05-2015 06:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:11 PM.


Copyright 2006 - 2016 F150Forum.com