Ford F150 Forum - Community of Ford Truck Fans

Ford F150 Forum - Community of Ford Truck Fans (http://www.f150forum.com/)
-   Lowered-Trucks (http://www.f150forum.com/f66/)
-   -   My Broken Belltech Lowering Strut (http://www.f150forum.com/f66/my-broken-belltech-lowering-strut-263703/)

royalblack 06-19-2014 11:13 AM

My Broken Belltech Lowering Strut
 
I purchased the Belltech Lowering Kit in November of 2013. I've had mine on the truck since I bought my first f150 (Nov 2013). After 14K km, it failed catastrophicly. The strut sheared in half while I was driving. The spring perch slammed on the the CV shaft, damaging the CV shaft. My truck had to be towed, was not drivable. Lucky my family wasn't in the car.

Its a great idea, however it needs to be significantly strengthen for is its application.

Words are meaningless, with no pictures.

https://www.facebook.com/photo.php?f...type=1&theater

https://www.facebook.com/photo.php?f...type=1&theater


https://www.facebook.com/photo.php?f...type=1&theater

https://www.facebook.com/photo.php?f...e=1&permPage=1

https://www.facebook.com/photo.php?f...e=1&permPage=1

:help::help::help:

Joe

zimmer0 06-19-2014 11:26 AM

interesting. what setting did you have them on? How is the roads where you live? First time ive seen these fail.

HawaiiKid 06-19-2014 12:13 PM

Pictures dont show up...

DJM/BELLTECH DIRECT 06-25-2014 03:08 AM

first one to fail since 2004 when they first came out and I started selling them.

REDrum5.0 06-25-2014 05:38 PM

Wow that is not good at all! Hope Belltech comes through for him.......

azmidget91 06-25-2014 05:54 PM

I would like to see pictures of the strut. Of the 5 post you have made on this site 3 have been about your strut breaking, but the pictures don't work. Only the first 2 pictures in this thread work.

I am interested to see where it broke.

I have 10,000 Miles on mine with it set to 2.5 and then a 2" drop coil for a 4.5" drop with no problems.

azmidget91 06-25-2014 05:59 PM

OK, did a little looking around on your Facebook page and found this picture

https://fbcdn-sphotos-b-a.akamaihd.n...55057361_n.jpg

Also found a comment from you that is was from hitting a pothole.

Also with only 14k km those tires look very worn on the inside edge, was it ever aligned after installed? did you do the install or a shop?


All times are GMT -4. The time now is 10:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com