Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-11-2013, 10:46 PM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Weird noise on my 97 4.6l

i have a 97 with 175k on it and when i bought it from a buddy he told me the Throttle position sensor was replaced because it made a weird horn like/ howling sound when the truck is up to operating temp and you are coasting to a stop sign. It doesnt always do it but if i tap the gas it goes away till i coast again. It will keep making the same sound even after ive stopped and put it in park untill i shut the truck off. I replaced the TPS and had no luck. Any ideas where I should look else where. Its coming from the intake and you can really hear it through the K&N filter when its idling. No engine codes are present
Redridermx88 is offline   Reply With Quote
Old 02-11-2013, 11:11 PM   #2
Will work for parts
5 Year Member
 
ghostrider's Avatar
 
Join Date: Feb 2008
Location: Everything is bigger in Texas
Posts: 783
Mentioned: 0 Post(s)
Thanks: 16
Thanked 22 Times in 20 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to ghostrider
Default

Are you sure that you replaced the tps. The iac valve is what is causing the fog horn sound at idle.
__________________
SUPERCHARGER will be here as soon as I can figure out how to convince my wife it will get better mileage
ghostrider is offline   Reply With Quote
Old 02-12-2013, 12:04 AM   #3
Senior Member
 
98redf150's Avatar
 
Join Date: May 2011
Posts: 406
Mentioned: 1 Post(s)
Thanks: 9
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Default

Does it have an entire k&n system?
__________________
98 f150 w/ 4.6, edge evolution cs, 6 inch zone on 35's, K&N cai, 4.88 richmond gears, flowmaster si/do exhaust
98redf150 is offline   Reply With Quote
Old 02-12-2013, 10:53 AM   #4
Junior Member
 
Join Date: Feb 2013
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I did indeed replace the TPS and it didnt do anything . But I was working off an old tip from the buddy who owned it before me. He had it taken to a shop and they infact changed the TPS. So your saying the IAC valve is whats bad eh? And it has a full K&N on it with an Airaid TBS
Redridermx88 is offline   Reply With Quote
Old 02-12-2013, 10:59 AM   #5
Senior Member
 
98redf150's Avatar
 
Join Date: May 2011
Posts: 406
Mentioned: 1 Post(s)
Thanks: 9
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Default

My truck used to do the same exact thing, I never found out the problem but I cleaned the filter and maf and it hasn't done it since and that was a year ago.
__________________
98 f150 w/ 4.6, edge evolution cs, 6 inch zone on 35's, K&N cai, 4.88 richmond gears, flowmaster si/do exhaust
98redf150 is offline   Reply With Quote
Old 02-12-2013, 11:10 PM   #6
Will work for parts
5 Year Member
 
ghostrider's Avatar
 
Join Date: Feb 2008
Location: Everything is bigger in Texas
Posts: 783
Mentioned: 0 Post(s)
Thanks: 16
Thanked 22 Times in 20 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to ghostrider
Default

Iac valve fixed mine, you may just try removing and cleaning it. The tps will have nothing to do with the sound.
__________________
SUPERCHARGER will be here as soon as I can figure out how to convince my wife it will get better mileage
ghostrider is offline   Reply With Quote
Old 02-12-2013, 11:10 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 07:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.