Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 11-16-2012, 08:57 AM   #1
Member
 
Join Date: Jun 2012
Posts: 43
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Water Pump???????

I was underneath my truck last night greasing everything and noticed some leaking anti-freeze on the bottom of the water pump. Truck has never overheated on me but my heat is way below adequate in this thing it will barely defrost my windows. Ive changed the tstat and flushed the radiator and the heater core on several occasions and still no heat. Im hoping this water pump is my heat issue? Could this be my problem even tho my truck isnt overheating???
Jason Mullins is offline   Reply With Quote
Old 11-16-2012, 11:05 AM   #2
Single & ready to mingle
 
Tackle's Avatar
 
Join Date: Sep 2012
Location: USA
Posts: 4,721
Mentioned: 29 Post(s)
Thanks: 124
Thanked 325 Times in 286 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Jason Mullins View Post
I was underneath my truck last night greasing everything and noticed some leaking anti-freeze on the bottom of the water pump. Truck has never overheated on me but my heat is way below adequate in this thing it will barely defrost my windows. Ive changed the tstat and flushed the radiator and the heater core on several occasions and still no heat. Im hoping this water pump is my heat issue? Could this be my problem even tho my truck isnt overheating???
It could be. If you don't drive for hours at a time it may not get to operating temperature. You live somewhere with frost so it will take longer for your truck to heat up. Leaking can be a sign of a bad WP. I would replace it, you certainly don't want your truck to over heat and warp something.

When you say it barely defrosts the window, is it because you haven't ran it to operating temp before you reach your destination? Is it because the blower is not working correctly?
Tackle is online now   Reply With Quote
Old 11-16-2012, 11:05 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.