Recurring P0118 ECT code - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Log In 

Recurring P0118 ECT code

Thread Tools Search this Thread
Old 12-25-2010, 02:04 PM   #1
Junior Member
Join Date: Dec 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Recurring P0118 ECT code

1997 4.6 auto

Had the heater core flushed, engine light came on and scan shows p0118. Replace both the black and grey sensors on top of manifold. Engine light came on again, replace the grey ECT sensor again. Still throws light right away when starting.

Hard to start in the morning and takes a few turns, then idles rough and dies if I press the gas. Need to leave it rev high for a little to keep running. After engine is warm, Starts and runs fine.

The first time I put the black sensor in the grey hole, by mistake and my temp gauge quit. Replace them both and gauge works but code p0118 pops up right away. Carquest checked with scanner, says engine is -40 degrees.

They said check the wiring.

Any help or adivice before I take it to the dealership !!

cncgg is offline   Reply With Quote
Join F150 Forum

Join Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that is a great community to join. Best of all it's totally free!

Join Today! - Click Here JOIN FOR FREE

Old 12-25-2010, 04:29 PM   #2
5 Year Member
torkum's Avatar
Join Date: Mar 2007
Location: MT. JULIET TN
Posts: 1,634
Thanks: 0
Thanked 8 Times in 4 Posts
Feedback Score: 0 reviews

I'm with Carquest, you have a connector/wiring problem. You might have pulled the wires out of the connector.
2015 XLT Supercab 4X4

torkum is offline   Reply With Quote
Old 04-12-2012, 09:54 PM   #3
Junior Member
Join Date: Dec 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

Finally got the check engine light to stay off !

I replaced the ECT sensor and connector, but light would come back on.

Found that the wires from the ECT sensor were cracked and rubbing both together. Replaced the wire back to the dash and did a tune up, new plugs and wires, truck runs great and no more check engine light !
cncgg is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just another dead on the road 2013 EcoBoost that Ford Won't Fix XDotNet General F150 Discussion 18 Today 05:50 PM
Important (Misfire) UCF 150 2011+ Engine Related Questions 10 Yesterday 05:36 PM
ABS Light - C1095 username182 1997 - 2003 Ford F150 3 10-05-2015 10:16 PM
f150 rough drive and can't find the problem!! theftedlincoln General F150 Discussion 1 09-27-2015 08:05 PM
Need help please! 99 f150 Ohio521 1997 - 2003 Ford F150 1 09-25-2015 05:14 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -4. The time now is 09:36 PM.

Copyright 2006 - 20011
This site is in no way affiliated with the Ford Motor Company.