Power windows not working ? - Ford F150 Forum - Community of Ford Truck Fans
Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Power windows not working ?

Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-18-2012, 09:10 PM   #1
Member
 
stangdad's Avatar
 
Join Date: Aug 2010
Location: Brandon Fl
Posts: 46
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Power windows not working ?

97 f150. Both power windows not working and wipers stop as well. Relay .Fuse ??? Please help
stangdad is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 05-18-2012, 10:31 PM   #2
Senior Member
 
kgintner1's Avatar
 
Join Date: Mar 2012
Posts: 10,752
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Default

Sounds like ur gem module. Does ur 4x4 work?
kgintner1 is offline   Reply With Quote
Old 05-19-2012, 08:51 AM   #3
Member
 
stangdad's Avatar
 
Join Date: Aug 2010
Location: Brandon Fl
Posts: 46
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by kgintner1 View Post
Sounds like ur gem module. Does ur 4x4 work?
Yes it still works
stangdad is offline   Reply With Quote
Old 05-19-2012, 12:00 PM   #4
Senior Member
 
kgintner1's Avatar
 
Join Date: Mar 2012
Posts: 10,752
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Default

Fuse 25 under the hood in the power box. It's a 30A
kgintner1 is offline   Reply With Quote
Old 05-19-2012, 11:36 PM   #5
Member
 
stangdad's Avatar
 
Join Date: Aug 2010
Location: Brandon Fl
Posts: 46
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by kgintner1 View Post
Fuse 25 under the hood in the power box. It's a 30A
thanks i will give that a look at
stangdad is offline   Reply With Quote
Old 05-19-2012, 11:37 PM   #6
Senior Member
 
kgintner1's Avatar
 
Join Date: Mar 2012
Posts: 10,752
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by stangdad

thanks i will give that a look at
Np good luck
kgintner1 is offline   Reply With Quote
Old 05-27-2012, 01:46 PM   #7
Member
 
stangdad's Avatar
 
Join Date: Aug 2010
Location: Brandon Fl
Posts: 46
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Update

Fuse's are all good, and #25 underhood is good. check for power at the fuse and I have power. What else could it be
stangdad is offline   Reply With Quote
Old 05-27-2012, 02:32 PM   #8
Member
 
Join Date: Apr 2012
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

It might be the switch has gone bad.
cgouldy is offline   Reply With Quote
Old 05-27-2012, 02:34 PM   #9
Member
 
Join Date: Apr 2012
Posts: 70
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

My 2003 F150 Super Crew driver side back window will not roll down from the driver contoll. It will roll down from the back switch. All other window roll down from diver controll except that one. i'm told it is mostlily the witch is going bad.

This this might be your problem as well.
cgouldy is offline   Reply With Quote
Old 05-27-2012, 04:29 PM   #10
Member
 
stangdad's Avatar
 
Join Date: Aug 2010
Location: Brandon Fl
Posts: 46
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Update

Checked switch no power. however no fuse is blown and i have power at each fuse outlet
stangdad is offline   Reply With Quote
Old 05-27-2012, 04:29 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 03:00 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.