Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-27-2011, 07:44 PM   #1
Lost but now Im found.
 
Join Date: Jun 2011
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs up Overdrive button problem FIXED. yahoooooo

Problem........ My 97 ford Expedition Overdrive is not working, It was working ok then suddently it stop. The light on the shift does not come on, But the transmission is working ok and shifting into all its gears I noticed, when I push on the overdrive button nothing happens. Is there a fuse for the overdrive....Please help


Problem Solved:.... I HAVE FINALY FOUND THE PROBLEM, THE OVERDRIVE WIRE WAS FRAYED, 2 OF THE 3 WIRES WERE CUT FROM RUBBING ON THE STEERING WHHEEL COLUMN, REMOVED THE WHOLE SHIFT AND REPAIRED THE WIRES PUT EVERYTHING BACK AND WALAAAA BACK IN BUSINESS......... yahoooooo. THANKS FOR THIS FORUN AND THE HELP OF SOME FOLKS THAT SHARED THERE EXPERIENCE HERE. SO GLAD NOW THIS IS NOW MY 2nd PROBLEM I RESOLVED FROM READING THESE FORUMS HERE. AWSOME....

Last edited by Ben RC; 07-02-2011 at 09:23 AM. Reason: Problem fixed
Ben RC is offline   Reply With Quote
Old 06-27-2011, 07:49 PM   #2
Lost but now Im found.
 
Join Date: Jun 2011
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 97 ford Expedition Overdrive not working

My 97 Ford Expedition Overdrive is not working, It was working ok then suddently it stop. The light on the shift does not come on, But the transmission is working ok and shifting into all its gears I noticed, when I push on the overdrive button nothing happens. Is there a fuse for the overdrive....Please help

Last edited by Ben RC; 07-02-2011 at 08:50 AM.
Ben RC is offline   Reply With Quote
Old 06-27-2011, 08:02 PM   #3
Senior Member
 
ANT2010KR's Avatar
 
Join Date: Sep 2010
Location: TX
Posts: 1,126
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Ben RC View Post
My 97 ford Expedition Overdrive is not working, It was working ok then suddently it stop. The light on the shift does not come on, But the transmission is working ok and shifting into all its gears I noticed, when I push on the overdrive button nothing happens. Is there a fuse for the overdrive....Please help
Maybe a bad switch, or shorted/broken wire coming from the switch. Pull the lower cover off the steering shroud andmake sure that the wires going to the shifter are intact.
__________________
" One morning I shot an elephant in my pajamas. How he got in my pajamas, I don't know."


USCG Retired, DAV
ANT2010KR is offline   Reply With Quote
Old 06-28-2011, 08:03 AM   #4
Lost but now Im found.
 
Join Date: Jun 2011
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by ANT2010KR View Post
Maybe a bad switch, or shorted/broken wire coming from the switch. Pull the lower cover off the steering shroud andmake sure that the wires going to the shifter are intact.

I will try that Thank You, But are there fuses do u know for the OD .THANK YOU
Ben RC is offline   Reply With Quote
Old 06-28-2011, 09:14 AM   #5
Senior Member
 
ANT2010KR's Avatar
 
Join Date: Sep 2010
Location: TX
Posts: 1,126
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Ben RC View Post
I will try that Thank You, But are there fuses do u know for the OD .THANK YOU

It might be fuse 29. At least that is what I'm seeing on a search.
__________________
" One morning I shot an elephant in my pajamas. How he got in my pajamas, I don't know."


USCG Retired, DAV
ANT2010KR is offline   Reply With Quote
Old 06-28-2011, 10:00 AM   #6
Senior Member
5 Year Member
 
Join Date: Feb 2008
Location: Henderson, NV.
Posts: 4,636
Mentioned: 0 Post(s)
Thanks: 0
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Default

If you find a blown fuse and it keeps blowing, here is an area that you might consider to look at. My OD off light was on all the time, the return wire from the light was grounding out where the lever bolted to the column. As I said my light was on all the time but the OD worked fine. Perhaps the live wire to the light is blowing your fuse.
__________________
Good old Bill
Good old Bill is offline   Reply With Quote
Old 06-28-2011, 10:00 AM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lights not working while turn signal is working @ trailer hitch connector hulmanite 1997 - 2003 Ford F150 4 01-16-2012 02:35 AM
Overdrive off button Stopped working! Phil93 1997 - 2003 Ford F150 8 07-01-2011 02:59 PM
Overdrive control not working CoachDion 1997 - 2003 Ford F150 2 06-27-2011 10:08 AM
Bulbs not working on window/sunroof/overdrive buttons hookntail 2004 - 2008 Ford F150 2 02-16-2010 03:04 AM
Overdrive Gtilli89 1997 - 2003 Ford F150 3 10-08-2009 03:29 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:11 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.