OBD won't read - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Log In 


OBD won't read

Reply
 
 
 
 
Thread Tools Search this Thread
Old 02-05-2009, 12:47 PM   #1
Junior Member
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default OBD won't read

Have a 2003 S'crew, 4.6L, 78k mi. Was told yesterday that my OBD port won't read. Checked the #3 20A fuse, it was okay. What else could be wrong? Searched the forum and couldn't find anything besides that, please forgive me if there's one I missed.
wbnethery3 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 02-07-2009, 01:19 PM   #2
Member
5 Year Member
 
Join Date: Nov 2008
Posts: 31
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

I have this trouble with my 04 Taurus. I can't seem to find out why either.
JimAbbett is offline   Reply With Quote
Old 02-08-2009, 11:40 AM   #3
Junior Member
 
Join Date: Feb 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I took my truck to AutoZone, where they do a free code check for CEL (Check Engine Light). Their reader worked fine, so I went to a different inspection station and they were able to connect just fine, I passed with no problems.

Turns out the first place I went had been having lots of Fords fail and eventually realized it was their machine that was the problem....not before it flagged every one of them to the state as failing the emissions inspection. You'd think they would have gotten a clue a little quicker. I even asked if they had tried on more than one machine. Moral of the story - don't trust just one person/shop to do your work, especially if it has $ implications.
wbnethery3 is offline   Reply With Quote
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 02:00 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.