My 5.4 Build - Page 53 - Ford F150 Forum - Community of Ford Truck Fans



My 5.4 Build

Reply
 
 
 
Thread Tools Search this Thread
Old 03-30-2014, 09:33 PM   #521
Senior Member
iTrader: (2)
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 8,192
Thanked 380 Times in 312 Posts
Default

Why does it have the backsplash looking bracket?
ibd2328 is offline   Reply With Quote
Old 03-30-2014, 09:38 PM   #522
4v > 2v
Thread Starter
 
MyFX4Project's Avatar
 
Join Date: Jan 2012
Location: Kansas
Posts: 4,972
Thanked 93 Times in 87 Posts
Default

Quote:
Originally Posted by ibd2328 View Post
Why does it have the backsplash looking bracket?
No not the 400 one lol its 129.99 on MMR. I got it for 89.99 on another site. But yeah idk what the purpose of thr backsplash/bracket thing is. Thats what I was hoping to hear from carcrazy or you. Might just grind it down so it stops making contact and call it good.
MyFX4Project is offline   Reply With Quote
Old 03-30-2014, 09:44 PM   #523
Senior Member
iTrader: (2)
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 8,192
Thanked 380 Times in 312 Posts
Default

Quote:
Originally Posted by MyFX4Project View Post
No not the 400 one lol its 129.99 on MMR. I got it for 89.99 on another site. But yeah idk what the purpose of thr backsplash/bracket thing is. Thats what I was hoping to hear from carcrazy or you. Might just grind it down so it stops making contact and call it good.
. Pick up a tube online. I wouldn't grind on that. Or just use one off a factory enginge.
ibd2328 is offline   Reply With Quote
Old 03-30-2014, 10:13 PM   #524
4v > 2v
Thread Starter
 
MyFX4Project's Avatar
 
Join Date: Jan 2012
Location: Kansas
Posts: 4,972
Thanked 93 Times in 87 Posts
Default

Quote:
Originally Posted by ibd2328 View Post
. Pick up a tube online. I wouldn't grind on that. Or just use one off a factory enginge.
Why not grind it down? It only needs like 3/8" to clear the crank.

I literally just threw my old tube away last week with all my pistons since I didnt need them, or so I thought lol
MyFX4Project is offline   Reply With Quote
Old 03-30-2014, 10:18 PM   #525
Senior Member
iTrader: (2)
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 8,192
Thanked 380 Times in 312 Posts
Default

Depending on how its attached, heating it up causes crazy changes in aluminum and steel.

I bet that tube was for the 6 bolt crank.
ibd2328 is offline   Reply With Quote
Old 03-30-2014, 10:19 PM   #526
Senior Member
iTrader: (2)
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 8,192
Thanked 380 Times in 312 Posts
Default

If the tube connects on the #8 stud fine and its just the back piece you can try it. I think I would just go back to factory for the pickup tube.
ibd2328 is offline   Reply With Quote
Old 03-30-2014, 10:36 PM   #527
4v > 2v
Thread Starter
 
MyFX4Project's Avatar
 
Join Date: Jan 2012
Location: Kansas
Posts: 4,972
Thanked 93 Times in 87 Posts
Default

Quote:
Originally Posted by ibd2328 View Post
Depending on how its attached, heating it up causes crazy changes in aluminum and steel.

I bet that tube was for the 6 bolt crank.
Ahh I forgot about 6 bolt cranks. That sounds right. Ill probably end up running by ford to get one. Got everything taped off for paint butnim gonna slap the oil pump and oil pan on and then tape that off before I paint the block. Just gonna do the sides and intake valley and keep my shiny chrome freeze plugs taped off too.
MyFX4Project is offline   Reply With Quote
Old 03-31-2014, 01:10 AM   #528
Senior Member
 
Join Date: Sep 2011
Posts: 7,188
Thanked 406 Times in 395 Posts
Default

Thats a Pick up for a 6 bolt crank. I would just cut the innerference off and not worry about it.
Carcrazygts2 is offline   Reply With Quote
Old 03-31-2014, 11:03 AM   #529
4v > 2v
Thread Starter
 
MyFX4Project's Avatar
 
Join Date: Jan 2012
Location: Kansas
Posts: 4,972
Thanked 93 Times in 87 Posts
Default

Even if its aluminum? My initial thought was to just grind it down some so it doesnt create contact and call her good. Makes sense to me sense everything else lines up.
MyFX4Project is offline   Reply With Quote
Old 03-31-2014, 11:11 AM   #530
Senior Member
 
fordmotorsport's Avatar
 
Join Date: Sep 2011
Posts: 1,733
Thanked 55 Times in 53 Posts
Default

Well it's all in where the pump pickup is in the pan..you have to use the f150 pan. I don't know where the pickup is in the navi pan but if I were you I would shave it like you said and run it because t will match to the f150 pan.
fordmotorsport is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New Member-Occasional loud tick on start up lippoby 2004 - 2008 Ford F150 4 10-21-2015 02:33 PM
Cylinder 1 missfire '02 5.4 Chevy luva 1997 - 2003 Ford F150 4 09-20-2015 11:57 AM
FRPP 4.6 intake on 5.4 f150 5450 2009 - 2014 Ford F150 1 09-14-2015 06:08 PM
5 lug to 6 lug conversion tech question Mallet 1997 - 2003 Ford F150 19 09-09-2015 08:46 PM
2000 5.4 leaking oil at crossover/Im Matthewb 1997 - 2003 Ford F150 0 09-05-2015 06:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:14 PM.


Copyright 2006 - 2016 F150Forum.com