lights flicker - Ford F150 Forum - Community of Ford Truck Fans



lights flicker

Reply
 
 
 
Thread Tools Search this Thread
Old 06-22-2011, 05:43 PM   #1
Senior Member
5 Year Member
Thread Starter
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default lights flicker

dash and outside lights flicker at idle. stops when givin gas. whats the problem?
phillip allan is offline   Reply With Quote
Old 06-22-2011, 06:58 PM   #2
Senior Member
 
Hollabakzach23's Avatar
 
Join Date: Feb 2011
Location: Indiana
Posts: 1,098
Thanked 31 Times in 30 Posts
Default

Alternator or battery maybe??
Hollabakzach23 is offline   Reply With Quote
Old 06-24-2011, 12:24 PM   #3
Senior Member
5 Year Member
Thread Starter
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default

idk. i never have a problem with the charging system and the batt terminals ar good and clean. i think maybe the cables may b bad.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:30 PM   #4
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Thanked 1 Time in 1 Post
Default

How many miles?
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:34 PM   #5
Senior Member
5 Year Member
Thread Starter
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default

235000
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:37 PM   #6
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Thanked 1 Time in 1 Post
Default

Take it to an auto parts store and they can test the battery and charging system, with that many miles it could be the alternator.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:46 PM   #7
Senior Member
5 Year Member
Thread Starter
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ive replaced the alternator 3 times within 135000 miles. its been a year in a half since the last time.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:49 PM   #8
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Thanked 1 Time in 1 Post
Default

Internal corrosion near the battery connectors in the cable can cause the same issues.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:53 PM   #9
Senior Member
5 Year Member
Thread Starter
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ive cleaned them up and put some protectant spray on it.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 01:26 PM   #10
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Thanked 1 Time in 1 Post
Default

The corrosion can creep further down into the cable, and also where it joins the connector, you can't see it unless you peel the insulation back.
AFSOCSGT is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Incredibly bright Led Mirror Puddle Lights Burke484 Lighting 16 10-19-2016 12:46 AM
Rear lights don't work when lights are on. readyoarnot Electrical 4 02-09-2016 06:29 PM
Southeast: Sct x3 SC_Titan 2009 - 2014 Part Sales 12 09-19-2015 09:59 PM
Southeast: Sct x3 SC_Titan General F150 Items 2 09-16-2015 10:34 PM
LED Bulbs Flickering Chris 1997 - 2003 Ford F150 2 09-09-2015 11:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:26 PM.


Copyright 2006 - 2016 F150Forum.com