Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-22-2011, 05:43 PM   #1
Senior Member
5 Year Member
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 132
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default lights flicker

dash and outside lights flicker at idle. stops when givin gas. whats the problem?
phillip allan is offline   Reply With Quote
Old 06-22-2011, 06:58 PM   #2
Senior Member
 
Hollabakzach23's Avatar
 
Join Date: Feb 2011
Location: Indiana
Posts: 978
Mentioned: 0 Post(s)
Thanked 21 Times in 21 Posts
Feedback Score: 0 reviews
Default

Alternator or battery maybe??
Hollabakzach23 is online now   Reply With Quote
Old 06-24-2011, 12:24 PM   #3
Senior Member
5 Year Member
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 132
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

idk. i never have a problem with the charging system and the batt terminals ar good and clean. i think maybe the cables may b bad.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:30 PM   #4
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

How many miles?
__________________


Originally Posted by obusnizzle dont touch it and play with it, just drive the truck, try not to overthink it.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:34 PM   #5
Senior Member
5 Year Member
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 132
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

235000
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:37 PM   #6
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Take it to an auto parts store and they can test the battery and charging system, with that many miles it could be the alternator.
__________________


Originally Posted by obusnizzle dont touch it and play with it, just drive the truck, try not to overthink it.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:46 PM   #7
Senior Member
5 Year Member
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 132
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

ive replaced the alternator 3 times within 135000 miles. its been a year in a half since the last time.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 12:49 PM   #8
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Internal corrosion near the battery connectors in the cable can cause the same issues.
__________________


Originally Posted by obusnizzle dont touch it and play with it, just drive the truck, try not to overthink it.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 12:53 PM   #9
Senior Member
5 Year Member
 
phillip allan's Avatar
 
Join Date: Mar 2009
Location: Crestview, FL.
Posts: 132
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

ive cleaned them up and put some protectant spray on it.
phillip allan is offline   Reply With Quote
Old 06-24-2011, 01:26 PM   #10
Kill em all
 
AFSOCSGT's Avatar
 
Join Date: Sep 2010
Location: Navarre FL
Posts: 1,735
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

The corrosion can creep further down into the cable, and also where it joins the connector, you can't see it unless you peel the insulation back.
__________________


Originally Posted by obusnizzle dont touch it and play with it, just drive the truck, try not to overthink it.
AFSOCSGT is offline   Reply With Quote
Old 06-24-2011, 01:26 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
HID Flicker + Wrong Bulb For Fogs ChrisC 2004 - 2008 Ford F150 8 02-27-2011 01:22 PM
HID Flicker Clemson Fx4 2004 - 2008 Ford F150 7 02-27-2011 12:36 AM
Lights flicker when truck is running phillip allan 1997 - 2003 Ford F150 0 01-05-2011 12:49 PM
HID's flicker with turn signal - Anyone ever seen this? XPerties Lighting 0 12-09-2009 10:04 PM
HID flicker 04FX4GUY 2004 - 2008 Ford F150 8 11-13-2009 11:48 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 10:04 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.