Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-26-2011, 12:41 PM   #1
Member
 
mself52's Avatar
 
Join Date: Aug 2011
Location: Athens, GA
Posts: 68
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Gas Cap Issues?

Im sorry to post such a question hat will prolly be noobish but i have been searching and havnt found a thread about it....

first problem:

i bought 1998 f-150 xlt 4.6L 2wd about a month ago i drove it for about 30 mins and the check engine light came on... i drove to advanced auto and they checked it and said it was the gas cap well he took off the cap and put it back on and used the programmer to clear the code... went fine for rest of the day then next day the light came on again so i drove it for 2 days with the light on cuz of work then went to O'rielys and they said the same thing cleared the code and it went away for a day and now its back on again.... the gas cap seems to be brand new and its not a screw on cap you just push it in and twist half a turn and its locked in... has anyone had this before is there something besides the gas cap that could be doing this or should i just buy a new cap anyway....

2nd problem:

Problem with the wiper control arm... sometimes when i turn the wipers to the slower speeds it wont come on till i get halfway thru the settings to medium/high speed... also to get the washer to spray out i have to push the cap i 10-15 times to get it to spray washer fluid on the window.. i believe that arm has a short in it or something is it hard to remove and replace?

thanks in advance for your help and sorry to waste anyones time if this question has been discussed before i swear i searched first...
mself52 is offline   Reply With Quote
Old 08-26-2011, 12:58 PM   #2
Senior Member
 
Join Date: Aug 2011
Location: Kokomo, IN
Posts: 104
Mentioned: 1 Post(s)
Thanks: 2
Thanked 14 Times in 5 Posts
Feedback Score: 0 reviews
Default

This helped me when I had your 2nd problem.....

http://www.fordf150.net/howto/fix-in...er-problem.php


Hopefully the others can help with your gas cap issue.....See here

http://www.obd-codes.com/p0455

Last edited by RaptoRx7; 08-26-2011 at 01:01 PM.
RaptoRx7 is offline   Reply With Quote
Old 08-26-2011, 01:39 PM   #3
Member
 
mself52's Avatar
 
Join Date: Aug 2011
Location: Athens, GA
Posts: 68
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

wow thanks so much that wiper writeup is perfect i will try that you rock
mself52 is offline   Reply With Quote
Old 08-26-2011, 01:57 PM   #4
Senior Member
 
Join Date: Aug 2011
Location: Kokomo, IN
Posts: 104
Mentioned: 1 Post(s)
Thanks: 2
Thanked 14 Times in 5 Posts
Feedback Score: 0 reviews
Default

Keep us posted on your progress....
RaptoRx7 is offline   Reply With Quote
Old 08-26-2011, 02:06 PM   #5
Senior Member
 
Join Date: Mar 2011
Location: Austin, TX
Posts: 460
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

does your gas cap have a lock on it?
Javi_F-150 is offline   Reply With Quote
Old 08-26-2011, 03:18 PM   #6
Senior Member
 
rbrais's Avatar
 
Join Date: Aug 2011
Location: CT
Posts: 2,585
Mentioned: 3 Post(s)
Thanks: 35
Thanked 79 Times in 74 Posts
Feedback Score: 0 reviews
Default

The gas cap could be defective or your filler tube might be rotted causing a pressure leak. My Ranger has that problem. Just got a new filler tube online for about $100.00. It's over $400 from Ford.
rbrais is offline   Reply With Quote
Old 08-26-2011, 03:44 PM   #7
Senior Member
 
Join Date: Jun 2010
Location: Florida, USA
Posts: 1,116
Mentioned: 0 Post(s)
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Default

I had a filler tube problem also on my Ford van, it is not real expensive to replace and is easy. They rot and get brittle and develop cracks like rbrais said. You can also check the gasket on the inside of the gas cap to see if it is damaged.
I doubt it is the gas cap if it feels like it seals when twist it.
1/4 turn is correct for the cap.
pickupsrule is offline   Reply With Quote
Old 08-26-2011, 08:22 PM   #8
Senior Member
 
DevinS's Avatar
 
Join Date: Jul 2011
Location: Grand Junction, CO
Posts: 368
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by RaptoRx7 View Post
This helped me when I had your 2nd problem.....

http://www.fordf150.net/howto/fix-in...er-problem.php


Hopefully the others can help with your gas cap issue.....See here

http://www.obd-codes.com/p0455
Wish I'd found that write up when I still had my 97 Town car because it was having the same issues with the wipers... I knew it was in the multi-function switch, but I didn't have the b@//s to try to fix it, LMAO! Oh well... I traded it in for my F150, so alls well that ends well! HAHA!
DevinS is offline   Reply With Quote
Old 08-26-2011, 08:26 PM   #9
call me Randy
 
2000MTZ's Avatar
 
Join Date: Nov 2010
Location: Salisbury, NC
Posts: 6,487
Mentioned: 0 Post(s)
Thanks: 4
Thanked 146 Times in 121 Posts
Feedback Score: 1 reviews
Default

get a new non locking gas cap, with some of the locking ones it will cause the check engine light to come on for some reason, this happened on my grandpas 97, he put a non locking one on and the light went off. strange
2000MTZ is offline   Reply With Quote
Old 08-26-2011, 08:26 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC issues 609boy 2009 - Present Ford F150 7 05-19-2011 06:45 AM
pre issues Robuilt 1987 - 1996 F150 0 04-08-2011 03:07 PM
07 5.4 VCT issues help!!! tim_040878 2004 - 2008 Ford F150 1 01-18-2011 01:51 PM
4.2L Issues zap General F150 Discussion 0 07-31-2010 01:30 PM
three issues outboardmike 1987 - 1996 F150 0 02-23-2010 11:32 PM

 

The Mustang Source

All times are GMT -4. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.