Engine Builders talk. - Page 169 - Ford F150 Forum - Community of Ford Truck Fans



Engine Builders talk.

Reply
 
 
 
Thread Tools Search this Thread
Old 07-10-2014, 09:03 PM   #1681
Senior Member
5 Year Member
 
4x4dave's Avatar
 
Join Date: Jan 2011
Location: CO
Posts: 1,077
Thanked 64 Times in 63 Posts
Default

[MENTION=141720]Z7What[/MENTION] nice work on porting that plenum. Looks better than mine.

You melted a hole in your piston?? How did you manage to do that? Do you recall any of your tempatures, was it detonation, or pure heat? Curious to hear more. I can hit 15# on a cool night. Yikes lol
4x4dave is offline   Reply With Quote
Old 07-10-2014, 09:57 PM   #1682
Senior Member
 
Jackedup00's Avatar
 
Join Date: May 2013
Posts: 19,544
Thanked 223 Times in 196 Posts
Default

What would be a good set of long tubes that won't set me back much? They're just to get by for now,I wanna go ahead and get a pair for when I drop the motor in
Jackedup00 is online now   Reply With Quote
Old 07-10-2014, 10:11 PM   #1683
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 5,434
Thanked 627 Times in 541 Posts
Default

I honestly don't know man. Here's the story.

One 50* Friday night at the track I ran my PB of 14.56@91MPH while spinning. Heard a little detonation so called it a night and drove home.

Called a friend up with a exact copy of my truck and told him how much fun I had. Changed the plugs during the week and don't so much signs f detonation. We decided to go the following Friday. It was 40* this night. I added 5 gallons of Sunoco 104(IIRC) to the tank and ran twice. But had problems spinning at half track, yes half track I was spinning 38"s! Even told a official that there most be oil on the track. They looked and there wasn't any. 3 run I heated the tires up extra, staged and was pulling strong all the way through the traps. When I backed off the exhaust note was different, looked behind me and there was a cloud.

So I parked it and went and sat with my GF and his wife while he ran a few more times. I sat next the the GF and said "if I hurt the motor there goes your engagement ring"

Drove it 40miles home and found #2 had a hole. Less than 2 months later was running again with the L motor. :-D

What was the cause? Tune? Injector? I really don't know!

Sal @ PSP personally dyno tuned it. I drove 1300miles round trip to have him tune it. After the dyno he test drove it and it detonated some. He adjusted tune and was fine after. He was one of the best L tuners in the country. Even started NLOC! Was he used to tuning big *** trucks? No, so it's possible that the loads were different and timing to high. Also I believe at the time of tuning it had straight gas. Shortly after being tuned is when a lot of places started going to E10. Which has a different stoich factor and runs a little leaner.

Later found out that the Sunoco race fuel also had Ethanol In it which change my stoich even more. So that could be it.

I monitored MAF counts and although they did get closed to being maxed out it never.

Guess I will never know 100% what happen.

Let me find some pics.

Wayne
Z7What is offline   Reply With Quote
Old 07-10-2014, 10:19 PM   #1684
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 5,434
Thanked 627 Times in 541 Posts
Default

I had had plenty issues with detonation before and I guess now that I think if it tune was prolly the cause. Due to tuner not knowing the huge amount of load the 38"s put in the motor. When taking motor apart heads showed a lot of sign of having detonation for a long time so I guess i just pushed it to hard at the track.

Melded piston!
Engine Builders talk.-image-4005576297.jpg Engine Builders talk.-image-2645428413.jpg

Putting new L motor in. Removed old, installed new and was driving down the street in 9hrs goin to parts store twice and eatting one. I did have a lot of the long block stripped down before we started thou.

Engine Builders talk.-image-777413938.jpg

Had to put stock tires on and flatten them in order to get the truck low enough to get the engine over the grill.

Wayne
Z7What is offline   Reply With Quote
Old 07-10-2014, 10:30 PM   #1685
Senior Member
 
Jackedup00's Avatar
 
Join Date: May 2013
Posts: 19,544
Thanked 223 Times in 196 Posts
Default

Quote:
Originally Posted by Z7What View Post
I had had plenty issues with detonation before and I guess now that I think if it tune was prolly the cause. Due to tuner not knowing the huge amount of load the 38"s put in the motor. When taking motor apart heads showed a lot of sign of having detonation for a long time so I guess i just pushed it to hard at the track.

Melded piston!


Putting new L motor in. Removed old, installed new and was driving down the street in 9hrs goin to parts store twice and eatting one. I did have a lot of the long block stripped down before we started thou.

Had to put stock tires on and flatten them in order to get the truck low enough to get the engine over the grill.

Wayne
9 hours? That's some quick work!
Jackedup00 is online now   Reply With Quote
Old 07-10-2014, 10:43 PM   #1686
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 5,434
Thanked 627 Times in 541 Posts
Default

Yeah me and the other guy in the pic both had L powered supercrews on 38"s. He was the guy with me at the track. We both have done plenty work on them to know what's what and worked great together.

When he got to my house the long block I had already stripped down. Just had to undo exhaust, TC, tranny and motor mounts. But still yeah real fast! The 3" body lift helped a lot too?

Wayne
Z7What is offline   Reply With Quote
Old 07-10-2014, 11:23 PM   #1687
Senior Member
iTrader: (2)
 
ibd2328's Avatar
 
Join Date: Mar 2012
Posts: 8,192
Thanked 380 Times in 312 Posts
Default

Nice work wayne. That was quick!!

I don't have a lift, but it was still tough to get the cherry picker in there. I pulled the tires off.
ibd2328 is offline   Reply With Quote
Old 07-10-2014, 11:30 PM   #1688
Senior Member
5 Year Member
 
charliedyal's Avatar
 
Join Date: May 2009
Location: Tallahassee, Fl
Posts: 2,926
Thanked 142 Times in 133 Posts
Default

Quote:
Originally Posted by Z7What View Post
Yeah me and the other guy in the pic both had L powered supercrews on 38"s. He was the guy with me at the track. We both have done plenty work on them to know what's what and worked great together.

When he got to my house the long block I had already stripped down. Just had to undo exhaust, TC, tranny and motor mounts. But still yeah real fast! The 3" body lift helped a lot too?

Wayne
Talk about turn around time. Speedy Gonzalez over here. I had to air down the tires too. Had about 2"s clearance to get it over the top.
charliedyal is offline   Reply With Quote
Old 07-11-2014, 02:52 AM   #1689
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 5,434
Thanked 627 Times in 541 Posts
Default

Quote:
Originally Posted by charliedyal View Post
Talk about turn around time. Speedy Gonzalez over here. I had to air down the tires too. Had about 2"s clearance to get it over the top.
When you are under the hood a few times a week modding things it really all becomes second nature. The L/HD motor is so easy to me, that's why I enjoy my side job, modding and repairing L/HDs. Has paid for every mod on my truck!

Wayne
Z7What is offline   Reply With Quote
Old 07-11-2014, 10:33 AM   #1690
Senior Member
5 Year Member
 
charliedyal's Avatar
 
Join Date: May 2009
Location: Tallahassee, Fl
Posts: 2,926
Thanked 142 Times in 133 Posts
Default

Any recommendations on an oil filter relocation kit? Tired of saturating my front diff every time I change the oil. The drop brackets from the lift are preventing me from getting a funnel close enough to catch anything. I can see the benefit of keeping everything lubricated, but this is ridiculous. LOL. Checking out several kits on JEGS, Summit, ebay, etc.. what works for y'all?
charliedyal is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
F-250 vs f-150 6.2 engine?? Blackpony 2009 - 2014 Ford F150 53 06-04-2016 12:47 AM
Changed vct solenoids at 151k engine tick went away redfishtd 2004 - 2008 Ford F150 21 12-31-2015 12:25 AM
INTAKE MANIFOLD GASKET FAILURE 2008 Ford F150 Crew cab 4X4 4.6 litre Pipercub1 2004 - 2008 Ford F150 0 09-12-2015 05:00 PM
FS: Ford 4.0 V6 Engine sohc 02-05 vin E $1,400 mzmzmz General F150 Discussion 0 09-12-2015 01:55 PM
FREE SHIPPING ALL WEEKEND ON CATCH CAN KITS 9/11 - 9/13 Come on by... RX Speed Works Vendor Showcase 0 09-11-2015 05:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:56 AM.


Copyright 2006 - 2016 F150Forum.com