Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-12-2012, 05:40 PM   #1
Member
 
Join Date: Oct 2010
Location: spring hill fl
Posts: 32
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Coolant Leak :(

yesterday afternoon i noticed a coolant smell coming out of my air vents and today when i got off work there was a big puddle on the passenger side of my truck, i crawled under and couldnt see where it was coming from, i think its the heater core but not sure. passenger carpet is dry and i dont have any leaks in the cab that i can see. anyone know where to start looking? my truck is a 98 4.6 4x4 any help would be very much appreciated
dreweeee is offline   Reply With Quote
Old 10-12-2012, 10:30 PM   #2
Senior Member
 
98-f150-kid's Avatar
 
Join Date: Aug 2011
Location: shelbyville mi
Posts: 448
Mentioned: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

maybe check the heater hoses
__________________
1998 f150 xlt,ext cab,4.6,with 3in body lift,3 in suspension lift,17in American racing rims with 37's,
1995 f150 xlt,ext cab,5.0 6in suspension lift,35's and lots more
1995 f150 xlt,reg cab,5.0 2.5in suspension lift,3in body lift,33's
98-f150-kid is offline   Reply With Quote
Old 10-12-2012, 10:40 PM   #3
Senior Member
 
JCP281's Avatar
 
Join Date: Sep 2010
Location: Texas
Posts: 516
Mentioned: 0 Post(s)
Thanks: 1
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Default

Do a pressure test, you will find your leak in a hurry.
__________________
2002 F150 SuperCrew Lariat FX4-SOLD

2012 F150 SuperCrew XTL 4X4
JCP281 is offline   Reply With Quote
Old 10-13-2012, 03:32 AM   #4
Senior Member
 
Join Date: Apr 2012
Location: Germany
Posts: 141
Mentioned: 0 Post(s)
Thanks: 19
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Default

Exactly the same symptoms, it was for me too. With me was the Heater Core broken. Put your vent on COLD, Ride a bit, and then look if you have water under the car .

Last edited by samok; 10-13-2012 at 03:35 AM.
samok is offline   Reply With Quote
Old 10-13-2012, 03:32 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 05:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.