Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-17-2012, 04:02 PM   #1
Junior Member
 
Msufan's Avatar
 
Join Date: Jan 2012
Location: Michigan
Posts: 6
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 4.6l slight rough idle

Hello everyone, new to the forum and I have found tons of great information! Bought a 2003 F150 Supercab XLT back in 2010 and after a couple of weeks I noticed a slight rough idle after the truck would warm up.

Well a couple months later it threw a check engine light and one of the cylinders had a misfire. Well all the plugs and coil packs were changed and it still had that rough idle. I then had a fuel system treatment done (was skeptical of the treatment even doing anything) and I noticed a slight improvement.

I have checked the PCV valve, checked for vacuum leaks and cleaned the MAF sensor. My mechanic who I have known for years and is very reputable in the community says he thinks it idles fine.

I found a ford service bulletin (01-24-8) that talks about feeling a shaking in the cab on certain trucks that have the seat belts integrated into the seats and they say its normal.

I have searched the forum and found some similar issues but not quite the same. Is there anybody with the same problem? Anything else I can check?

It is just a slight shake (more pronounced when in drive) but it bugs me like crazy. I take pride in my vehicles and want them to operate as they should. Sorry for the long post but I am looking for answers or to see if anybody else is in the same boat. Thanks!!

Last edited by Msufan; 01-17-2012 at 05:01 PM.
Msufan is offline   Reply With Quote
Old 01-17-2012, 11:20 PM   #2
Senior Member
 
Join Date: Apr 2010
Location: Oregon
Posts: 155
Mentioned: 0 Post(s)
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Default rough idle

Sounds like the throttle body needs to be cleaned. Remove air intake tube, soak a clean cloth in WD-40 (or?) and clean all around the butterfly.
Good luck.



'97 4.6 scab 2wd, 205,000 good miles.
j.low is offline   Reply With Quote
Old 01-18-2012, 10:17 AM   #3
Junior Member
 
Msufan's Avatar
 
Join Date: Jan 2012
Location: Michigan
Posts: 6
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I was looking after I posted and that thought came to me as well about cleaning the throttle body. I will have to give that a try. I really like the truck so far other then the idle.

After looking on this forum for a while I have found a lot of mods to spend more of my money on lol. Just ordered a super 44 Flowmaster today, been wanting that for a while, next is either a cai or a gotts mod and a new radio and speakers.
Msufan is offline   Reply With Quote
Old 01-18-2012, 02:33 PM   #4
Senior Member
 
97offroad4.6l4x4's Avatar
 
Join Date: Jul 2011
Location: cincinnati ohio
Posts: 103
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

had the same thing. oxygen sensors. the ones closest to the manifold.
97offroad4.6l4x4 is offline   Reply With Quote
Old 01-18-2012, 03:16 PM   #5
Junior Member
 
Msufan's Avatar
 
Join Date: Jan 2012
Location: Michigan
Posts: 6
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I cleaned the throttle body today and it didn't seem to do much. Did your truck throw a code for the O2 sensors or was it a matter lets try this and see what happens? Also did you do them yourself and if so how much were they and how easy are they to get to?

Last edited by Msufan; 01-18-2012 at 03:34 PM.
Msufan is offline   Reply With Quote
Old 01-18-2012, 03:54 PM   #6
Senior Member
 
97offroad4.6l4x4's Avatar
 
Join Date: Jul 2011
Location: cincinnati ohio
Posts: 103
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

It threw the code but there real cheap and worth replacing. Woth a tool its easy but i couldnt get it with a wrench. Had my mech do it
97offroad4.6l4x4 is offline   Reply With Quote
Old 01-18-2012, 03:54 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle, slight hesitation on take off bikeymikey 1987 - 1996 F150 3 11-17-2011 10:53 PM
slight vibration at idle JwS 4.6 1997 - 2003 Ford F150 0 10-08-2010 12:08 AM
Rough Idle, Ticking Slight Miss! What is Wrong? dukester544600 2004 - 2008 Ford F150 6 10-15-2009 11:01 PM
Rough idle, ticking sound, slight miss! What is wrong? dukester544600 General F150 Discussion 0 10-06-2009 09:23 AM
slight hesitation and slightly rough idle when warm rickbert 1987 - 1996 F150 3 04-05-2009 03:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 11:11 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.