4.2 problems - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Log In 


4.2 problems

Reply
 
 
 
 
Thread Tools Search this Thread
Old 09-02-2015, 06:34 PM   #1
Junior Member
 
Join Date: Nov 2014
Location: south Texas
Posts: 20
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 4.2 problems

i have a 1999 4.2 with 211k miles, 2wd and auto tranny, yesterday on the freeway it downshifted and i felt a big clunk and it shifted like this 3 total times, i don't know what caused this or what it means, never had any problems with the tranny before,
another thing is sometimes it takes a bit longer to start and then it idles poorly but goes back to normal, i have sea foamed the intake, cleaned the mass air flow and idle air control, and that fixed the problem for about 2 weeks, dont know what t do about that either.
any help is appreciated
mjs757 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old Yesterday, 03:20 PM   #2
Senior Member
 
SICKS NINE's Avatar
 
Join Date: Mar 2011
Location: Raleigh, North Carolina
Posts: 153
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by mjs757 View Post
i have a 1999 4.2 with 211k miles, 2wd and auto tranny, yesterday on the freeway it downshifted and i felt a big clunk and it shifted like this 3 total times, i don't know what caused this or what it means, never had any problems with the tranny before,
another thing is sometimes it takes a bit longer to start and then it idles poorly but goes back to normal, i have sea foamed the intake, cleaned the mass air flow and idle air control, and that fixed the problem for about 2 weeks, dont know what t do about that either.
any help is appreciated
I'm not a transmission guy, so I'm no help there...

As far as the the idle: When's the last time you checked your fuel delivery? I had some similar issues and I ended up replacing fuel pump, fuel filter, fuel pressure regulator and my baby ran a whole lot better and I didn't have any stalling issues.
__________________
"Little Truck" 1999 F-150 4.2l 4x4 5speed regular cab. (133k mi)

"Big Truck" 2001 F-150 5.4l 4x4 Lariat Supercrew. (127k mi)
SICKS NINE is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor call quality? ebrouwer 2015 Ford F150 9 Yesterday 09:27 AM
dies at idle rpm, need help bad! betty_white 2004 - 2008 Ford F150 5 Yesterday 09:08 AM
Starting issues dmummy Maintenance Shop 1 09-02-2015 08:25 AM
Starting issues dmummy Maintenance Shop 0 09-01-2015 11:27 PM
Clunk in shift from 2nd to 1st for 2010 4x4 segen77 2009 - 2014 Ford F150 5 09-01-2015 11:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 06:36 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.