Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 1997 - 2003 Ford F150
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-02-2009, 12:33 PM   #1
Junior Member
 
Join Date: Jul 2009
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 1997 f150 w/5.4 triton runs rough under load

I have a 97 F150 with 5.4 Triton. It only has 75,000 miles and has been serviced regularly. A few months ago it started running rough while driving and also at stop lights it would idle up & down. I replaced the MAF sensor and the idle up & down stopped, however I still have hesitation and roughness under load (accelerating, uphill, etc.). It never threw an engine code until I pulled my boat. I had it scanned and the code was P1131 (insufficient mixture, O2s 1/1, lean. I thought maybe I forgot to erase the old code after the MAF sensor replacement, so I disconeced the battery and cleared this code. It still runs rough under load. I have checked the air filter/canister for debris, all vacuum lines & O2 sensor and all is fine. Someone mentioned a bad coil pack, but said that will always throw a misfire code, which I don't have.

Any help would be great. I fear towing my boat since it runs so much worse under that load. I would hate to get stuck on the boat ramp and not able to pull out of the water!!!

PLEASE HELP!!!!!!!!!!!!!!!!!
DKOTLAREK is offline   Reply With Quote
Old 07-02-2009, 12:33 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Runs a little rough bigern26 1987 - 1996 F150 11 05-28-2009 05:47 PM
runs rough suddenly forroy9 1987 - 1996 F150 2 01-15-2009 08:26 PM
major rough idle, under load, no codes? cole_ford 1997 - 2003 Ford F150 2 11-22-2008 10:42 PM
Runs fine idleing but runs like crap under load Wallace6400 1987 - 1996 F150 23 08-21-2008 01:22 PM
1997 f150 hesitating under low load terry Introductions 2 08-03-2007 10:27 AM

 

The Mustang Source

All times are GMT -4. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.