Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-06-2012, 06:00 PM   #1
Junior Member
 
Join Date: Oct 2012
Posts: 9
Mentioned: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Need Help ASAP Battery Issue

I have had my truck 3 days now and I can't figure out whats going on. The first night i drove it home I had to jump it about 4 hours later. Well it has a brake controller and i figured it was that so i unplugged it and ran 2 days no problem. But then tonight i was replacing the "amazing factory speakers" that ford puts in these and i had the radio on very low, no lights on (besides dome light) for about 30 minutes. Then i went to start it and cranked once, gauges started hopping and radio reset itself and went to am radio and truck didnt start, battery dead now, but dome lights and everything else works. It has a 6 cd changer (factory) and i know it has some issues. The dealer is replacing it. But it dosent make since to me whats going on with it. I've left a radio on with an amp pulling juice for over an hour and never had a problem like this. Wanting to know if anyone has ever had this issue either. Thank you very much!
DJEM2010 is offline   Reply With Quote
Old 10-06-2012, 06:58 PM   #2
Custom Enthusiast
 
TxCustoms89's Avatar
 
Join Date: Mar 2012
Location: Texas
Posts: 1,091
Mentioned: 0 Post(s)
Thanks: 2
Thanked 12 Times in 12 Posts
Feedback Score: 1 reviews
Default

Could be alternator not recharging battery or just a bad battery but those would be my first two tests
TxCustoms89 is offline   Reply With Quote
Old 10-06-2012, 07:01 PM   #3
Senior Member
 
Join Date: Jul 2011
Location: Tonopah. AZ.
Posts: 2,215
Mentioned: 1 Post(s)
Thanks: 38
Thanked 187 Times in 126 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by TxCustoms89 View Post
Could be alternator not recharging battery or just a bad battery but those would be my first two tests
^^^+1
bubbabud is offline   Reply With Quote
Old 10-07-2012, 05:37 AM   #4
Senior Member
 
Join Date: Jul 2011
Posts: 308
Mentioned: 0 Post(s)
Thanks: 0
Thanked 17 Times in 17 Posts
Feedback Score: 0 reviews
Default

Bad cell or weak alternator as stated.
lariatboy is offline   Reply With Quote
Old 10-07-2012, 05:37 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.