Low oil pressure and engine shut down - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Log In 


Low oil pressure and engine shut down

Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-10-2008, 07:55 PM   #1
Senior Member
 
eacdabnow's Avatar
 
Join Date: Aug 2007
Location: Virginia Beach, VA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Low oil pressure and engine shut down

Today while driving the truck just shut off while at a light and it said low oil pressure on the dash read out. It started back up and did it again at another light. Its a 2004 5.4 with 50,000 miles . any ideas? The check engine light is now on too. HELP!
eacdabnow is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 05-11-2008, 08:09 AM   #2
Senior Member
 
HarmsWay's Avatar
 
Join Date: Jan 2008
Location: NJ
Posts: 231
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Talking

um...check the oil.
__________________
'04 FX4 Yellow S-cab flareside & loaded. Let's just say the mod bug bit me & I bit back...Just need the tunner and some tunes and maybe some wheels...
HarmsWay is offline   Reply With Quote
Old 05-11-2008, 10:02 AM   #3
KAC Shooter
5 Year Member
 
Join Date: May 2007
Location: West Palm Beach, FL
Posts: 3,617
Thanks: 0
Thanked 44 Times in 39 Posts
Feedback Score: 0 reviews
Default

the PCM does not read oil pressure, the gauge on the dash is just an idiot sensor. Most likely, the sender needs to be replaced, which is somewhat odd for the low amount of miles the truck has. Start with the simple stuff, get the code read, and replace the sensor. Also, throw the post up on flatratetech.com and see what they say before taking it to the dealership if you so desire. Does the motor make any noise that it shouldnt be making when you started it back up?
__________________
2013 Ecoboost Black on Black FX2 SCREW
2007 Black on Black SCAB sold 14 Sept 13
1996 Thunderbird LX 14.17@98mph sold 13 Oct 12
Booyah. Stu Scott.
obusnizzle is offline   Reply With Quote
Old 05-11-2008, 11:17 AM   #4
Senior Member
 
eacdabnow's Avatar
 
Join Date: Aug 2007
Location: Virginia Beach, VA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

No funny noises when it was started back up.
eacdabnow is offline   Reply With Quote
Old 05-11-2008, 07:57 PM   #5
PM me to run your VIN
5 Year Member
 
Join Date: Oct 2007
Location: Uppityburgh, FL
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to RoyLPita
Default

Possible throttle body issue?
__________________
I have a 300B MM
I am dreaming of S/C'ing a 2004 and up 5.4 3V F150 with a Trilogy kit.
RoyLPita is offline   Reply With Quote
Old 05-11-2008, 08:00 PM   #6
Junior Member
5 Year Member
 
Join Date: Oct 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Your problem is probably related to the Check Engine. It would be completely normal for the Low Oil Pressure light to be on after the engine dies.

Get the ECU scanned and go from there.
Mach825 is offline   Reply With Quote
Old 11-23-2014, 06:53 PM   #7
Junior Member
 
Join Date: Nov 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2014 Raptor

Quote:
Originally Posted by eacdabnow View Post
Today while driving the truck just shut off while at a light and it said low oil pressure on the dash read out. It started back up and did it again at another light. Its a 2004 5.4 with 50,000 miles . any ideas? The check engine light is now on too. HELP!
My raptor has 4000 miles on it and it shut down while I was drivkng 30mph and the low oil pressure light came on. Coasted to a parking lot and tried starting it up again and it did and it ran fine. Oil was dead on and I pulled out my code reader and no codes or history codes. Weird.. Tarted driving and I noticed there was no sound to my radio or nav. Parked the truck for 1 hour and the radio worked. Anyone have this problem??
Bryan Cook is offline   Reply With Quote
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 06:21 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.