Heater problems - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Log In 


Heater problems

Reply
 
 
 
Thread Tools Search this Thread
Old 12-06-2009, 09:45 AM   #1
Junior Member
5 Year Member
 
Join Date: Dec 2009
Location: florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Heater problems

I have a F-150 King Ranch with a heater problem,there is no heat, the blower works, the tempture indicator works, the eng indicate normal. Is there a relay I can't see this as being a fuse problem
cameron is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 12-06-2009, 10:39 AM   #2
FLARESIDE MAN !!!
 
seniorFORDtech's Avatar
 
Join Date: Nov 2009
Location: chicago il
Posts: 287
Thanks: 0
Thanked 0 Times in 0 Posts
Default

if your concern is no tempature change, you most likely have a bad blend door motor this has been a problem for a lot of f150's the blend door motor is mounted behind the radio on top of the heater box, sounds easy, but the screws are not easily accessed also u must line the motor up with the door,the key must be in the off postion...
seniorFORDtech is offline   Reply With Quote
Old 12-07-2009, 01:36 AM   #3
Junior Member
5 Year Member
 
Join Date: Dec 2009
Location: florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default heater

Thanks for the info I check it out. Today it was working ok I hope it not going to be one of those that works when it feel like it
cameron is offline   Reply With Quote
Old 12-07-2009, 08:20 PM   #4
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?
D MAN is offline   Reply With Quote
Old 12-07-2009, 08:22 PM   #5
FLARESIDE MAN !!!
 
seniorFORDtech's Avatar
 
Join Date: Nov 2009
Location: chicago il
Posts: 287
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by D MAN View Post
Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?

it will work intermittantly still would check it out..
seniorFORDtech is offline   Reply With Quote
Old 12-07-2009, 08:28 PM   #6
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 8,824
Thanked 331 Times in 272 Posts
Default

Quote:
Originally Posted by D MAN View Post
Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?
You answered your own question pertaining to the thermostat...if the engine temp gauge is showing a normal temp, then the thermostat is working.

Blend door or auto climate box (if equipped). You did not tell us your model; the crystal ball is in the shop right now.
__________________
"Never argue with an idiot; they'll only drag you down to their level, then beat you with experience"

2007 F150 STX Supercab (4.6 2V V8), Edge tuner, factory navigation, Mark VIII electric fan conversion with flex-o-lite controller.

Last edited by Bucko; 12-07-2009 at 08:30 PM.
Bucko is offline   Reply With Quote
Old 12-07-2009, 08:29 PM   #7
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Haeter problems

thanks senior ford tech will do!!
D MAN is offline   Reply With Quote
Old 12-07-2009, 08:32 PM   #8
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[quote=Bucko;330188]You answered your own question pertaining to the thermostat...if the engine temp gauge is showing a normal temp, then the thermostat is working.

Blend door or auto climate box (if equipped). You did not tell us your model; the crystal ball is in the shop right now. 2004 F-150 LARIET
D MAN is offline   Reply With Quote
Old 12-07-2009, 08:32 PM   #9
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 8,824
Thanked 331 Times in 272 Posts
Default

Lariats have the "auto climate" feature, another troublesome unit. If it is found to be bad, it's unrepairable and on the pricy side to replace.

Hopefully for you it will be something simple; otherwise be prepared for a large repair (and parts) bill from the "senior Ford tech".
__________________
"Never argue with an idiot; they'll only drag you down to their level, then beat you with experience"

2007 F150 STX Supercab (4.6 2V V8), Edge tuner, factory navigation, Mark VIII electric fan conversion with flex-o-lite controller.

Last edited by Bucko; 12-07-2009 at 08:35 PM.
Bucko is offline   Reply With Quote
Old 12-07-2009, 08:36 PM   #10
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

THE MODEL IN QUESTION IS A 2004 F-150 LARIET!!
D MAN is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 36 07-10-2016 05:41 PM
Anyone else have a Canadian FX4? Silverlx 2009 - 2014 Ford F150 18 01-21-2016 03:08 PM
Need help! Battery keeps dying! john367 2009 - 2014 Ford F150 42 10-23-2015 02:23 PM
Transmission problems P0720,P0722 azkfx450 2004 - 2008 Ford F150 2 09-11-2015 11:52 AM
New to me truck with problems--please help!! AKJT1215 2004 - 2008 Ford F150 13 09-09-2015 05:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 09:32 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.