Heater problems - Ford F150 Forum - Community of Ford Truck Fans



Heater problems

Reply
 
 
 
Thread Tools Search this Thread
Old 12-06-2009, 10:45 AM   #1
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2009
Location: florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Heater problems

I have a F-150 King Ranch with a heater problem,there is no heat, the blower works, the tempture indicator works, the eng indicate normal. Is there a relay I can't see this as being a fuse problem
cameron is offline   Reply With Quote
Old 12-06-2009, 11:39 AM   #2
FLARESIDE MAN !!!
 
seniorFORDtech's Avatar
 
Join Date: Nov 2009
Location: chicago il
Posts: 287
Thanks: 0
Thanked 0 Times in 0 Posts
Default

if your concern is no tempature change, you most likely have a bad blend door motor this has been a problem for a lot of f150's the blend door motor is mounted behind the radio on top of the heater box, sounds easy, but the screws are not easily accessed also u must line the motor up with the door,the key must be in the off postion...
seniorFORDtech is offline   Reply With Quote
Old 12-07-2009, 02:36 AM   #3
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2009
Location: florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default heater

Thanks for the info I check it out. Today it was working ok I hope it not going to be one of those that works when it feel like it
cameron is offline   Reply With Quote
Old 12-07-2009, 09:20 PM   #4
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?
D MAN is offline   Reply With Quote
Old 12-07-2009, 09:22 PM   #5
FLARESIDE MAN !!!
 
seniorFORDtech's Avatar
 
Join Date: Nov 2009
Location: chicago il
Posts: 287
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by D MAN View Post
Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?

it will work intermittantly still would check it out..
seniorFORDtech is offline   Reply With Quote
Old 12-07-2009, 09:28 PM   #6
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 9,139
Thanked 388 Times in 304 Posts
Default

Quote:
Originally Posted by D MAN View Post
Im new to the sight and heres my problem . It was 11 degrees this morning and go to turn the heater on luke warm? . Fans fine, themostat shows engine fine! ? Fluids good! Whats up is it my thermostat ?
You answered your own question pertaining to the thermostat...if the engine temp gauge is showing a normal temp, then the thermostat is working.

Blend door or auto climate box (if equipped). You did not tell us your model; the crystal ball is in the shop right now.

Last edited by Bucko; 12-07-2009 at 09:30 PM.
Bucko is offline   Reply With Quote
Old 12-07-2009, 09:29 PM   #7
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Haeter problems

thanks senior ford tech will do!!
D MAN is offline   Reply With Quote
Old 12-07-2009, 09:32 PM   #8
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[quote=Bucko;330188]You answered your own question pertaining to the thermostat...if the engine temp gauge is showing a normal temp, then the thermostat is working.

Blend door or auto climate box (if equipped). You did not tell us your model; the crystal ball is in the shop right now. 2004 F-150 LARIET
D MAN is offline   Reply With Quote
Old 12-07-2009, 09:32 PM   #9
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 9,139
Thanked 388 Times in 304 Posts
Default

Lariats have the "auto climate" feature, another troublesome unit. If it is found to be bad, it's unrepairable and on the pricy side to replace.

Hopefully for you it will be something simple; otherwise be prepared for a large repair (and parts) bill from the "senior Ford tech".

Last edited by Bucko; 12-07-2009 at 09:35 PM.
Bucko is offline   Reply With Quote
Old 12-07-2009, 09:36 PM   #10
Junior Member
 
Join Date: Dec 2009
Location: spokane valley , wa.
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

THE MODEL IN QUESTION IS A 2004 F-150 LARIET!!
D MAN is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
Anyone else have a Canadian FX4? Silverlx 2009 - 2014 Ford F150 18 01-21-2016 04:08 PM
Need help! Battery keeps dying! john367 2009 - 2014 Ford F150 42 10-23-2015 03:23 PM
Transmission problems P0720,P0722 azkfx450 2004 - 2008 Ford F150 2 09-11-2015 12:52 PM
New to me truck with problems--please help!! AKJT1215 2004 - 2008 Ford F150 13 09-09-2015 06:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:52 AM.


Copyright 2006 - 2016 F150Forum.com