F150 stalls when i stop; starts right back up - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Log In 


F150 stalls when i stop; starts right back up

Reply
 
 
 
Thread Tools Search this Thread
Old 12-08-2009, 06:45 AM   #1
Junior Member
 
Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default F150 stalls when i stop; starts right back up

The engine light was coming on and going off without any noted pattern. Recently the truck has started stalling when i come to a stop - not constant - very intermittent. The truck starts right back up without any problems.

The truck runs and performs great other than what is noted above.
CR250R is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 12-08-2009, 01:37 PM   #2
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 8,972
Thanked 360 Times in 282 Posts
Default

dump the codes and post them here. Can't tell you whats wrong by just your description...need the stored trouble codes.
__________________
"Never argue with an idiot; they'll only drag you down to their level, then beat you with experience"

2007 F150 STX Supercab (4.6 2V V8), Edge tuner, factory navigation, Mark VIII electric fan conversion with flex-o-lite controller.
Bucko is offline   Reply With Quote
Old 12-15-2009, 11:24 PM   #3
Junior Member
 
Join Date: Dec 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default F150 stalls when i stop; restarts fine

Pulled code p0506 (idle air control system rpm lower than expected) from the computer; cleared it, but returned in no time. Feels like it has a bad plug? Help!!!



Quote:
Originally Posted by cr250r View Post
the engine light was coming on and going off without any noted pattern. Recently the truck has started stalling when i come to a stop - not constant - very intermittent. The truck starts right back up without any problems.

The truck runs and performs great other than what is noted above.
CR250R is offline   Reply With Quote
Old 12-15-2009, 11:41 PM   #4
Senior Member
5 Year Member
 
NorCal-09's Avatar
 
Join Date: Jun 2009
Location: After 20 + years in the foothills of the Sierras; I am now [back] in the south-end of Sunny SoCal!
Posts: 2,103
Thanked 71 Times in 45 Posts
Default

Quote:
Originally Posted by CR250R View Post
The engine light was coming on and going off without any noted pattern. Recently the truck has started stalling when i come to a stop - not constant - very intermittent. The truck starts right back up without any problems.

The truck runs and performs great other than what is noted above.

FYI, my '04 was doing this same thing (exact symptoms); I changed the fuel filter and it stopped doing it. I thought about the filter, because just prior to this, I had ran a couple of bottles of HD injector cleaner through the fuel system, via the gas tank. I think a lot of junk clogged up the filter? Maybe not the fix in your case, but just a thought, as this drove me nuts for a month, before I figured it out.
NorCal-09 is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
F150 number Two! SplinterF150 Introductions 18 01-15-2016 10:10 AM
Fix for gauge light battery drain please! Chile 2009 - 2014 Ford F150 16 12-22-2015 12:05 PM
Engine cuts out on HWY, hard to start after gassing ThomD 2009 - 2014 Ford F150 10 12-15-2015 10:16 PM
dies at idle rpm, need help bad! betty_white 2004 - 2008 Ford F150 6 09-05-2015 02:10 PM
'09 SFE cuts out, and hard to start after gassing. ThomD General F150 Discussion 1 09-03-2015 11:03 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 12:42 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.