Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-27-2014, 07:06 PM   #1
Junior Member
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Engine Help!

Hey guys...I'm having a problem with my 2004 FX4. It is shaking rather violently at idle, like it's about to die. Acompanying this issue, there is also a rapid "metallic tapping" noise, though I can not discern where it is coming from in the engine. I'm not all that experienced with engines, and this is the first time anything like this has ever happened to a vehicle of mine. Any ideas? I look forward to any help. Thanks
RyanPair is offline   Reply With Quote
Old 02-27-2014, 07:21 PM   #2
Mark
5 Year Member
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 17,113
Mentioned: 3 Post(s)
Thanks: 157
Thanked 361 Times in 314 Posts
Feedback Score: 1 reviews
Default

dont sound good...any DTC codes...CEL light
__________________
08 FX4... Flowmaster Exhaust, line-X, Sky Jacker leveling kit. 295/65/20 Nitto trails mounted on 20 X 9 Carol Shelby wheels. AIRAID CAI. Projector/Halo headlamps and LED Tails & 3rd brake lights,custom upper and lower Grill. Edge Evolution. Interior/Exterior LED lighting, NFAB step bars.
techrep is offline   Reply With Quote
Old 02-28-2014, 07:56 AM   #3
Junior Member
 
Join Date: Feb 2014
Posts: 3
Mentioned: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I don't have a code reader. The CEL came on just before all of this started, which was about 4 days ago.
RyanPair is offline   Reply With Quote
Old 02-28-2014, 07:56 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

The Mustang Source
All times are GMT -4. The time now is 07:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.