Edge Evo settings - Page 36 - Ford F150 Forum - Community of Ford Truck Fans



Edge Evo settings

Reply
 
 
 
Thread Tools Search this Thread
Old 09-19-2013, 09:09 PM   #351
I Like Tires
5 Year Member
 
BassAckwards's Avatar
 
Join Date: Aug 2010
Location: Texas
Posts: 4,851
Thanked 235 Times in 209 Posts
Default

Quote:
Originally Posted by Zax View Post
Did this and I like the power gain, but I have one small issue. My normal speeds are 25-35 and than 45-55 so right around 40-52 MPH if I let off the gas and then tap it again I get clunking and it sounds like it's shifting all over the place. If I go to stock setting that issue goes away. I'm not good enough with this to know what to change so please ! I feel like I'm harming my truck.
Sounds like your torque converter. Turn those back to stock and see if it goes away.
BassAckwards is online now   Reply With Quote
Old 09-20-2013, 03:28 AM   #352
Zax
♫♪ I Hold On ♫♪
5 Year Member
 
Zax's Avatar
 
Join Date: Feb 2011
Location: Alaska
Posts: 1,366
Thanked 73 Times in 68 Posts
Default

Quote:
Originally Posted by BassAckwards View Post
Sounds like your torque converter. Turn those back to stock and see if it goes away.
Okay I will try that tomorrow thanks.
Zax is offline   Reply With Quote
Old 09-20-2013, 02:53 PM   #353
Zax
♫♪ I Hold On ♫♪
5 Year Member
 
Zax's Avatar
 
Join Date: Feb 2011
Location: Alaska
Posts: 1,366
Thanked 73 Times in 68 Posts
Default

[MENTION=43581]BassAckwards[/MENTION] Okay I am going to try it after work, but does this mean my tq converter is bad or just doesn't like this program...
Zax is offline   Reply With Quote
Old 09-20-2013, 03:58 PM   #354
Senior Member
 
Smokestone12's Avatar
 
Join Date: Jun 2013
Location: East Texas
Posts: 131
Thanked 1 Time in 1 Post
Default

I have a 06 5.4L with flow masters and CIA what tune should I try?
Smokestone12 is offline   Reply With Quote
Old 09-20-2013, 09:52 PM   #355
I Like Tires
5 Year Member
 
BassAckwards's Avatar
 
Join Date: Aug 2010
Location: Texas
Posts: 4,851
Thanked 235 Times in 209 Posts
Default

Quote:
Originally Posted by Zax View Post
@BassAckwards Okay I am going to try it after work, but does this mean my tq converter is bad or just doesn't like this program...
If you let off the gas the torque converter will automatically unlock and when you tap it, it is trying to lock again but you may have slowed down to much for it to stay locked.

For the speeds you drive I would keep it stock, you really have to train yourself to drive differently to see a big gain from it.
BassAckwards is online now   Reply With Quote
Old 09-21-2013, 05:34 AM   #356
Zax
♫♪ I Hold On ♫♪
5 Year Member
 
Zax's Avatar
 
Join Date: Feb 2011
Location: Alaska
Posts: 1,366
Thanked 73 Times in 68 Posts
Default

So just keep the lock stock? So all the other settings should be fine? I set it back to fully stock and no issue on my drive home.
Zax is offline   Reply With Quote
Old 09-23-2013, 02:11 AM   #357
Zax
♫♪ I Hold On ♫♪
5 Year Member
 
Zax's Avatar
 
Join Date: Feb 2011
Location: Alaska
Posts: 1,366
Thanked 73 Times in 68 Posts
Default

Well two days of driving no more issue. I will keep it stock for a bit longer to make sure though.
Zax is offline   Reply With Quote
Old 09-23-2013, 09:15 AM   #358
Junior Member
 
Join Date: Sep 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just purchased myself a 2007 f150 crew cab w/5.4 i am doing my research on Programmers and so far it seems everyone is on the Evo.. i am hoping to purchase in the next few weeks. also i plan on dropping it 4/6 w/22s and to add a CAI and exhaust maybe a TB spacer as well..
SBenesh is offline   Reply With Quote
Old 09-25-2013, 04:18 PM   #359
Junior Member
 
bosoxfanme's Avatar
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ophidia View Post
Everything with mine seems to be working great. I just have a few Q's. First, it seems like the throttle response when taking off is a lot more abrupt with the tow tune than it is with extreme. Anyone else notice that? I'm running extreme now because of it (and it's working well) but not sure I want to keep ponying up for premium. Also, with the torque convertor lockup setting. Am I right that if I set it at, say. -6, that's supposed to make it lock up 6mph lower than the stock setting? Because I did that and it still locks at like 41mph like it did before. Good thread-- glad I found it!
Hi all,
I'm new here. This is a great thread.
I've had my evolution for a week now.
I notice the same thing Ophidia!
As far as throttle response in the tow setting. It is very abrupt/touchy. Go down a bumpy dirt road!

I'm wondering if there is anything you can adjust to improve it??

I agree with you program 3. Definitely doesn't have that issue.
I'm real happy thus far with this though overall. There is definitely an improvement.
I just wish this dog 4.6l could spin my 275/70/17's. I used have a 5.4l so I miss not being able to brake stand. That ain't happening. I guess.
bosoxfanme is offline   Reply With Quote
Old 09-25-2013, 04:19 PM   #360
Junior Member
 
bosoxfanme's Avatar
 
Join Date: Sep 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ophidia View Post
Everything with mine seems to be working great. I just have a few Q's. First, it seems like the throttle response when taking off is a lot more abrupt with the tow tune than it is with extreme. Anyone else notice that? I'm running extreme now because of it (and it's working well) but not sure I want to keep ponying up for premium. Also, with the torque convertor lockup setting. Am I right that if I set it at, say. -6, that's supposed to make it lock up 6mph lower than the stock setting? Because I did that and it still locks at like 41mph like it did before. Good thread-- glad I found it!
Quote:
Originally Posted by ophidia View Post
Everything with mine seems to be working great. I just have a few Q's. First, it seems like the throttle response when taking off is a lot more abrupt with the tow tune than it is with extreme. Anyone else notice that? I'm running extreme now because of it (and it's working well) but not sure I want to keep ponying up for premium. Also, with the torque convertor lockup setting. Am I right that if I set it at, say. -6, that's supposed to make it lock up 6mph lower than the stock setting? Because I did that and it still locks at like 41mph like it did before. Good thread-- glad I found it!
Hi all,
I'm new here. This is a great thread.
I've had my evolution for a week now.
I notice the same thing Ophidia!
As far as throttle response in the tow setting. It is very abrupt/touchy. Go down a bumpy dirt road!

I'm wondering if there is anything you can adjust to improve it??

I agree with you program 3. Definitely doesn't have that issue.
I'm real happy thus far with this though overall. There is definitely an improvement.
I just wish this dog 4.6l could spin my 275/70/17's. I used have a 5.4l so I miss not being able to brake stand. That ain't happening. I guess.
bosoxfanme is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Aluminum Problems wpbritton General F150 Discussion 11 03-20-2016 09:39 PM
Need audio experts! Kalen427 Stereo/Audio 34 01-24-2016 04:54 PM
Learned something the hard way tazmanken 2015 - Present Ford F150 8 09-11-2015 04:55 PM
What is the best teir 1 Edge Tune for 4.6 WWII HiStOrIaN 2004 - 2008 Ford F150 5 09-09-2015 12:18 PM
Breaks brain buster 2012 Scab please help Rob_taylor Maintenance Shop 0 09-07-2015 01:07 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:44 PM.


Copyright 2006 - 2016 F150Forum.com