Edge Evo settings - Page 34 - Ford F150 Forum - Community of Ford Truck Fans



Edge Evo settings

Reply
 
 
 
Thread Tools Search this Thread
Old 04-02-2013, 05:00 PM   #331
Member
 
Join Date: Jan 2013
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just got an edge evo. What settings should I set if I have a 6" lift on 325/65/18 tires? That is my only mod. Should I edit the towing, transmission, or extreme? I run 87 octane and am currently using the stock towing tune without changing anything.
Nickksim1 is offline   Reply With Quote
Old 04-02-2013, 05:11 PM   #332
Member
 
05norcal150's Avatar
 
Join Date: Dec 2012
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Nickksim1 View Post
I just got an edge evo. What settings should I set if I have a 6" lift on 325/65/18 tires? That is my only mod. Should I edit the towing, transmission, or extreme? I run 87 octane and am currently using the stock towing tune without changing anything.
You would be good with setting two(towing) , adjust for your tire size and put the shift firmness to 9-12 for all gears...you can continue to use 87 gas and should notice a pretty nice power difference
05norcal150 is offline   Reply With Quote
Old 04-02-2013, 06:46 PM   #333
I Like Tires
5 Year Member
 
BassAckwards's Avatar
 
Join Date: Aug 2010
Location: Texas
Posts: 4,851
Thanked 235 Times in 209 Posts
Default

Quote:
Originally Posted by Nickksim1 View Post
I just got an edge evo. What settings should I set if I have a 6" lift on 325/65/18 tires? That is my only mod. Should I edit the towing, transmission, or extreme? I run 87 octane and am currently using the stock towing tune without changing anything.
The performance or extreme tune will require 93 octane so I would stick with the tow tune.
BassAckwards is offline   Reply With Quote
Old 05-08-2013, 11:00 PM   #334
Senior Member
 
ophidia's Avatar
 
Join Date: Apr 2013
Location: West Fargo, ND
Posts: 172
Thanked 15 Times in 15 Posts
Default

Everything with mine seems to be working great. I just have a few Q's.

First, it seems like the throttle response when taking off is a lot more abrupt with the tow tune than it is with extreme. Anyone else notice that? I'm running extreme now because of it (and it's working well) but not sure I want to keep ponying up for premium.

Also, with the torque convertor lockup setting. Am I right that if I set it at, say. -6, that's supposed to make it lock up 6mph lower than the stock setting? Because I did that and it still locks at like 41mph like it did before.

Good thread-- glad I found it!
ophidia is offline   Reply With Quote
Old 05-17-2013, 02:05 AM   #335
Senior Member
 
Black FX2's Avatar
 
Join Date: Jan 2013
Location: San Diego
Posts: 1,249
Thanked 86 Times in 83 Posts
Default

I love mine, but so far at about 45 it shifts kind of hard.. what should I do to fix this?
Black FX2 is offline   Reply With Quote
Old 05-17-2013, 02:17 AM   #336
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i Run it at the second setting i think its -towing.... heard some noises similar, took it in an my alternator was putting no output out, so i replaced it. it hasnt made any sounds since runs smooth, my mechanic said it might of been something with the battery connect.

35/12.50/18 Mud Tires, Magna Flow dual (racing edition) exhaust straight pipes, Cold Air intake (silver tube), Spyer Headlights, Spyer Tail Lights, Spyer Fog lights, Rhino guard bed of truck, EDGE power/performance chip, 2 10 Alpine subs, after market door speakers, alpine touch screen dock, alpine amp
GreyGhoast24 is offline   Reply With Quote
Old 05-17-2013, 02:21 AM   #337
Member
 
chuyito79's Avatar
 
Join Date: May 2013
Posts: 35
Thanked 0 Times in 0 Posts
Default

i have an 05 f150 with the 4.6,, currently i have the airaid tube instead of the fatory intake tube,, along with the drop in filter,, thinking about getting an edge evo for the truck,, do guys think it would run lean even if the maf is in the stock place?,, i mean its not really a cai system
chuyito79 is offline   Reply With Quote
Old 05-27-2013, 02:01 AM   #338
Senior Member
 
CHUMCHAL72's Avatar
 
Join Date: Jul 2012
Posts: 602
Thanked 18 Times in 18 Posts
Default

I have kinda a problem. Lol I know my truck is gonna be kinda slow but I did a 0-60 the other day and got a 19 usually I get around 12-13. From the start it really struggled to push over the 2300rpm range. I have the 5.4 with 35's and 3.73 gears. I'm not sure what I put in setting I did it a while back but ill post them tomorrow. But till then can anyone explain what could cause this. I understand it might be something mechanical but I would like to see if it was my programming.

Thanks,
CHUMCHAL72 is offline   Reply With Quote
Old 05-27-2013, 08:50 PM   #339
Senior Member
5 Year Member
 
LUVmyDUX's Avatar
 
Join Date: May 2010
Location: NW Portland
Posts: 607
Thanked 35 Times in 32 Posts
Default

Anyone have a good setting for the 4.6?
LUVmyDUX is offline   Reply With Quote
Old 05-28-2013, 02:47 AM   #340
Senior Member
 
Join Date: Oct 2011
Posts: 458
Thanked 7 Times in 7 Posts
Default

Truck just doesn't like any sort of light throttle in anything above level 1. I love the firmer trans and thats as much as I use it. Its peppier in 2, but to spotty unless you are harder on acceleration.
wintersucks is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Aluminum Problems wpbritton General F150 Discussion 11 03-20-2016 09:39 PM
Need audio experts! Kalen427 Stereo/Audio 34 01-24-2016 04:54 PM
Learned something the hard way tazmanken 2015 - Present Ford F150 8 09-11-2015 04:55 PM
What is the best teir 1 Edge Tune for 4.6 WWII HiStOrIaN 2004 - 2008 Ford F150 5 09-09-2015 12:18 PM
Breaks brain buster 2012 Scab please help Rob_taylor Maintenance Shop 0 09-07-2015 01:07 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:46 AM.


Copyright 2006 - 2016 F150Forum.com