Does hypertech suck? - Ford F150 Forum - Community of Ford Truck Fans



Does hypertech suck?

Reply
 
 
 
Thread Tools Search this Thread
Old 03-23-2008, 05:43 AM   #1
Senior Member
5 Year Member
Thread Starter
 
TMintus8's Avatar
 
Join Date: Oct 2007
Location: Brookfield, OH
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Default Does hypertech suck?

I got a pro comp programmer when I did my lift, mostly to recalibrate the speedo for the tires. Didn't do much research cuz it said pro comp on it and I got a good deal. Turns out the programmer is just a hypertech programmer in pro comp blue. Anyway just recently my trucks been acting up. The little yellow wrench will light up and the truck will start acting like it's mis-firing or something. It makes a sputtering sound at lower rpm's and loses power. If I turn the truck off and restart it it's fine...that's why i'm thinking it's the programmer. Anyone have any experience with these?
TMintus8 is offline   Reply With Quote
Old 03-23-2008, 11:15 AM   #2
08 February TOTM
5 Year Member
 
whitecrystal1's Avatar
 
Join Date: Nov 2006
Location: Dumfries, VA Member: #77
Posts: 3,184
Thanks: 0
Thanked 10 Times in 5 Posts
Default

I had on on mine for about two months. After noticing no real power gains I sold it and bout a used Edge. I never had any issues with mine. what performance mods do you have on your truck?
whitecrystal1 is offline   Reply With Quote
Old 03-23-2008, 12:01 PM   #3
workin for parts!!!
5 Year Member
 
05 super's Avatar
 
Join Date: Nov 2007
Location: watson lake,yukon
Posts: 1,447
Thanked 12 Times in 12 Posts
Default

i agree with whitecrystal. mine's been on for 2 years and not a prob, although no real gains IMO. i want to get it dyno'ed this summer to see. i do sometimes get a belt chirping sound if i get it revved out in 2nd. it seems that the rev limiter has been reached and accelleration stops, until it shifts to 3rd. but i have f*cked with the rev limiter and shift points.
05 super is online now   Reply With Quote
Old 03-23-2008, 04:57 PM   #4
Senior Member
5 Year Member
Thread Starter
 
TMintus8's Avatar
 
Join Date: Oct 2007
Location: Brookfield, OH
Posts: 235
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a K&N cai and a gibson supertruck cat back. I'm not sure if there was a noticeable power gain since I did it at the same time as my lift.
TMintus8 is offline   Reply With Quote
Old 03-24-2008, 09:11 PM   #5
Senior Member
5 Year Member
 
hondarider400at's Avatar
 
Join Date: Sep 2007
Posts: 103
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yea i had the same problem. correct me if im wrong... but i learned that the little yellow wrench always means a throttle problem. took it to the dealership and had the throttle body replaced.

Last edited by hondarider400at; 03-26-2008 at 09:41 PM.
hondarider400at is offline   Reply With Quote
Old 03-25-2008, 11:37 AM   #6
NGM
Resident A-hole
5 Year Member
 
NGM's Avatar
 
Join Date: Feb 2007
Location: Tallahassee
Posts: 4,098
Thanks: 0
Thanked 25 Times in 20 Posts
Default

Yes Hypertec Sucks.
NGM is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Lariat Crew Cab - Lease Upgrade iJeffG Stereo/Audio 6 10-26-2015 02:20 PM
How to access OBD Lockelamora 2015 - Present Ford F150 1 10-01-2015 06:15 PM
Two Years Later CDC5.0 2009 - 2014 Ford F150 2 09-30-2015 04:51 PM
any ideas jayb21 Maintenance Shop 0 09-29-2015 12:34 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:29 PM.


Copyright 2006 - 2016 F150Forum.com