Code p0016 rought idle - Ford F150 Forum - Community of Ford Truck Fans



Code p0016 rought idle

Reply
 
 
 
Thread Tools Search this Thread
Old 11-23-2011, 08:12 PM   #1
Member
Thread Starter
 
gonzo8000's Avatar
 
Join Date: Feb 2011
Location: Germany
Posts: 89
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hi

My 2006 FX4 Screw 5.4 with only 19.000 miles on it started to idle very rough, had no power and the CEL blinked, indicating missfire.

So i checked for Codes with my gryphon.
P0016 crankshaft position - camshaft position correlation bank 1
P0012 camshaft Position - timing over retarded Bank 1
P0303 cylinder 3 misfire detected

After two nights of research in this Forum and other sites i had a very bad feeling that there is an issue with my camphasers or the vct solenoides

Last edited by gonzo8000; 11-23-2011 at 09:04 PM.
gonzo8000 is offline   Reply With Quote
Old 11-23-2011, 08:34 PM   #2
Member
Thread Starter
 
gonzo8000's Avatar
 
Join Date: Feb 2011
Location: Germany
Posts: 89
Thanks: 0
Thanked 2 Times in 2 Posts
Default

As i live in Germany i had to fix it myself...
So i started with changing the oil and filter, had to be done anyways...
Then i thought i'd change the VCT solenoid from side to side and see if the issue goes to the other bank with a p0018 code.
But when i took the solenoid out of bank 1 passenger side, i found the problem. A pice of the mesh came loose and got the piston stuck. That caused the wrong camshaft position and timing problem.
After taking the solenoid apart and cleaning it. The truck runs like nothing happened.
Man i'm so happy about that no cost fix. I feared the 1000+ Euro camphaser fix
Attached Thumbnails
Code p0016 rought idle-image-2591154669.jpg   Code p0016 rought idle-image-923468624.jpg  

Last edited by gonzo8000; 11-23-2011 at 08:57 PM.
gonzo8000 is offline   Reply With Quote
Old 11-23-2011, 09:02 PM   #3
Member
Thread Starter
 
gonzo8000's Avatar
 
Join Date: Feb 2011
Location: Germany
Posts: 89
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Vct solenoid
Attached Thumbnails
Code p0016 rought idle-image-3990799097.jpg   Code p0016 rought idle-image-905439393.jpg  
gonzo8000 is offline   Reply With Quote
Old 11-23-2011, 09:14 PM   #4
Senior Member
5 Year Member
 
Join Date: Sep 2007
Location: Las Vegas
Posts: 1,103
Thanks: 0
Thanked 0 Times in 0 Posts
Default

so did you buy a new screen or just put the damaged one back in?
luckythirteen13 is offline   Reply With Quote
Old 11-23-2011, 09:57 PM   #5
Member
Thread Starter
 
gonzo8000's Avatar
 
Join Date: Feb 2011
Location: Germany
Posts: 89
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I did not put the screen back in and will order a complete vct solenoid
gonzo8000 is offline   Reply With Quote
Old 11-23-2011, 10:04 PM   #6
Moderator
5 Year Member
 
Bucko's Avatar
 
Join Date: Sep 2008
Location: Lake Mary Florida
Posts: 9,121
Thanked 388 Times in 304 Posts
Default

Great post! I sure wish more would go the effort to post their findings and solutions such as yours!

This one will no doubt get used in a future search.

My hats off to you for taking the effort to post the results. You researched your fault codes, dove in, and found the problem. A rare thing these days.
Bucko is offline   Reply With Quote
Old 11-24-2011, 01:09 PM   #7
Member
Thread Starter
 
gonzo8000's Avatar
 
Join Date: Feb 2011
Location: Germany
Posts: 89
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Thanks man.
I am so happy that i found and solved the problem so "easy" that i just had to share it.
Here in Germany the Ford dealerships dont cover US models. So i had to figure it out on my one by searching the internet and trying...
gonzo8000 is offline   Reply With Quote
Old 12-02-2014, 05:07 PM   #8
Junior Member
 
Join Date: Dec 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default p0016 & p0012

I have a 2006 f150 5.4 3valve. It started running bad. Changed both timing guides, tensioners, tensioner arms, and both phasers. Replaced both vct sylenoids, camshaft position sensor, 8 new spark plugs, and most of the coil packs ( checked all the others). Rechecked timing the times. Still has a rough idle and their codes p0016 & p0012. After 4 mechanics and 8 months without a truck we need help!!!
wskbowe is offline   Reply With Quote
Old 12-02-2014, 05:08 PM   #9
Junior Member
 
Join Date: Dec 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It runs fine other than at idle. It never stalls.
wskbowe is offline   Reply With Quote
Old 12-02-2014, 06:39 PM   #10
Senior Member
 
Join Date: Feb 2014
Location: Birmingham, Alabama
Posts: 1,063
Thanked 93 Times in 92 Posts
Default

If the reluctor ring was installed backwards, that could cause it. Also a damaged crankshaft position sensor, or the wiring to it.
lewissa81 is offline   Reply With Quote
The Following User Says Thank You to lewissa81 For This Useful Post:
Darren123 (11-08-2016)
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
'91 4.9l electrical, IAC, computer? jereman Electrical 12 09-29-2015 10:20 AM
Another P0012, but maybe a little different KwitcherBitchin 2004 - 2008 Ford F150 17 09-15-2015 09:22 AM
My 5.4 problem mikeyb_23 2004 - 2008 Ford F150 5 09-14-2015 10:58 AM
P0182 - Temerature Sensor "A" Circuit Low mcouture 2004 - 2008 Ford F150 3 09-02-2015 09:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:13 AM.


Copyright 2006 - 2016 F150Forum.com