Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-24-2014, 03:26 PM   #1
Junior Member
 
Join Date: Dec 2013
Location: Lake Jackson, TX
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Another gas mileage post

Hi guys. Long time lurker first time poster. I've searched plenty on this issue but I every situation is different and I like some advice on where to start looking first. I bought my 07 fx4 (5.4 3v) in December with about 120k on the clock. When I bought it I knew it would need plugs changed as well as some other maintenance very soon. On the first couple of tanks I got about 13-14 mpg. The truck also came with a 2 or 3 inch lift, bigger tires (295) and true dual exhaust. Around the 3rd tank I started getting a bad misfire. So I changed out the plugs and replaced the coils with some slightly upgraded options. I also cleaned my air filter (came with a k&n). Instantly my mileage with down to around 10 even on the highway. I don't drive the truck hard. I keep it below 2000 rpm aside from some on ramp merging situations. Last take littering around the town I got 8.9 mpg. My question to you all is where should I start looking for the problem. What should be changed out first and all that? I know it's a truck with a big engine and the lift and tires don't help so I'm not expecting a miracle. But 5 extra mpg on a 33 gallon tank would be a might big help.

Thanks in advance,
Nate from Brazoria county Texas
Arvina is offline   Reply With Quote
Old 08-24-2014, 03:58 PM   #2
Force Trucker:)
 
yoda13's Avatar
 
Join Date: Sep 2011
Location: Texas
Posts: 127
Mentioned: 0 Post(s)
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

How about changing your fuel filter? That probably needs to be done. What brand plugs did you use? These Fords sometimes don't do well on non-motorcraft replacement parts...did you over oil the filter after you cleaned it?
__________________
2007 Ford F150 XLT Texas Edition Scab w/ 4.6 V8, Superchips Cortex, AFE Stage 2 CAI, and Cherry Bomb muffler...
yoda13 is offline   Reply With Quote
Old 08-24-2014, 09:23 PM   #3
Member
 
Join Date: Oct 2013
Posts: 98
Mentioned: 0 Post(s)
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Default

i'd try cleaning the MAF sensor too
__________________
04 Super Cab FX-4. Gibson exhaust, AFE intake, Edge programmer, 2" leveling kit, 285/65-18 Terra Grapplers, Pro Comp 1079 18x9, 15% tint
effects4 is offline   Reply With Quote
Old 08-24-2014, 09:23 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 05:40 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.