4X4 won't engage 2007 F150 XLT 5.4 SCREW - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Log In 


4X4 won't engage 2007 F150 XLT 5.4 SCREW

Reply
 
 
 
 
Thread Tools Search this Thread
Old 12-19-2010, 09:46 PM   #1
Senior Member
 
Join Date: Aug 2010
Location: edmonton alberta
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 4X4 won't engage 2007 F150 XLT 5.4 SCREW

4X4 won't engage 2007 F150 XLT 5.4 SCREW

so its been cold out here and then it got warm one day so I washed my truck. now I'm having 4X4 problems, I don't know if washing the truck had anything to do with it. the 4X4 was working fine and then when I needed it, nothing no click, no light on hi or low. I checked all the fuses and I pulled the IWE but everything is checking out ok. anyone else having this problem? all I can find in a search is people saying that their hubs will lock while driving but that is not one of my symptoms. I did read that there is a motor on the transfer case that can get stuck. anyone having the same problems as me? any idea what to try next?
__________________
CHEVROLET - Cracked Heads, Every Valve Rattles, Oil Leaks, Engine Ticks.
dextreme is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 04:10 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.