Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-12-2010, 01:55 PM   #1
Junior Member
 
Join Date: Apr 2010
Location: Good Ol' Va
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 4x4 high dash light

Just bought a 2006 and noticed today when trying out the 4wd that the 4x4 high light does not come on. It is a manual floor stick operated transfer case. The light will sometimes "blink" while shifting but does not stay lit. It appeared to engage 4wd when put in 4H by my simple "it spins the back tires in the grass on a hill until the stick is engaged to 4H and then it doesn't spin the back tires and climbs the hill method". When put into 4L the indicator light for that works fine. I have read on here about sticking engagement motors on the tranfser case but my manual case doesn't have one of those selonoid motors to do the rubber mallet trick on. Any sugestions on what is wrong and how to fix this is appriciated.

Thanks,
Dave
VADave is offline   Reply With Quote
Old 10-17-2010, 11:55 PM   #2
Junior Member
 
Join Date: Jul 2010
Location: Spokane / Missoula
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default another link

See if this guys problem is similar:

http://www.justanswer.co.uk/question...d-out-solenoid

My light doesn't come on, but the 4x4 works. Vacuum system fixed and all.
jesse1414 is offline   Reply With Quote
Old 09-30-2012, 10:19 PM   #3
Junior Member
 
Join Date: Aug 2012
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I have same exact problem as vadave, any suggestions?
118866 is offline   Reply With Quote
Old 10-02-2012, 10:10 AM   #4
jaxwireman
 
Join Date: Sep 2012
Location: Jacksonville,Fl.
Posts: 265
Mentioned: 0 Post(s)
Thanks: 1
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Default

I think it is still a vacum solenoid to activate the motor on the transfer case. The solenoid is what says go to the ECU and engages TC Motor and tells the indicator light to come on. Mine is not floor shift, however it did the same thing, changed solenoid on firewall and fixed. I dont think you can buy a true manual shift in a f-150 at all after 04 if not before.

If locking in 4x4, you can tell just by driving as the turns want be as tight or put it in some dirt and see if the front turns the tires spin when you give it some gas you will no the TC motor is working.

Last edited by sglover; 10-02-2012 at 10:24 AM.
sglover is offline   Reply With Quote
Old 10-03-2012, 06:42 AM   #5
Junior Member
 
Join Date: Apr 2010
Location: Good Ol' Va
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Replace the firewall mounted vaccum switch

Replace the fire wall switch behind the battery. That will fix the problem. Check to see if your axles are turning all the time right now. I have a feeling they are. Bad design by ford uses vaccum to dis engage the hubs. When it looses vaccum the hubs are engaged. Some trucks like mine that were never put in 4x4 mode may have had to hubs engaged for a long time. Let me know what you find out.
Dave
VADave is offline   Reply With Quote
Old 10-03-2012, 09:21 AM   #6
Senior Member
 
Join Date: Jul 2010
Location: Harlingen,tx
Posts: 152
Mentioned: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

The hubs are still vacuum and if my memory serves me right they are actually what turns the 4wd light on, not the t-case being shifted into 4wd. So if the hubs aren't engaging the light won't come on
__________________
New toy: 2010 RAPTOR Oxford white with graphics, 20" BMF novakanes wrapped in 35/12.50/20 trail grapplers
Volant intake and SCT tunes!

Sold 04 super cab flare side fx4!
baddkarmaracing is offline   Reply With Quote
Old 10-03-2012, 09:21 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installed HID's and now my high beam light on the dash is on? 1wheel_up 2004 - 2008 Ford F150 6 05-28-2014 04:06 AM
how do u install high intensity light bulbs 90f150 1987 - 1996 F150 1 03-14-2010 10:37 PM
engine light at high RPM mattie 2004 - 2008 Ford F150 1 11-18-2009 11:09 PM
ABS light on dash tom.bullock 1997 - 2003 Ford F150 11 04-03-2009 10:29 AM
4x4 dash light american732 Maintenance Shop 2 12-20-2008 02:07 PM

Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 10:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.