Ford F150 Forum - Community of Ford Truck Fans

Ford F150 Forum - Community of Ford Truck Fans (http://www.f150forum.com/)
-   2004 - 2008 Ford F150 (http://www.f150forum.com/f4/)
-   -   2008 F150, Lincoln nav sytem to replace stock radio. (http://www.f150forum.com/f4/2008-f150-lincoln-nav-sytem-replace-stock-radio-261569/)

Scott Caesar 05-30-2014 01:43 PM

2008 F150, Lincoln nav sytem to replace stock radio.
 
3 Attachment(s)
OK Im missing something. my stock radio just quit one day because I punched it the night before. (it talked back to me,lol) anywho, I bought an aftermarket pioneer that my wife hates, so I found a Lincoln Mark LT Nav. system on ebay cheap like $100.00 cheap. I just got it in the mail today went to plug everything up, and viola it start to power up, and immediately power back down. it got as far starting up as to display the ford logo on the screen. I have read on here about guys getting these things re-programmed, so is that something I can do at the dealer? meaning can I take it down to the dealer and drop it off by itself or do I have to leave the truck with it?

johnny_tucson 05-30-2014 02:48 PM

Sub'd. I'm curious about this. So the mark lts had nav available. Can't wait to see what you find out!

stringer 05-30-2014 02:55 PM

Sub'd as well...

Bobkat65 05-30-2014 08:45 PM

They can be reprogrammed, if you can find the right dealer. I found a guy online that did mine for around $100. I had to ship him the radio and he had it a couple days.

But it sounds like you may have gotten a bad radio. It should power up and work the programming just turns on/off the options for your vehicle. If it powers up and then shuts down I think there may be an issue with the unit. The guy that did mine also does repairs. PM me and I'll send you his info.

Inkdot22 06-01-2014 01:39 PM

You may want to go back and re-read your ebay auction... that unit sounds like it has some issues which may have contributed to you getting it so cheap...

Also... if the navi came out of a Mark LT, the "Lincoln" logo should come up when it powers up, not the "Ford" logo...

I would contact the seller and try for a refund... The money you put into repairing it can just go into a unit that already works...

Here's one that's priced under $350 and also has a "best offer" option....

Good luck!!


Scott Caesar 06-04-2014 05:25 AM

Quote:

Originally Posted by Bobkat65 (Post 3522335)
They can be reprogrammed, if you can find the right dealer. I found a guy online that did mine for around $100. I had to ship him the radio and he had it a couple days.

But it sounds like you may have gotten a bad radio. It should power up and work the programming just turns on/off the options for your vehicle. If it powers up and then shuts down I think there may be an issue with the unit. The guy that did mine also does repairs. PM me and I'll send you his info.





If it can be fixed for $100.00 and a veryfew days I am game. To get an "exact fit" Alpine (witch is the only one avail.) Its $800-$1k. so $200.00+shipping for a working stock unit is worth it to me. ty for the reply and the info on the bad radio. I do appreciate it, and thank you for your time.

Scott Caesar 06-04-2014 05:27 AM

Quote:

Originally Posted by stringer (Post 3521740)
Sub'd as well...

Sub'd????

Scott Caesar 06-04-2014 05:30 AM

Here is the Ebay auction that I won/(maybe lost LOL)

stringer 06-05-2014 10:06 AM

Quote:

Originally Posted by Scott Caesar (Post 3529711)
Sub'd????

Sub'd = Subscribed to thread. I am curious as to what you find lol


All times are GMT -4. The time now is 11:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com