2007 F150 Engine sputters and rattles in gear near idle. - Ford F150 Forum - Community of Ford Truck Fans
Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


2007 F150 Engine sputters and rattles in gear near idle.

Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-26-2015, 05:57 PM   #1
Junior Member
 
Join Date: Jun 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2007 F150 Engine sputters and rattles in gear near idle.

Hello forum, this is my first post. I have a 2007 f150 fx4 5.4l with 113k miles. Recently, it started running poorly when in gear and near idle speed. The engine will sputter and make rattling sounds. An example of this would be coasting into a parking spot or driveway. Just before coming to a complete stop it starts acting up. I can put it in park, rev it a couple of times, and it snaps out of it. Then if I put it in reverse and begin to back up at idle speed it starts sputtering again. The only time it happens is during very low speed maneuvers. Normal driving and stop lights don't seem to be an issue. Does anyone have any idea what could be wrong? Thanks in advance!
maco7037 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 06-26-2015, 08:28 PM   #2
Junior Member
 
Join Date: Jun 2015
Location: Central, AL, USA
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Could be in your VCT solenoids. They are known for causing idle issues when coming to a stop, going into reverse, etc. When the solenoid sticks, it can cause your camshaft to stay advanced when coming to a stop, causing a misfire or rough idle. There is one solenoid on each engine bank and they are about $50-55 per. It's not a guaranteed fix, but it's common, none-the-less.

Part # 8L3Z-6M280-B
__________________

2007 Ford F-150 Lariat SuperCab 2wd 5.4L 3V
07F150Lariat5.4 is online now   Reply With Quote
Old 06-28-2015, 10:02 PM   #3
Junior Member
 
Join Date: Jun 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Thanks Lariat. I'll check that out. Hopefully that is a fix I can tackle myself. Did the plugs and coils last fall and that was a bear-broke 4 out of eight! It does have an exhaust leak at the manifold. Could that effect the way the motor runs?
maco7037 is offline   Reply With Quote
Old 06-28-2015, 10:17 PM   #4
Junior Member
 
Join Date: Jun 2015
Location: Central, AL, USA
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

No problem. As for exhaust manifolds effecting how it runs... not really. They mainly just make a lot of noise on cold starts. But your rattling and poor running issue is most likely in your variable cam timing. Especially since you say it happens at low speeds, etc.

I would start with the solenoids. There is a video on YouTube of replacing them by the username "FordTechMakuloco". His video is very in-depth with the procedure.
__________________

2007 Ford F-150 Lariat SuperCab 2wd 5.4L 3V
07F150Lariat5.4 is online now   Reply With Quote
Old 06-29-2015, 02:10 AM   #5
Senior Member
 
WhyteLobo07's Avatar
 
Join Date: Jan 2014
Location: SoCal
Posts: 242
Thanked 24 Times in 23 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by maco7037 View Post
Hello forum, this is my first post. I have a 2007 f150 fx4 5.4l with 113k miles. Recently, it started running poorly when in gear and near idle speed. The engine will sputter and make rattling sounds. An example of this would be coasting into a parking spot or driveway. Just before coming to a complete stop it starts acting up. I can put it in park, rev it a couple of times, and it snaps out of it. Then if I put it in reverse and begin to back up at idle speed it starts sputtering again. The only time it happens is during very low speed maneuvers. Normal driving and stop lights don't seem to be an issue. Does anyone have any idea what could be wrong? Thanks in advance!
I also have an 07 and I am experiencing the same thing, I cleaned the throttle body and maf sensor today and I will admit it feels smoother and has not sputtered yet, I hope this is the solution, if not I am going to have try the vct solenoid. I would suggest you clean the throttle body and maf sensor, it the cheapest and easiest way to start.
__________________
07 Lariat Screw 2wd oxford white w/arizona gold bottom, kenwood indash & kenwood 3-ways, Si/SO flowmaster 10 series, 20% tint front/stock rear, white ford oval overlays, ptm mirror caps, ford LOBO emblems, lowered 3" front w/belltech drop struts & 5" w/DJM flip kit.
WhyteLobo07 is offline   Reply With Quote
The Following User Says Thank You to WhyteLobo07 For This Useful Post:
bullwinkle89 (06-29-2015)
Old 06-29-2015, 02:10 AM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 11:42 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.