Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-25-2009, 09:28 AM   #1
Junior Member
 
Join Date: Dec 2009
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2005 5.4 liter Running Rough

My 2005 F-150 with 44,500 miles and a 5.4 liter motor is suddenly idling rough. It is also highly noticeable when driving on the freeway. I have replaced the fuel filter as well as the air filter, and filled up with a tank of high octane. I took it to a local shop and it did not bring up any codes on their machine, and the check engine light is not on. He recommended changing the plugs at a cost of $340. He offered no guarantees that it would fix the problem. He basically said you have to start somewhere, and that is the first place to start. Also, I purchased an extended warranty on the truck when I bought it new, which covers the motor and drive train for 70,000 miles or five years. Any suggestions would be greatly appreciated.
jrhooper1963 is offline   Reply With Quote
Old 12-25-2009, 08:30 PM   #2
Junior Member
 
Join Date: Dec 2009
Posts: 2
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Anyone?
jrhooper1963 is offline   Reply With Quote
Old 12-25-2009, 08:47 PM   #3
Senior Member
5 Year Member
 
Join Date: Nov 2007
Posts: 291
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

could be a plug, could be a coil, could be an injector, if anything was really wrong I'm surprised it didn't throw a code.

If your mechanic is willing to do the plugs for that price, get it in writing, and make sure he knows if the plugs snap off in the head, as they are prone to do, he eats the time labor, parts, and tool to get them out. Make sure he understands the process and has a copy of the TSB

If it is a Ford warranty hand it to the dealer and make them fix it, their scanners are far superior to anything available to local shops.

Last edited by Neggy; 12-25-2009 at 08:51 PM.
Neggy is offline   Reply With Quote
Old 12-25-2009, 11:49 PM   #4
Junior Member
 
Join Date: Nov 2009
Posts: 17
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

that happened to my Silverado, turned out to be the plugs
GL
Medina_602 is offline   Reply With Quote
Old 12-25-2009, 11:49 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Running 4.9 psurob 1987 - 1996 F150 4 04-27-2010 06:42 AM
Rough running 99 Jeepstercj5 1997 - 2003 Ford F150 4 11-03-2009 08:03 PM
running rough ozzie56 1997 - 2003 Ford F150 3 11-05-2008 06:17 PM
Running Rough/Down on power BigBadJon 1987 - 1996 F150 5 07-18-2008 03:42 PM
Rough running 5.4 Need help bad boyfromdixie88 General F150 Discussion 4 01-18-2008 08:06 PM

 

The Mustang Source
All times are GMT -4. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.