Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 03-08-2012, 07:41 PM   #1
Junior Member
 
Join Date: Mar 2012
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2004 f150 5.4L rough idle

I bought my truck from a used car dealership about a year ago and when i bought it the check engine light came on. I scanned the truck and it came up as the camshaft positioning sensor bank 2 circuit malfunction...truck was idling low but seemed to only do it when a/c was on so didnt worry to much about it just didnt use my a/c and it didnt idle low anymore. I took my truck into ford the other day to get an oil change done and conviently within the half hour of picking my truck up it started running terribly. When coming to a stop or when stopped the truck idles around 200 rpm and i actually have to put it in neutral and rev it up to over 1000rpm so it wont stall. Took it back to ford and they told me that it was my cam phasers and its just a coincidence that it happened as soon as i got the oil changed. They are telling me that it is about a $2000 job and i would really not like to spend that much. Just wondering if anyone else has had this issue and how it was fixed. Don't know if i trust the dealership to much.
jmartin89 is offline   Reply With Quote
Old 03-08-2012, 07:41 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

The Mustang Source
All times are GMT -4. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.