Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-18-2013, 03:32 AM   #1
Junior Member
 
Join Date: May 2013
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 04 xlt 150 problems

can some one please with the problem we are having..
we are working on a 2004 f150 xlt 2 wheel drive 4.6.
Here is how it went.
we changed oil and fuel filter.Drove truck 3 or 4 miles came back to shop,turned truck off. Went to start it 3 hrs later and no start.. just turns over like there is no fuel.scanned it with modis and codes came up
p0121,p2104,p2106,p2111,p2135.... so we switch out the throttle body and the truck fired up and ran fine. Checked the codes and they were gone. so reset all settings etc.. ran the truck back and forth to work for 2 days , (about 50 miles or so) then driving back to work it died on me driving down... towed it back to my shop,so we decided to swap out fuel pump..put new fuel pump in,fired right up.. sounds perfect,it ran about 2 mins then died....now we are back to same problem, the truck turns over (like there is no fuel) and doesn't fire....fuel press on modis says 48 -54 psi +-..
after we mess with the pump off and on with the scanner, it did fire up ran smooth for 1 min then soon as you touch gas, dies... now it wont start at all...
can someone please if you have had this problem? thanks for the input..

Last edited by courtesycab; 05-18-2013 at 03:37 AM.
courtesycab is offline   Reply With Quote
Old 05-18-2013, 04:52 AM   #2
Member
 
jmoon4's Avatar
 
Join Date: Feb 2013
Location: Greer, South Carolina
Posts: 88
Mentioned: 1 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

Someone else with more input may chime in, but you could check the fuel pump driver module located near the spare tire. If it's corroded real bad, then chances are its bad.
__________________
Sony navigation w/ backup camera, Westin bull bar, Westin 6" round off road lights, black headlights, black taillights, flowmaster exhaust, 6" Rough Country lift, Bilstein struts, 20"matte black Fuel Pump wheels, 35x12.5 Durun Terrain Grabber tires.
jmoon4 is offline   Reply With Quote
Old 05-18-2013, 08:18 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

we checked that and its fine, we have good fuel pressure etc... on a cold start it will fire up and run about 45 sec perfect then dies...
courtesycab is offline   Reply With Quote
Old 05-18-2013, 09:22 PM   #4
Senior Member
5 Year Member
 
primalurges's Avatar
 
Join Date: Mar 2009
Posts: 801
Mentioned: 1 Post(s)
Thanks: 1
Thanked 41 Times in 40 Posts
Feedback Score: 0 reviews
Default

Have you checked fuel filter to ensure arrow is pointing at line going to engine?
primalurges is offline   Reply With Quote
Old 05-18-2013, 09:25 PM   #5
Junior Member
 
Join Date: May 2013
Posts: 3
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

yes... that it what i thought at 1st... i put a wix on there , took it off tried another too....seem like it is in the engine compartment?
courtesycab is offline   Reply With Quote
Old 05-18-2013, 09:58 PM   #6
Senior Member
 
Especial86's Avatar
 
Join Date: Dec 2011
Posts: 3,092
Mentioned: 3 Post(s)
Thanks: 126
Thanked 264 Times in 226 Posts
Feedback Score: 1 reviews
Default

Quote:
Originally Posted by courtesycab View Post
yes... that it what i thought at 1st... i put a wix on there , took it off tried another too....seem like it is in the engine compartment?
Is your FPDM on risers? If not, then change it anyway... You have to remove it in order to see how badly its corroded sometimes..
Especial86 is offline   Reply With Quote
Old 05-19-2013, 02:13 PM   #7
Mark
5 Year Member
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 17,501
Mentioned: 5 Post(s)
Thanks: 167
Thanked 387 Times in 339 Posts
Feedback Score: 1 reviews
Default

^^^Agree^^^ remove it and check it...can be intermittent
__________________
08 FX4... Flowmaster Exhaust, line-X, Sky Jacker leveling kit. 295/65/20 Nitto trails mounted on 20 X 9 Carol Shelby wheels. AIRAID CAI. Projector/Halo headlamps and LED Tails & 3rd brake lights,custom upper and lower Grill. Edge Evolution. Interior/Exterior LED lighting, NFAB step bars.
techrep is offline   Reply With Quote
Old 05-19-2013, 02:13 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.