04 xlt 150 problems - Ford F150 Forum - Community of Ford Truck Fans



04 xlt 150 problems

Reply
 
 
 
Thread Tools Search this Thread
Old 05-18-2013, 04:32 AM   #1
Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 04 xlt 150 problems

can some one please with the problem we are having..
we are working on a 2004 f150 xlt 2 wheel drive 4.6.
Here is how it went.
we changed oil and fuel filter.Drove truck 3 or 4 miles came back to shop,turned truck off. Went to start it 3 hrs later and no start.. just turns over like there is no fuel.scanned it with modis and codes came up
p0121,p2104,p2106,p2111,p2135.... so we switch out the throttle body and the truck fired up and ran fine. Checked the codes and they were gone. so reset all settings etc.. ran the truck back and forth to work for 2 days , (about 50 miles or so) then driving back to work it died on me driving down... towed it back to my shop,so we decided to swap out fuel pump..put new fuel pump in,fired right up.. sounds perfect,it ran about 2 mins then died....now we are back to same problem, the truck turns over (like there is no fuel) and doesn't fire....fuel press on modis says 48 -54 psi +-..
after we mess with the pump off and on with the scanner, it did fire up ran smooth for 1 min then soon as you touch gas, dies... now it wont start at all...
can someone please if you have had this problem? thanks for the input..

Last edited by courtesycab; 05-18-2013 at 04:37 AM.
courtesycab is offline   Reply With Quote
Old 05-18-2013, 05:52 AM   #2
Member
 
jmoon4's Avatar
 
Join Date: Feb 2013
Location: Greer, South Carolina
Posts: 87
Thanked 2 Times in 2 Posts
Default

Someone else with more input may chime in, but you could check the fuel pump driver module located near the spare tire. If it's corroded real bad, then chances are its bad.
jmoon4 is offline   Reply With Quote
Old 05-18-2013, 09:18 PM   #3
Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

we checked that and its fine, we have good fuel pressure etc... on a cold start it will fire up and run about 45 sec perfect then dies...
courtesycab is offline   Reply With Quote
Old 05-18-2013, 10:22 PM   #4
Senior Member
5 Year Member
 
primalurges's Avatar
 
Join Date: Mar 2009
Posts: 899
Thanked 48 Times in 46 Posts
Default

Have you checked fuel filter to ensure arrow is pointing at line going to engine?
primalurges is offline   Reply With Quote
Old 05-18-2013, 10:25 PM   #5
Junior Member
Thread Starter
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes... that it what i thought at 1st... i put a wix on there , took it off tried another too....seem like it is in the engine compartment?
courtesycab is offline   Reply With Quote
Old 05-18-2013, 10:58 PM   #6
Senior Member
iTrader: (1)
 
Especial86's Avatar
 
Join Date: Dec 2011
Posts: 3,693
Thanked 336 Times in 290 Posts
Default

Quote:
Originally Posted by courtesycab View Post
yes... that it what i thought at 1st... i put a wix on there , took it off tried another too....seem like it is in the engine compartment?
Is your FPDM on risers? If not, then change it anyway... You have to remove it in order to see how badly its corroded sometimes..
Especial86 is offline   Reply With Quote
Old 05-19-2013, 03:13 PM   #7
Mark
5 Year Member
iTrader: (1)
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 27,604
Thanked 1,175 Times in 1,042 Posts
Default

^^^Agree^^^ remove it and check it...can be intermittent
techrep is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
"Squeeking" noise in rear NorCal_Fords 2015 - Present Ford F150 4 05-29-2016 10:08 PM
Replaced front fuel pump; still not working spinningchurro 1987 - 1996 F150 6 10-23-2015 11:01 PM
Little to almost no power while towing reader585 Maintenance Shop 2 09-10-2015 09:10 AM
Wireless/Internet Teek 2015 - Present Ford F150 4 09-03-2015 01:36 PM
2004 Roush F150 issue in reverse vanguard2010 Maintenance Shop 0 09-02-2015 09:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:43 AM.


Copyright 2006 - 2016 F150Forum.com