Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 11-17-2012, 07:58 AM   #1
Junior Member
 
Join Date: Apr 2011
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default Tsb 12-10-19

This TSB is for the shudder/miss problem with the 3.5 EcoBoost. Who has had it done and did it fix the problem? I haven't had the additional deflector plate add but am thinking of trying this TSB as it changes the CAC cooler and has a new computer program. ANYONE???
F150RT is offline   Reply With Quote
Old 11-17-2012, 11:23 AM   #2
Senior Member
 
Rockhopper's Avatar
 
Join Date: Jan 2012
Posts: 242
Mentioned: 0 Post(s)
Thanked 35 Times in 27 Posts
Feedback Score: 0 reviews
Default

There is a "sticky" on this in the 2011+ engines section. Should give you the info your looking for. If not, post your question there to get a better response.
__________________
2012 Silver Plat Screw 4x4 Eco 3.55EL. 1.5" AS Level.2" Rear Block. 275/60/20. Harley Heads. LED Tails. Airaid CAI. Full Race Exhaust.
Rockhopper is offline   Reply With Quote
Old 11-17-2012, 12:39 PM   #3
Junior Member
 
Join Date: Oct 2012
Posts: 21
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

I just had the 12-10-19 TSB done and everything seems good. Shifting is more smooth than before and power seems the same. I couldn't get it to shutter at 55-60 anymore, but time will tell about the limp mode issue.

2012 FX4 Ecoboost 10k miles
Sweet12FX4 is offline   Reply With Quote
Old 11-17-2012, 04:24 PM   #4
Senior Member
 
kmaximus's Avatar
 
Join Date: Aug 2011
Location: Columbia, SC
Posts: 468
Mentioned: 3 Post(s)
Thanked 87 Times in 62 Posts
Feedback Score: 0 reviews
Default

I'm having this done week of the 26th. I experienced the acceleration lock out and shake once.....hope this takes care of it.

the dealership I'm dealing with has been great regarding this so far.....
kmaximus is offline   Reply With Quote
Old 11-17-2012, 04:50 PM   #5
TTV6>V8
 
Logan24's Avatar
 
Join Date: Feb 2010
Location: Edmonton, Alberta
Posts: 1,631
Mentioned: 2 Post(s)
Thanked 221 Times in 155 Posts
Feedback Score: 0 reviews
Default

Good luck with your trucks guys. I hope Ford has found a solution to this problem so you guys can fully enjoy your trucks!!
__________________

Logan - 2012 F-150 FX4 EB Sterling Grey Metallic
Looks - Blacked out Bilinvic Retro's, LED Everything, Truxedo Lo-Pro QT, 30" SR Rigid Light Bar, Plasti-dipped Emblems and Rims
Performance - AFE Stage 2 CAI, SCT SF3, SOLO MR400, Roush Black LED Boost Gauge
Logan24 is offline   Reply With Quote
Old 11-18-2012, 01:39 PM   #6
G2G
Senior Member
 
Join Date: Dec 2011
Posts: 129
Mentioned: 0 Post(s)
Thanked 10 Times in 7 Posts
Feedback Score: 0 reviews
Default

I've had this TSB performed. So far I haven't had a problem, been in conditions that were optimal for the problem twice but neither time did it happen. I'm very happy so far. Roughly 500 miles since TSB was performed.

- Steiner
G2G is offline   Reply With Quote
Old 12-22-2012, 10:04 AM   #7
Junior Member
 
Join Date: Dec 2012
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Tsb 12 10 19

Hello fellow Ecoboost owners!

History of truck: Purchased (new) Sept. 9th 2012 F150 XLT Ecoboost. as of 21 December 1654 miles.

Well my journey started on 25 November, when the shudder showed while towing a travel trailer. Turned the truck into the dealer on the 26th of November with 1575 miles on the truck.

The service writer said that they were looking into the problem, then after a couple of weeks they said they had a fix and we are waiting for parts.

The parts showed, and were installed. We got the truck back on the 20th of December. We drove the truck with out a trailer connected, 1 minor hesitation at take off from a stop sign but no other problems. Next day, while picking the kids up from school, the engine was at idle for about 10 minutes. Rolled slow up to the stop sign, hit the gas to get through the intersection, and boom, major hesitation. Drove about a half mile to get to an area where I could get into the gas and build up some speed... hesitation, shudder, and check engine light again.

Drove strait to the dealership, they plugged in the computer and found that now the injectors and catalytic converter are the problem. Now... if you read the actual TSB one of the parts listed is the catalytic converter. I asked the service manager if ours was replaced during the first visit, and they said no, because it passed the computer tests... (well how about now)???

So, what they are having to do now, is pull the intake manifold, to check the injectors, if they are "good" then they move onto the catalytic converter.

Moral of the story, and to all who read and go in for this repair...

1. make sure they clean / flush the new intercooler before install.
2. the TSB says replace the catalytic converter, replace it!

Good luck to us all!!! Merry Christmas!
mdferguson5 is offline   Reply With Quote
Old 12-22-2012, 10:04 AM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 06:27 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.