Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?


Closed Thread
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-18-2013, 05:09 PM   #251
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,819
Mentioned: 36 Post(s)
Thanked 464 Times in 321 Posts
Feedback Score: 0 reviews
Default

I'm not brand loyal by any means this is my first Ford but GMC is the bottom of the pile. Do your homework before you jump ship....save yourself some serious grief.

A quick search finds tons of issues with their 14s and here's some reading material for you. Pull up a comfy chair and make some popcorn...let's begin:

5.3 crew 4x4 z71 5.5 bed, 2600 miles on it so far and this is what I have

Vibration at highway speeds (see vibration or shake post)

Loud motor probably normal but I could swear when it only had 150 miles on it it was hard to tell if it was even running.

Transmission seems to shift strange every once and a while but I've been told that's how they are.

Buzzing sound from speakers 2 times when I open the door in the morning sounds like electrical interference

When using cruise and I hit the "-" button I've had it speed up not down keep hitting it and it will go up 2 more miles per hour then on the four try it will go back down like it should. This has been in the last 500 miles has done it about 6 times.

After an incoming Bluetooth call ended the screen stays on phone instead of going back to the radio, you have to hit the radio icon to get it back.

The recorder for the radio has a strange glitch when playing audio back that's been recorded, sounds similar to a scratched cd.

Windshield urethane on back of cab from installing rear glass.

3/4 scrape in lower left corner of dash next to the info center looks to be from installing the bezel.

Right tail lamp bulb element was broken before it left the dealer lot (dealer sent me a new one)

Shield for the gas tank is loose and rattles (easy to fix but shouldn't be loose)

Ride seems to be very stiff even for a z71, feels more like a straight axle then IFS, hope it softens up after some more miles. There's a professional review on YouTube and they guy said it rides rougher then then the 07 to 13 model non z71 and most of the comments disagree with him. I didn't own a outgoing model but I think my 04 z71 rode softer. The 2014 seems to get high marks on ride comfort so I don't know what's going on with mine.

Not a actual problem but you have 4" info center and an 8" info center and neither tells you your in 4 wheel drive just that a "four wheel shift is in progress" while it goes into 4x4, come on GM! Just the little yellow light on the dial way over in the corner. Show a lit up 4x4 or or a picture of all four tires in orange or something after all it is 2014! This really get to me if you couldn't tell.

I can live with all the problems as long as they don't get worse except for the vibration an rough ride. I'm constantly analyzing the truck as I drive it trying to figure out what it could be. Hopefully I get some answers from the dealer when it goes in tomorrow for a second time. First time they checked tires for roundness and rebalanced and that didn't help.

For anyone thinking I'm a troll to have this many problems i don't blame you. I will post a pic of the dealer invoice for the check for roundness and rebalance but i don't know how to resize the picture from my ipad so if someone can tell me how (said file too large). Also I've owned 8 chevy trucks in my life and 4 of them have been new and I've never been so disappointed in one as this one mostly because of the vibration. On a good note gas mileage is awesome! And power is a nice step up from my old 5.3.

One more rant, I wonder how much snow I will be able to go threw this winter with the 9" of ground clearance from the front valance. Maybe it will act like a plow for the front tires.
Edited by Silver space ship, 04 August 2013 - 11:17 PM.


21 more pages of reading material. Plenty of appoligists etc etc. source:

http://www.gm-trucks.com/forums/topi...h-their-truck/
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline  
Old 10-18-2013, 05:17 PM   #252
Senior Member
 
Grandpa's Grocery Getter's Avatar
 
Join Date: Aug 2012
Location: Vancouver, BC - Canada
Posts: 2,057
Mentioned: 0 Post(s)
Thanked 204 Times in 157 Posts
Feedback Score: 0 reviews
Default

I still Love my 2012 and Grin everytime I drive it
( like a Jackass eating cactus) BUT Ive mostly been a GM Man starting from the age 15 when I got my first 1972 GMC and fixed it up modified it......

I like the GMC over the Silverado, and now they finally done the Interior it looks good. So next Truck I get in 2016 or 2017 will be either a F-250 or Atlas or GMC, that's my thoughts but it comes down to Price and that's why I went with my 2012 XTR, It was between this and Dodge.....now that GM re did the interior its going to be a hard choice to make when its time

or I might just Keep my F150 if it holds out.........

just sayin

Grant
__________________
MOD's 2012 XTR 5.0,3.55, Pro Comp 3" kit, 2.5" block, BFG Rugged Terrian T/A 34.1", K&N 63 Kit Bushwacker Flares, BAK Flip HD, Katzkin Leather w/heat, Webasto Moon Roof, Blue LED Ambient lighting, PIAA Extreme Bulbs Head & Fog, Rigid LED Dually Floods 3" & 2"Dually Mini's, AVS Chrome Bug Skin, Huskey Liner Mud Flaps, Alpine/Infinity stereo & MTX 12"Sub, Firestone Air Bags Sherwood Door Kit
Grandpa's Grocery Getter is offline  
Old 10-18-2013, 05:35 PM   #253
Senior Member
 
Grandpa's Grocery Getter's Avatar
 
Join Date: Aug 2012
Location: Vancouver, BC - Canada
Posts: 2,057
Mentioned: 0 Post(s)
Thanked 204 Times in 157 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Azuri View Post
I'm not brand loyal by any means this is my first Ford but GMC is the bottom of the pile. Do your homework before you jump ship....save yourself some serious grief.

A quick search finds tons of issues with their 14s and here's some reading material for you. Pull up a comfy chair and make some popcorn...let's begin:

5.3 crew 4x4 z71 5.5 bed, 2600 miles on it so far and this is what I have

Vibration at highway speeds (see vibration or shake post)

Loud motor probably normal but I could swear when it only had 150 miles on it it was hard to tell if it was even running.

Transmission seems to shift strange every once and a while but I've been told that's how they are.

Buzzing sound from speakers 2 times when I open the door in the morning sounds like electrical interference

When using cruise and I hit the "-" button I've had it speed up not down keep hitting it and it will go up 2 more miles per hour then on the four try it will go back down like it should. This has been in the last 500 miles has done it about 6 times.

After an incoming Bluetooth call ended the screen stays on phone instead of going back to the radio, you have to hit the radio icon to get it back.

The recorder for the radio has a strange glitch when playing audio back that's been recorded, sounds similar to a scratched cd.

Windshield urethane on back of cab from installing rear glass.

3/4 scrape in lower left corner of dash next to the info center looks to be from installing the bezel.

Right tail lamp bulb element was broken before it left the dealer lot (dealer sent me a new one)

Shield for the gas tank is loose and rattles (easy to fix but shouldn't be loose)

Ride seems to be very stiff even for a z71, feels more like a straight axle then IFS, hope it softens up after some more miles. There's a professional review on YouTube and they guy said it rides rougher then then the 07 to 13 model non z71 and most of the comments disagree with him. I didn't own a outgoing model but I think my 04 z71 rode softer. The 2014 seems to get high marks on ride comfort so I don't know what's going on with mine.

Not a actual problem but you have 4" info center and an 8" info center and neither tells you your in 4 wheel drive just that a "four wheel shift is in progress" while it goes into 4x4, come on GM! Just the little yellow light on the dial way over in the corner. Show a lit up 4x4 or or a picture of all four tires in orange or something after all it is 2014! This really get to me if you couldn't tell.

I can live with all the problems as long as they don't get worse except for the vibration an rough ride. I'm constantly analyzing the truck as I drive it trying to figure out what it could be. Hopefully I get some answers from the dealer when it goes in tomorrow for a second time. First time they checked tires for roundness and rebalanced and that didn't help.

For anyone thinking I'm a troll to have this many problems i don't blame you. I will post a pic of the dealer invoice for the check for roundness and rebalance but i don't know how to resize the picture from my ipad so if someone can tell me how (said file too large). Also I've owned 8 chevy trucks in my life and 4 of them have been new and I've never been so disappointed in one as this one mostly because of the vibration. On a good note gas mileage is awesome! And power is a nice step up from my old 5.3.

One more rant, I wonder how much snow I will be able to go threw this winter with the 9" of ground clearance from the front valance. Maybe it will act like a plow for the front tires.
Edited by Silver space ship, 04 August 2013 - 11:17 PM.

21 more pages of reading material. Plenty of appoligists etc etc. source:

http://www.gm-trucks.com/forums/topi...h-their-truck/
WoW!!

and I thought I had it bad.........lol that really sucks!

I did notice on my 2012 5.0 the Engine is louder and ticking a bit before it was really quiet, noticed the difference pulling up to a drive through wall, and now shutting it off .....

but they checked it out said its either fuel rails or injectors which is normal......if its normal why was it so quiet for the first 3000km's....
now it's louder.....I couldn't even tell it was running before I can now...there is a difference (im not talking about when the fan kicks in either)

Glad my issue's are fixed.on my 2012.....on our FX4 5.4 we haven't had any issue's with it.....except people driving into the side of 3 times now....same side rear quarter......lol...but no mechanical issue's so far....
__________________
MOD's 2012 XTR 5.0,3.55, Pro Comp 3" kit, 2.5" block, BFG Rugged Terrian T/A 34.1", K&N 63 Kit Bushwacker Flares, BAK Flip HD, Katzkin Leather w/heat, Webasto Moon Roof, Blue LED Ambient lighting, PIAA Extreme Bulbs Head & Fog, Rigid LED Dually Floods 3" & 2"Dually Mini's, AVS Chrome Bug Skin, Huskey Liner Mud Flaps, Alpine/Infinity stereo & MTX 12"Sub, Firestone Air Bags Sherwood Door Kit

Last edited by Grandpa's Grocery Getter; 10-18-2013 at 05:50 PM.
Grandpa's Grocery Getter is offline  
Old 10-18-2013, 05:37 PM   #254
Senior Member
 
ns_redneck's Avatar
 
Join Date: Apr 2011
Location: mississagua on canada
Posts: 2,417
Mentioned: 2 Post(s)
Thanked 294 Times in 248 Posts
Feedback Score: 0 reviews
Default

my uncles chevy broke the leaf springs going over the train tracks. it was 1 and a half years old. now it doesn't like to start in the cold. they blamed is cold air intake so he took it off. but they still can't figure out what's wrong.
__________________

2011 f-150 xlt with xtr package. 5.0L. sync system. lariet chrome mesh grill. chrome mirror caps. magnaflow exhaust. xtang trifecta soft tri fold taunnoe cover.harley davidson taillights. 20 inch rims. toyo open country at2's 275/60/20. dupli colour roll in bed liner.
ns_redneck is online now  
Old 10-18-2013, 05:40 PM   #255
Senior Member
 
RES4CUE's Avatar
 
Join Date: Feb 2010
Location: Manassas Va
Posts: 6,370
Mentioned: 15 Post(s)
Thanked 866 Times in 672 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Azuri View Post
I'm not brand loyal by any means this is my first Ford but GMC is the bottom of the pile. Do your homework before you jump ship....save yourself some serious grief. A quick search finds tons of issues with their 14s and here's some reading material for you. Pull up a comfy chair and make some popcorn...let's begin: 5.3 crew 4x4 z71 5.5 bed, 2600 miles on it so far and this is what I have Vibration at highway speeds (see vibration or shake post) Loud motor probably normal but I could swear when it only had 150 miles on it it was hard to tell if it was even running. Transmission seems to shift strange every once and a while but I've been told that's how they are. Buzzing sound from speakers 2 times when I open the door in the morning sounds like electrical interference When using cruise and I hit the "-" button I've had it speed up not down keep hitting it and it will go up 2 more miles per hour then on the four try it will go back down like it should. This has been in the last 500 miles has done it about 6 times. After an incoming Bluetooth call ended the screen stays on phone instead of going back to the radio, you have to hit the radio icon to get it back. The recorder for the radio has a strange glitch when playing audio back that's been recorded, sounds similar to a scratched cd. Windshield urethane on back of cab from installing rear glass. 3/4 scrape in lower left corner of dash next to the info center looks to be from installing the bezel. Right tail lamp bulb element was broken before it left the dealer lot (dealer sent me a new one) Shield for the gas tank is loose and rattles (easy to fix but shouldn't be loose) Ride seems to be very stiff even for a z71, feels more like a straight axle then IFS, hope it softens up after some more miles. There's a professional review on YouTube and they guy said it rides rougher then then the 07 to 13 model non z71 and most of the comments disagree with him. I didn't own a outgoing model but I think my 04 z71 rode softer. The 2014 seems to get high marks on ride comfort so I don't know what's going on with mine. Not a actual problem but you have 4" info center and an 8" info center and neither tells you your in 4 wheel drive just that a "four wheel shift is in progress" while it goes into 4x4, come on GM! Just the little yellow light on the dial way over in the corner. Show a lit up 4x4 or or a picture of all four tires in orange or something after all it is 2014! This really get to me if you couldn't tell. I can live with all the problems as long as they don't get worse except for the vibration an rough ride. I'm constantly analyzing the truck as I drive it trying to figure out what it could be. Hopefully I get some answers from the dealer when it goes in tomorrow for a second time. First time they checked tires for roundness and rebalanced and that didn't help. For anyone thinking I'm a troll to have this many problems i don't blame you. I will post a pic of the dealer invoice for the check for roundness and rebalance but i don't know how to resize the picture from my ipad so if someone can tell me how (said file too large). Also I've owned 8 chevy trucks in my life and 4 of them have been new and I've never been so disappointed in one as this one mostly because of the vibration. On a good note gas mileage is awesome! And power is a nice step up from my old 5.3. One more rant, I wonder how much snow I will be able to go threw this winter with the 9" of ground clearance from the front valance. Maybe it will act like a plow for the front tires. Edited by Silver space ship, 04 August 2013 - 11:17 PM. 21 more pages of reading material. Plenty of appoligists etc etc. source: http://www.gm-trucks.com/forums/topi...h-their-truck/

Not to discount the OPs problems but posts like the one above have me convinced that the truck is the new SUV. I know when and when I'm not in 4wd, I don't need a little light to remind me!

Motor too loud? Really?

You see, I think a lot of these people are coming from cars that have smaller displacement and torque and aren't used to the motors and trans of trucks.

I don't know, I have a 2010 and there have been a couple little issues but nothing that I couldn't diagnose and fix myself.

Although I agree with the, you modded it and something went wrong now you want it fixed free, you need to be accountable theory but the OP did state these things happened before mods. The only thing I would criticize would be that he waited two years before doing anything about it.

I'm sure the mods, even though slight, exacerbate the problems.
__________________
2010 F150 STX Scab 4.6 3V, 6Spd, 3.73 LS diff, SCT X3 with 5 Star custome tunes, Bilinvic retrofit HIDs with FX heads, SGM buckets, flat black orbit shrouds, Morimoto 5Five ballasts, 5000k 5Five bulbs, and Evox-R projectors, Auto headlight mod, added TBC, Kenwood DDX 616 with rear cam, SGM Scorche HU surround, Infinity speakers x 4 and Sound Ordinance sub, Nitto TG 275/70-18s,
RES4CUE is offline  
Old 10-18-2013, 06:09 PM   #256
Fuggetaboutit
 
HCFX2013's Avatar
 
Join Date: Aug 2011
Location: 'Berta
Posts: 15,733
Mentioned: 64 Post(s)
Thanked 1,561 Times in 1,044 Posts
Feedback Score: 0 reviews
Default

There's always a bad one from every brand. 2014 is the first year of a brand new truck from GM.
__________________
2013 F-150 FX4 SCrew 5.0L V8 | Oxford White | 402A | 3.55 | Nav | Roof | OEM Wheelwell liners | Line-X | 20% tint | 3M Protection | Fox 2.0 Coilovers | CustomTruckSolutions Emblems | Tremor grille | 20x9 Fuel Maverick | LT295/55R20 Toyo Open Country A/TII Extremes
HCFX2013 is online now  
Old 10-18-2013, 06:36 PM   #257
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,819
Mentioned: 36 Post(s)
Thanked 464 Times in 321 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by RES4CUE View Post
Not to discount the OPs problems but posts like the one above have me convinced that the truck is the new SUV. I know when and when I'm not in 4wd, I don't need a little light to remind me!

Motor too loud? Really?

You, see, I think a lot of these people are coming from cars that have smaller displacement and torque and aren't used to the motors and trans of trucks
I totally get what your saying but the manufactures are to blame too. They are going for the SUV market with their upscale trims. Platinums and Limiteds are close or on par with high end luxury cars so the work truck of yesterday that rattles and squeaks is not acceptable to some. if you are going to cater to a new market share your product needs to meet that standard.

I just picked that post since it was a lengthy post of gripes. Feel free to go through the thread for some more substantial mechanical issues.

Quote:
Originally Posted by HardcoreFXFour View Post
There's always a bad one from every brand. 2014 is the first year of a brand new truck from GM.
My point exactly stay clear it may look good but they're not proven.

Some other stuffs to digest marking the price up to give a rebate...lol.

http://www.usatoday.com/story/money/...rices/2983109/
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline  
The Following User Says Thank You to Azuri For This Useful Post:
RES4CUE (10-18-2013)
Old 10-18-2013, 06:36 PM   #258
Senior Member
 
mamonti's Avatar
 
Join Date: Jan 2012
Location: DuBois, Pa.
Posts: 1,383
Mentioned: 4 Post(s)
Thanked 203 Times in 163 Posts
Feedback Score: 0 reviews
Default

I was just hoping that HardCore was happy for a couple of reasons first he has to pay for a truck that is not up to His (my) standards as to the problems he is having and two that I have the same problem(s) mostly including the Limp mode. I have waited myself as to the passing of time to get it fixed not because the issue didn't exist but to give Ford a chance to get it corrected. I have waited long enough and made a appointment for Thursday. Of course I do have a good relationship with my dealer and went in to see if they could order the parts so I could get it done. They know I have a pretty good knowledge mechanic wise and have even helped them out of occasion but said they had to do the diagnostics first before Ford would release the parts. So I will take it in and then wait for them to get the parts to ,,,,,,,,,,, well I have to say this ,,,,,,,,,,,, hope to fix it!!
__________________
2012 XLT EcoBoost Scab 8' bed 3.31 gears 4X4
getting 18.3, 11,300 miles lifetime 17.3

Last edited by mamonti; 10-18-2013 at 06:40 PM.
mamonti is offline  
Old 10-18-2013, 06:45 PM   #259
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,819
Mentioned: 36 Post(s)
Thanked 464 Times in 321 Posts
Feedback Score: 0 reviews
Default

@HardcoreFXFour Sorry man not I'm not intentionally trying to derail or hijack your thread but some good discussions led into other ones.
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline  
Old 10-18-2013, 06:51 PM   #260
Senior Member
 
mamonti's Avatar
 
Join Date: Jan 2012
Location: DuBois, Pa.
Posts: 1,383
Mentioned: 4 Post(s)
Thanked 203 Times in 163 Posts
Feedback Score: 0 reviews
Default

I agree every car and truck will have issues,,,, at least something you don't like about it,,, but I will have to say that I am really puzzled that so many of these problems don't have solutions.... I want to get a vehicle that if something goes wrong that you take it to the dealer and they fix it,,, not throw parts at it in a hope that they will not see you return. I guess I am going to start backing off on Ford as Toyota, Chevy and Dodge have issues they are not solving either... I guess my problem is I wish I would have known this before I got rid of my Nissan! Again I am not saying they are perfect either but it was paid for and the money I spent to get a new F150 would have allowed many years of repairs to a truck I drove 2 years without any main issues! So I am not sure what to do if they don't get with it and come up with a true fix for the main issues as I am not one to get rid of a truck because the stereo sucks or sync works once in a great while... I can replace them with better components but not the motor, suspension, steering or rear! Now I will say I really do love the truck,,, much more than the Nissan and even though I wanted to see better MPG I am getting the same as I did in the Nissan and it is almost twice it's size!!! The real reason believe it or not I went with a Ford instead of another Nissan was the dealers... Not that I had a bad experience with a Nissan one just that you have a Ford dealer in every little town and I had to drive at least 1.5 hours to get to the nearest Nissan dealer...
__________________
2012 XLT EcoBoost Scab 8' bed 3.31 gears 4X4
getting 18.3, 11,300 miles lifetime 17.3

Last edited by mamonti; 10-18-2013 at 06:55 PM.
mamonti is offline  
Old 10-18-2013, 06:51 PM
 
 
 
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:01 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.