Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-17-2010, 07:45 PM   #1
Senior Member
5 Year Member
 
Join Date: Sep 2009
Posts: 149
Mentioned: 0 Post(s)
Thanked 20 Times in 12 Posts
Feedback Score: 0 reviews
Question Sony Nav Radio / SYNC stopped working

Hi All,
I have an 09 F150 SCrew w/ Nav radio and SYNC. Truck is 9 mos. old, has been working great. Today, for some unknown reason, the radio display was dead. No current to the on/off switch for the radio. SYNC was also dead, with no response from the steering wheel switch.

I checked the fuses in the lower right kick panel area for the radio, radio display and the SYNC: all were intact.

Does anyone have any idea what is wrong or what I can check next before I commit the truck to the dealer for ? days? I'm out of ideas. Thanks.
danonbar is offline   Reply With Quote
Old 05-17-2010, 08:20 PM   #2
Senior Member
 
shotgun's Avatar
 
Join Date: Oct 2009
Posts: 1,291
Mentioned: 0 Post(s)
Thanks: 0
Thanked 9 Times in 4 Posts
Feedback Score: 0 reviews
Default

Try pulling the Sync fuse. If that doesn't work and the Nav screen is working, try a Master Reset.

If that doesn't work I'm afraid the dealer is your only option.
shotgun is offline   Reply With Quote
Old 05-18-2010, 02:14 PM   #3
Senior Member
5 Year Member
 
Join Date: Sep 2009
Posts: 149
Mentioned: 0 Post(s)
Thanked 20 Times in 12 Posts
Feedback Score: 0 reviews
Default

The radio and navigation display, along with the SYNC was completely inop. Like there was no power to any of it. I pulled the fuses and that didn't help, but disconnecting the battery for 15 minutes apparently reset everything, and now it is working just fine again.

Curious to know what caused that in the first place, but the reset corrected whatever it was. Thank you.
danonbar is offline   Reply With Quote
The Following User Says Thank You to danonbar For This Useful Post:
Fletch87 (10-05-2012)
Old 05-20-2010, 09:54 AM   #4
Member
 
Join Date: Apr 2010
Location: Minnesota
Posts: 51
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by danonbar View Post
The radio and navigation display, along with the SYNC was completely inop. Like there was no power to any of it. I pulled the fuses and that didn't help, but disconnecting the battery for 15 minutes apparently reset everything, and now it is working just fine again.

Curious to know what caused that in the first place, but the reset corrected whatever it was. Thank you.
Thanks for sharing the disconnect battery fix. This will be handy knowledge to have should this ever happen to my truck.

Cheers!
kdjasper is offline   Reply With Quote
Old 06-02-2011, 04:49 PM   #5
Junior Member
 
Join Date: Mar 2011
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default F150 Nav/controls cutting off

L&G,

I am on vacation and of course using the nav in my brand new truck when all of a sudden the radio is playing but I have no control over the nav, radio or controls. It would not even turn on or off. I stopped, cut off the engine and restarted and it functioned fine. Anyone with ideas before I take it in?

Thanks
toytruck is offline   Reply With Quote
Old 06-03-2011, 12:41 PM   #6
Member
 
BubbaTX's Avatar
 
Join Date: May 2011
Posts: 35
Mentioned: 0 Post(s)
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Default

My 2011 F150 Sync / Iphone 3G was acting similarly. It would connect, work for awhile, then disconnect bluetooth, then play random songs, then lose control via steering wheel. I tried deleting the profiles (both Sync and iPhone), master reset, original factory settings, all no good. Also had an error when connecting via USB "unable to index all your songs. Please make sure all songs have name, artist,...". the SYNC people were worthless. All the steps below I found on various forums

Finally
1)removed Fuse #2 (labeled SYNC in owners manual), left out for about 10 mins.
2)cleaned up all songs without name/artist
3)turned off auto push on email.

So far, working for 2 days. We'll see... By the way, I suggest finding a young child to pull the Fuse#2. Behind kick panel, hidden up in corner blocked in view by a circuit breaker, ... A real pain to pull.
BubbaTX is offline   Reply With Quote
Old 06-05-2011, 10:17 AM   #7
Member
 
BubbaTX's Avatar
 
Join Date: May 2011
Posts: 35
Mentioned: 0 Post(s)
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Default Oh well....

Worked for three days as expected. When I got in the truck after work, the phone never reconnected. At least this time all I had to do was go to the Bluetooth device panel, and it reconnected right away. Not sure if that is normal behavior, but now another two days working "OK"
BubbaTX is offline   Reply With Quote
Old 02-21-2012, 04:04 AM   #8
Junior Member
 
Join Date: Feb 2012
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Radio not working - Battery disconnect

Thanks for Posting this topic and solution...saved me from making a trip to the dealership. Disconnected the battery, reconnected after ten mins or so, and it's back to normal.
RatedRR1000 is offline   Reply With Quote
Old 10-05-2012, 06:07 PM   #9
Junior Member
 
Join Date: Sep 2012
Location: Germany
Posts: 1
Mentioned: 0 Post(s)
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

SYNC quit after battery issue, found this and finally tried it out today. SYNC is back without any issues.

Thanks.
Fletch87 is offline   Reply With Quote
Old 10-05-2012, 07:16 PM   #10
Senior Member
 
JPCharmin's Avatar
 
Join Date: Jun 2012
Location: Houston
Posts: 401
Mentioned: 0 Post(s)
Thanked 24 Times in 21 Posts
Feedback Score: 0 reviews
Default

pay your sirius bill
JPCharmin is offline   Reply With Quote
Old 10-05-2012, 07:16 PM
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Acc wire stopped working OtherWeckta 1987 - 1996 F150 12 12-06-2012 04:12 PM
Sony microsoft sync hacks mods HardcoreHeath Stereo/Audio 1 08-05-2011 09:48 AM
2010 Platinum - Radio stopped working Wipedout 2009 - Present Ford F150 4 03-24-2010 01:45 PM
Sony Nav System w/Sync - Where is the Microphone? jmine 2009 - Present Ford F150 7 05-21-2009 12:29 AM
Radio Just Randomly Stopped Working?? Daytripper540 1997 - 2003 Ford F150 0 04-04-2009 04:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:24 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.