This is that retrofit thread we talked about! - Page 71 - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150
Log In 


This is that retrofit thread we talked about!

Reply
 
 
 
Thread Tools Search this Thread
Old 12-30-2013, 08:06 PM   #701
Senior Member
 
Joel_980's Avatar
 
Join Date: Jun 2013
Posts: 262
Thanked 13 Times in 12 Posts
Default

Quote:
Originally Posted by iRub1Out View Post
No there is no adapter that does what it does. You need an actual replacement. Ask TRS for one, or I may have a spare I'd be willing to toss your way just on good faith - just to help a fellow retrofit user. If TRS won't send one I'll see if my other harness still has it.
Wow. That's very unexpected for me to read. Very cool. TRS is closed till jan 6, but I should ask for the accommodating relay harness yes. If they think for some reason the cube relays are better than this black one.
Joel_980 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 12-30-2013, 08:11 PM   #702
Senior Member
 
Joel_980's Avatar
 
Join Date: Jun 2013
Posts: 262
Thanked 13 Times in 12 Posts
Default

Quote:
Originally Posted by kidastra View Post
if you want to try, take the new ballast, hook both grounds directly to the battery and test it like that
I'll go try this now with the one side (passenger), that never works anymore... See if grounding is my fault, though I expect not, as I sanded the gram to bare metal then screwed/bolted onto that.
Joel_980 is offline   Reply With Quote
Old 12-30-2013, 08:18 PM   #703
Senior Menber
 
Join Date: Oct 2010
Location: Victoria, BC
Posts: 814
Thanked 549 Times in 376 Posts
Default

TRS has indicated that the ballasts may have faulted the HID bulbs as well. Has TRS sent you new bulbs? If not, you may want to get them to.

As most of you all know, I use TRS products exclusively and have had very good success doing so. Yes, on occasion, there is a hiccup, but I always ensure my clients are taken care of. My own F150 has been running on TRS components for a few years now, including the old skool relay that would utilize the relay cubes they sent you. I have no idea why they would have sent those to you.

TRS is extremely proactive with product development, which is good....but I do believe they need to thoroughly test their updated products in all possible conditions for a longer period of time prior to releasing the product(s) for sale. You are dealing with just your own retrofitted headlights, whereas I am dealing with hundreds and any electrical gremlins cause me much grief.

The whole system is quite simple when it comes to troubleshooting. If you can, hook your ballasts up to 12v directly with the bulbs and see if they work. Try switching the bulbs on the same ballast if one doesn't fire up. This eliminates the harness to narrow down the fault finding.
bilinvic Retrofits is offline   Reply With Quote
The Following 3 Users Say Thank You to bilinvic Retrofits For This Useful Post:
bobkyle2 (01-01-2014), iRub1Out (12-30-2013), Joel_980 (12-30-2013)
Old 12-31-2013, 08:06 AM   #704
Senior Member
iTrader: (1)
 
kidastra's Avatar
 
Join Date: Jul 2012
Location: Montreal, Quebec
Posts: 3,358
Thanked 568 Times in 463 Posts
Default

any luck joel?
kidastra is offline   Reply With Quote
Old 12-31-2013, 08:46 AM   #705
Senior Member
 
Joel_980's Avatar
 
Join Date: Jun 2013
Posts: 262
Thanked 13 Times in 12 Posts
Default

No unfortunately not. I truly appreciate everyone's Help, and I so badly want to go back to stock headlights and never have to waste another minute on these things in the -30...

And then I wonder how the new ballasts would react had they shipped me a new relay harness like we had specified. ...
Joel_980 is offline   Reply With Quote
Old 12-31-2013, 09:36 AM   #706
Senior Member
iTrader: (1)
 
kidastra's Avatar
 
Join Date: Jul 2012
Location: Montreal, Quebec
Posts: 3,358
Thanked 568 Times in 463 Posts
Default

it makes no sense that the relay would work ford the old set but not the new. Maybe iRub1Out can send you that relay to test. did you try bilinvics suggestion and go straight to the 12v with the ballast?
kidastra is offline   Reply With Quote
Old 12-31-2013, 10:13 AM   #707
Problem Solver
 
iRub1Out's Avatar
 
Join Date: Feb 2011
Location: Des Moines, IA
Posts: 2,221
Thanked 351 Times in 258 Posts
Default

The relay you pictured, not the cubes, but the brick, is really different from the one I have.

Mine is gold in color - not black.

It makes sense that the cubes wouldn't work since his harness isn't designed to use them, he needs that brick one like it had originally.

Idk why TRS didn't try that.

But what Bilinvic said would be the first step. If they work flawlessly when directly wired to 12v then I would suspect the relay or something harness related.

If they still act up without the relay then it could be ballast or bulb.

But in this case my gut says its the relay.
__________________
THE IMPORTANCE OF COMMAS:
'Let's eat, grandpa!'
versus
'Let's eat grandpa!'

iRub1Out is offline   Reply With Quote
Old 12-31-2013, 10:33 AM   #708
Senior Member
iTrader: (1)
 
kidastra's Avatar
 
Join Date: Jul 2012
Location: Montreal, Quebec
Posts: 3,358
Thanked 568 Times in 463 Posts
Default

joel, where you located?
kidastra is offline   Reply With Quote
Old 12-31-2013, 11:17 AM   #709
Junior Member
 
Join Date: Nov 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Does anyone know if a ds3 bulb would work with a ds1 ballast.
Lukef150 is offline   Reply With Quote
Old 12-31-2013, 11:26 AM   #710
Problem Solver
 
iRub1Out's Avatar
 
Join Date: Feb 2011
Location: Des Moines, IA
Posts: 2,221
Thanked 351 Times in 258 Posts
Default

No it won't.

You mean D3S bulb and a D1S connector?

How did that combo come to be? That's a really strange question.
__________________
THE IMPORTANCE OF COMMAS:
'Let's eat, grandpa!'
versus
'Let's eat grandpa!'


Last edited by iRub1Out; 12-31-2013 at 11:29 AM.
iRub1Out is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm that guy Ford wants - 2016 F150-Limited sevrith 2015 - Present Ford F150 130 03-06-2016 05:03 PM
Wichita Truck Meet Manuellabour247 South Central 22 11-09-2015 10:11 AM
Recently retired, looking for open car hauler eagle1par3 Towing/ Hauling/ Plowing 15 10-10-2015 12:22 AM
Headlight problems RubberDuckie General F150 Discussion 4 09-15-2015 11:55 AM
Adaptive Learning Topkeg 2015 - Present Ford F150 3 09-11-2015 06:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 02:49 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.