Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?
Register Garage Photos FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read StoreVendor Directory

Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-29-2012, 05:16 PM   #1
Senior Member
 
Join Date: Oct 2012
Posts: 114
Mentioned: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Default Problems with 2013 ford my touch nav..

Hello first post. Just bought a 2013 king ranch solid black 4x4 ecoboost. Love the truck but the navigation is haywire! Will tell me to turn into the water while on a bridge and will show me off of the road that I am currently on.. Anyone else having this problem?? Truck had 650 miles on it, Ford had no fix yet that they know of-

Mods include: bilstein 5100 front cranked all the way up, 1'' lift in rear, and 295 65 20 trail grapplers (not a typo) on stock chrome KR 20's. Discount was suppose to order 295 60 20 and accidentally ordered 65's. They barely rub in reverse on the plastic crap in the front. NO a-arm rubbing whatsoever even at full lock. I was as shocked as you are reading this.. They measure 35.5'' tall. Getting 13.2 mpg when cold and 14.1mpg when warm.
King Onyx is offline   Reply With Quote
Old 10-29-2012, 05:25 PM   #2
Confused Member
 
TheBlack2011FX4's Avatar
 
Join Date: May 2012
Location: Nebraska
Posts: 3,191
Mentioned: 16 Post(s)
Thanks: 274
Thanked 425 Times in 350 Posts
Feedback Score: 0 reviews
Default

I'm unsure of the issues, but I know MFT has had many issues in many cars.. MFT is not very reliable lol... I have to ask, can we see some pics of the truck? Sounds amazing!!
__________________
2011 F-150 FX4 EcoBoost in Ebony Black.
Mods: 2.5" BDS Level, 35x12.5 Nitto Trail Grapplers, 17" Fuel Maverick Wheels, HID retrofits by tuxedoblack11, SOLO Performance MR400 Exhaust, Overlays by Moody Blue.
TheBlack2011FX4 is offline   Reply With Quote
Old 10-29-2012, 05:32 PM   #3
Member
 
Join Date: Nov 2010
Location: Mississippi
Posts: 38
Mentioned: 0 Post(s)
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

pics please....
__________________
2010 King Ranch SCrew 4x4, 3.73 gear ratio, 2" autospring leveling kit, 295 65 r20 Nitto Trail Grappler.
RebelKR09 is offline   Reply With Quote
Old 10-29-2012, 05:39 PM   #4
Member
 
Join Date: Jan 2011
Location: New Brunswick, Canada
Posts: 46
Mentioned: 0 Post(s)
Thanks: 1
Thanked 26 Times in 8 Posts
Feedback Score: 0 reviews
Default

MFT has its issues but is generally quite good. I've sold lots of MFT vehicles and if it was a problematic as some people make it out to be I'd be hearing about it. The first thing to try is a reboot of the system.

On the rare occasion I've had to do it, I just pull the fuses related to the MFT/Radio, key the ignition on to make sure it doesn't power up, key off and replace the fuses. Start the vehicle again and wait a minute or two for the MFT computer to reboot.

There is a second method involving a USB stick and a "Reboot App" from http://outofmytouch.com/reboot.html

I have a USB stick set up but havn't had occasion to try it.
Matt_E_Salesman is offline   Reply With Quote
The Following User Says Thank You to Matt_E_Salesman For This Useful Post:
byte (01-15-2014)
Old 10-29-2012, 08:07 PM   #5
Senior Member
 
Join Date: Oct 2012
Posts: 114
Mentioned: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Default

Well the dealership tech rebooted the nav several times with no luck...

Also how do I post pictures from my iPhone? I only have one I can post but will post more when I get back from my honeymoon in Maui-
King Onyx is offline   Reply With Quote
Old 10-29-2012, 08:10 PM   #6
Senior Member
 
eye.surgeon's Avatar
 
Join Date: Nov 2010
Location: Central California
Posts: 1,079
Mentioned: 4 Post(s)
Thanks: 72
Thanked 197 Times in 109 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by King Onyx View Post
Well the dealership tech rebooted the nav several times with no luck...

Also how do I post pictures from my iPhone? I only have one I can post but will post more when I get back from my honeymoon in Maui-
I can't help but think that your not knowing how to post pictures might be related to the problems you are having with MyTouch.
eye.surgeon is offline   Reply With Quote
The Following 2 Users Say Thank You to eye.surgeon For This Useful Post:
Legendsk (06-17-2013), RES4CUE (10-29-2012)
Old 10-29-2012, 08:13 PM   #7
Confused Member
 
TheBlack2011FX4's Avatar
 
Join Date: May 2012
Location: Nebraska
Posts: 3,191
Mentioned: 16 Post(s)
Thanks: 274
Thanked 425 Times in 350 Posts
Feedback Score: 0 reviews
Default

Here we go. In a new reply, you're going to want to hit the + button in the top right corner..

Problems with 2013 ford my touch nav..-image-671983673.jpg

Next, you'll want to hit Attach from Photos

Problems with 2013 ford my touch nav..-image-1882757471.jpg

Select the photo(s) you want

Problems with 2013 ford my touch nav..-image-261502492.jpg

Once you do this, it'll start uploading.. Eventually it will say Done Uploading.

Problems with 2013 ford my touch nav..-image-1673562164.jpg

Then click on the picture and hit Insert Inline

Problems with 2013 ford my touch nav..-image-1281901941.jpg

Hitting that is where the picture will appear in the text, the picture will pop up like this on the reply screen

Problems with 2013 ford my touch nav..-image-1819873730.jpg

And then hit send, and it should show up!! Have fun on your honeymoon!!

Problems with 2013 ford my touch nav..-image-439352459.jpg
__________________
2011 F-150 FX4 EcoBoost in Ebony Black.
Mods: 2.5" BDS Level, 35x12.5 Nitto Trail Grapplers, 17" Fuel Maverick Wheels, HID retrofits by tuxedoblack11, SOLO Performance MR400 Exhaust, Overlays by Moody Blue.
TheBlack2011FX4 is offline   Reply With Quote
Old 10-29-2012, 08:31 PM   #8
Senior Member
 
Join Date: Oct 2012
Posts: 114
Mentioned: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Default

First of all thank you The Black 2011 FX4 for your help.

Second of all let me apologize for offending eye.surgeon with my sub-par technology skills..

The only options that I have are post reply and quick reply. None of which offer a plus sign. I have AT&T.
King Onyx is offline   Reply With Quote
Old 10-29-2012, 08:35 PM   #9
Confused Member
 
TheBlack2011FX4's Avatar
 
Join Date: May 2012
Location: Nebraska
Posts: 3,191
Mentioned: 16 Post(s)
Thanks: 274
Thanked 425 Times in 350 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by King Onyx
First of all thank you The Black 2011 FX4 for your help.

Second of all let me apologize for offending eye.surgeon with my sub-par technology skills..

The only options that I have are post reply and quick reply. None of which offer a plus sign. I have AT&T.
Do you have the app? If you're not on the app, that's what you need, makes it really easy.. And don't worry about your skills, it took me a month to figure out how to post pictures using the app, I've been there!
__________________
2011 F-150 FX4 EcoBoost in Ebony Black.
Mods: 2.5" BDS Level, 35x12.5 Nitto Trail Grapplers, 17" Fuel Maverick Wheels, HID retrofits by tuxedoblack11, SOLO Performance MR400 Exhaust, Overlays by Moody Blue.
TheBlack2011FX4 is offline   Reply With Quote
Old 10-29-2012, 08:42 PM   #10
Senior Member
 
Join Date: Oct 2012
Posts: 114
Mentioned: 0 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Default

Thanks for the help! How do I get the app?
King Onyx is offline   Reply With Quote
Old 10-29-2012, 08:42 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

The Mustang Source

All times are GMT -4. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.