New CB Install - Page 2 - Ford F150 Forum - Community of Ford Truck Fans



New CB Install

Reply
 
 
 
Thread Tools Search this Thread
Old 02-01-2013, 05:40 PM   #11
Member
 
GEE1949's Avatar
 
Join Date: Jun 2012
Posts: 66
Thanks: 0
Thanked 3 Times in 2 Posts
Default

I didn't know anyone still used cbs. They were lots of fun though.
GEE1949 is offline   Reply With Quote
Old 02-01-2013, 05:45 PM   #12
Senior Member
 
RES4CUE's Avatar
 
Join Date: Feb 2010
Location: Manassas Va
Posts: 9,421
Thanked 1,500 Times in 1,193 Posts
Default

Quote:
Originally Posted by GEE1949 View Post
I didn't know anyone still used cbs. They were lots of fun though.
Heck yeah, they are great on trips with or without others. Great for wondering why the traffic is messed up or where all the cops are.

Lou's it is just damn good entertainment listening to some of the truckers! They keep me awake on my 13 hour drive from Va to Ks and back! Lol
RES4CUE is offline   Reply With Quote
Old 02-27-2013, 04:22 PM   #13
Senior Member
 
nix150's Avatar
 
Join Date: Apr 2012
Location: Northern Virginia
Posts: 915
Thanked 100 Times in 83 Posts
Default

Thought I'd share my install, inspired by this thread! I will say, that mounting that unit, in that box, was a ...but, it came out fantastic!! I'm including a pic of where I mounted my antenna too...I know I struggled with where to put that too.
Attached Thumbnails
New CB Install-f150-cb-install-1.jpg   New CB Install-f150-ant-install-1.jpg  
nix150 is offline   Reply With Quote
Old 02-27-2013, 05:06 PM   #14
0.9% is for suckers!
 
HoustonRider's Avatar
 
Join Date: Sep 2012
Location: Texas
Posts: 1,529
Thanked 167 Times in 119 Posts
Default

I have a portable Cobra, its tucks in the center console. The Antenna is the issue. I use a K40 magnetic and just run the cable outside the cab thru a hole and sit it on top. Only use it for Long drives. I would use it all the time if it was perm mounted though.

Good antenna will make or break your experience with a CB. Tune it UP
HoustonRider is offline   Reply With Quote
Old 03-01-2013, 02:44 PM   #15
Member
5 Year Member
Thread Starter
 
Fasttimez's Avatar
 
Join Date: Feb 2011
Location: Virginia
Posts: 1,040
Thanks: 0
Thanked 168 Times in 95 Posts
Default

Quote:
Originally Posted by nix150 View Post
Thought I'd share my install, inspired by this thread! I will say, that mounting that unit, in that box, was a ...but, it came out fantastic!! I'm including a pic of where I mounted my antenna too...I know I struggled with where to put that too.
Glad I could inspire your install I actually put my antenna in the same place, but on the opposite side. I put a quick disconnect on it so it comes on and off in like 5 seconds. Here's some updated pics.
Attached Images
  
Fasttimez is offline   Reply With Quote
Old 03-01-2013, 11:35 PM   #16
Senior Member
 
Join Date: Sep 2011
Location: Alberta
Posts: 223
Thanked 13 Times in 5 Posts
Default

Quote:
Originally Posted by Fasttimez View Post
Glad I could inspire your install I actually put my antenna in the same place, but on the opposite side. I put a quick disconnect on it so it comes on and off in like 5 seconds. Here's some updated pics.
pictures no worky.
72mustang is offline   Reply With Quote
Old 03-02-2013, 01:00 PM   #17
Senior Member
 
nix150's Avatar
 
Join Date: Apr 2012
Location: Northern Virginia
Posts: 915
Thanked 100 Times in 83 Posts
Default

@Fasttimez...how did you route/run your coax and power...firewall??? ....and then how did you power..straight to the battery (both hot/ground)???? Pics whould help!!!
nix150 is offline   Reply With Quote
Old 03-03-2013, 07:21 PM   #18
Big Mike
5 Year Member
 
zx14_rider's Avatar
 
Join Date: Jul 2010
Location: Upstate New York
Posts: 825
Thanked 11 Times in 10 Posts
Default

power and ground both direct to the battery thru the big grommet on the passenger side firewall..

zx14_rider is offline   Reply With Quote
The Following User Says Thank You to zx14_rider For This Useful Post:
nix150 (03-03-2013)
Old 03-03-2013, 07:45 PM   #19
Senior Member
 
RES4CUE's Avatar
 
Join Date: Feb 2010
Location: Manassas Va
Posts: 9,421
Thanked 1,500 Times in 1,193 Posts
Default

Quote:
Originally Posted by nix150 View Post
@Fasttimez...how did you route/run your coax and power...firewall??? ....and then how did you power..straight to the battery (both hot/ground)???? Pics whould help!!!
If you look at zx14 pics, he ran it through the passenger side grommet. If you look you will see a nipple on the big round grommet. If you cut off the tip of this nipple you can then run your wires through. There is one on the drivers and passenger side.

I would just find a solid ground inside the truck.

As to the coax for antennae, if you pull down back seat you can run it out of the vent or if you pop the driver or passenger side scuff plates and look under wire bundle towards the rear you will see rubber grommets and can run your coax through there to get it to the rear.
RES4CUE is offline   Reply With Quote
The Following User Says Thank You to RES4CUE For This Useful Post:
nix150 (03-03-2013)
Old 03-03-2013, 08:15 PM   #20
My Other Vehicle Flies!
5 Year Member
 
Greg Owen's Avatar
 
Join Date: Mar 2011
Location: Flemington, NJ
Posts: 292
Thanked 42 Times in 37 Posts
Default My Install

Don't know if you happened to have seen my install (old post), but here it is...
Attached Images
   
Greg Owen is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Installing backup camera 2015 F150 SCab 300A Kimber15 2015 - Present Ford F150 45 10-10-2016 02:44 PM
LED Turn Signals? Resistor? Flasher? NorCal_Fords 2015 - Present Ford F150 26 09-04-2016 10:40 AM
Can I Run 35/12.5/20??? lifted ford 2015 - Present Ford F150 27 07-28-2016 06:18 PM
Full audio upgrade (minus head unit), what did you pay? txmedic90 Stereo/Audio 16 10-06-2015 03:56 PM
Installed a Kicker VSS system in my 96' Ranger Rogel Ford Stereo/Audio 0 09-07-2015 12:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:01 AM.


Copyright 2006 - 2016 F150Forum.com