Electric Power Steering EPAS fluid? - Ford F150 Forum - Community of Ford Truck Fans



Electric Power Steering EPAS fluid?

Reply
 
 
 
Thread Tools Search this Thread
Old 01-10-2017, 01:39 PM   #1
Junior Member
Thread Starter
 
TheBurnerGuy's Avatar
 
Join Date: Jul 2014
Location: Katy, Texas
Posts: 22
Thanked 5 Times in 5 Posts
Default Electric Power Steering EPAS fluid?

Strange thing happened. After having truck parked all weekend there was about a 1 foot by 3 foot oil slick under it. Completely clear, oily, no smell. Not motor oil, not transmission fluid, not coolant. It seemed to be dripping from the EPAS and the shield below it. Cold and darks out so did not look real close. Drove it the next day about 40 miles to have a mechanic look at it and give me the bad news. Mechanic put it on the lift and there was no sign of a leak!?! Drove another 50 miles no trouble.

Steering is working fine, but I am concerned that whatever magic oil is supposed to be inside the magic EPAS box is gone, and it will die soon. Anyone else seen anything like this? Any other ideas what the fluid could be if not from the EPAS? Is there a hydraulic engine mount hidden under there somewhere? I'm stumped...
TheBurnerGuy is offline   Reply With Quote
Old 01-13-2017, 09:56 AM   #2
Junior Member
Thread Starter
 
TheBurnerGuy's Avatar
 
Join Date: Jul 2014
Location: Katy, Texas
Posts: 22
Thanked 5 Times in 5 Posts
Default

Has been nearly a week, and steering is still completely normal. Have no idea what the fluid could have been from other than the rack, but it is still working...
TheBurnerGuy is offline   Reply With Quote
Old 01-13-2017, 10:01 AM   #3
Senior Member
 
Join Date: Aug 2013
Location: Sudbury, Ontario
Posts: 689
Thanked 69 Times in 67 Posts
Default

Front dif (if you have one) maybe? I had read that the EPAS rack had transmission fluid in it, so yeah I guess it could be that you're seeing.
paintballdude05 is offline   Reply With Quote
The Following User Says Thank You to paintballdude05 For This Useful Post:
TheBurnerGuy (01-16-2017)
Old 01-16-2017, 11:39 AM   #4
Junior Member
Thread Starter
 
TheBurnerGuy's Avatar
 
Join Date: Jul 2014
Location: Katy, Texas
Posts: 22
Thanked 5 Times in 5 Posts
Default

Thanks Paintball. Mine is just 2 wheel drive. The fluid seemed kind of like transmission fluid but looked clear, no pink or red I could see when dabbed with paper towel. Transmission fluid would make sense for a sealed up gear box like that. Everything still working fine, and no more leaks. I'm stumped. If it needs to be filled with fluid surprised it would still be working.

It got below freezing when it leaked. Only other thing that I can think is that the cold made it leak a little, and then it stopped. That was coldest weather this Texas truck has ever seen.
TheBurnerGuy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mutliple engine codes Gib1031 2004 - 2008 Ford F150 3 01-12-2017 06:15 AM


Tags
electric, epas, leak, power steering

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:17 PM.


Copyright 2006 - 2016 F150Forum.com