Ecoboost Knocking Video... any ideas? - Page 2 - Ford F150 Forum - Community of Ford Truck Fans



Ecoboost Knocking Video... any ideas?

Reply
 
 
 
Thread Tools Search this Thread
Old 11-09-2013, 09:41 AM   #11
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

Quote:
Originally Posted by Fissues View Post
Seriously, all I hear is your injectors. Is there something else I am missing?
There is a knock/thud that has no pattern... maybe I am just worrying about a non issue but it's definitely something different than I have heard. Maybe try headphones. I can try to get a better video after work.


Listen carefully at 10-11 second mark and you hear a "TAP TAP"
rdkev is offline   Reply With Quote
Old 11-09-2013, 09:46 AM   #12
Shut up and Fish
 
Fissues's Avatar
 
Join Date: Mar 2013
Location: Marblehead
Posts: 336
Thanked 67 Times in 56 Posts
Default

Ugggh, I hear it now. It shows concern to me. I'll go listen to mine.
Fissues is offline   Reply With Quote
Old 11-09-2013, 10:03 AM   #13
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

I need to check the engine oil level too... If the tech neglected to put my skid plates and under body panel back on, maybe he forgot to fill the oil up all the way too.
rdkev is offline   Reply With Quote
Old 11-09-2013, 10:31 AM   #14
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

[MENTION=75227]HardcoreFXFour[/MENTION] what do you think?
rdkev is offline   Reply With Quote
Old 11-09-2013, 10:41 AM   #15
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,744
Thanked 474 Times in 330 Posts
Default

Quote:
Originally Posted by rdkev View Post
I need to check the engine oil level too... If the tech neglected to put my skid plates and under body panel back on, maybe he forgot to fill the oil up all the way too.
How many miles have you driven since your oil change?
Azuri is offline   Reply With Quote
Old 11-09-2013, 10:47 AM   #16
Ambitious but Rubbish
 
HCFX2013's Avatar
 
Join Date: Aug 2011
Location: Canada
Posts: 17,988
Thanked 1,982 Times in 1,259 Posts
Default

That's really odd..I don't think I've ever heard mine do the same thing, though I do notice a constant audible tap from my injectors and a high pitched chirping whenever it's warming up.

Something's f*cky.
HCFX2013 is offline   Reply With Quote
Old 11-09-2013, 10:48 AM   #17
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

Quote:
Originally Posted by Azuri View Post
How many miles have you driven since your oil change?
maybe 50-80
rdkev is offline   Reply With Quote
Old 11-09-2013, 10:50 AM   #18
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

[MENTION=47652]FordService[/MENTION] for the love of all things holy, please help me.
rdkev is offline   Reply With Quote
Old 11-09-2013, 10:52 AM   #19
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,744
Thanked 474 Times in 330 Posts
Default

Quote:
Originally Posted by rdkev View Post
maybe 50-80
Sounds about the right amount of miles to hear some ill effects from a botched oil change. Go have a peak at your oil level it's the easiest thing to trouble shoot by yourself at this exact moment.
Azuri is offline   Reply With Quote
The Following User Says Thank You to Azuri For This Useful Post:
rdkev (11-09-2013)
Old 11-09-2013, 10:57 AM   #20
Member
Thread Starter
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 577 Times in 404 Posts
Default

Quote:
Originally Posted by Azuri View Post
Sounds about the right amount of miles to hear some ill effects from a botched oil change. Go have a peak at your oil level it's the easiest thing to trouble shoot by yourself at this exact moment.
I will as soon as I get home. It isn't parked on a level surface at the moment so I should probably wait until it's at some place flat. The tech probably did do something wrong.... to not even put the skid and undercarriage panel back on tells me he was in a rush or just didn't care. I can also see the remnants of oil spillage near the cap to fill the oil. I am so sad right now...
[MENTION=160438]kend[/MENTION] the saga continues.
rdkev is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My new 2015 Platinum_Dawg General F150 Discussion 9 12-08-2015 11:29 PM
My new truck Platinum_Dawg 2015 - Present Ford F150 18 09-14-2015 09:02 PM
Little to almost no power while towing reader585 Maintenance Shop 2 09-10-2015 09:10 AM
Platinum 5.0 oil color and level Takeda 2015 - Present Ford F150 17 09-05-2015 11:20 PM
New member from VA! VA10 Introductions 0 09-03-2015 10:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:39 AM.


Copyright 2006 - 2016 F150Forum.com