Ecoboost Knocking Video... any ideas? - Page 2 - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150
Log In 


Ecoboost Knocking Video... any ideas?

Reply
 
 
 
Thread Tools Search this Thread
Old 11-09-2013, 08:41 AM   #11
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

Quote:
Originally Posted by Fissues View Post
Seriously, all I hear is your injectors. Is there something else I am missing?
There is a knock/thud that has no pattern... maybe I am just worrying about a non issue but it's definitely something different than I have heard. Maybe try headphones. I can try to get a better video after work.


Listen carefully at 10-11 second mark and you hear a "TAP TAP"
rdkev is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 11-09-2013, 08:46 AM   #12
Shut up and Fish
 
Fissues's Avatar
 
Join Date: Mar 2013
Location: Marblehead
Posts: 336
Thanked 67 Times in 56 Posts
Default

Ugggh, I hear it now. It shows concern to me. I'll go listen to mine.
__________________
http://www.f150forum.com/signaturepics/sigpic136629_2.gif 2015 Platinum EB, 3.55 Locker, FX4, Lane Assist, Absolutely Loaded
2009 Audi TTS 1st in the US, 385 hp, 4 cyl. 2 liter; 2014 Audi SQ5 1st in the US, 365 hp; 2008 Carolina Classic Sportfish, Marblehead, MA
Fissues is offline   Reply With Quote
Old 11-09-2013, 09:03 AM   #13
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

I need to check the engine oil level too... If the tech neglected to put my skid plates and under body panel back on, maybe he forgot to fill the oil up all the way too.
rdkev is offline   Reply With Quote
Old 11-09-2013, 09:31 AM   #14
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

[MENTION=75227]HardcoreFXFour[/MENTION] what do you think?
rdkev is offline   Reply With Quote
Old 11-09-2013, 09:41 AM   #15
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,744
Thanked 474 Times in 330 Posts
Default

Quote:
Originally Posted by rdkev View Post
I need to check the engine oil level too... If the tech neglected to put my skid plates and under body panel back on, maybe he forgot to fill the oil up all the way too.
How many miles have you driven since your oil change?
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline   Reply With Quote
Old 11-09-2013, 09:47 AM   #16
I tell you hwut
 
HCFX2013's Avatar
 
Join Date: Aug 2011
Location: Over there
Posts: 17,811
Thanked 1,914 Times in 1,229 Posts
Default

That's really odd..I don't think I've ever heard mine do the same thing, though I do notice a constant audible tap from my injectors and a high pitched chirping whenever it's warming up.

Something's f*cky.
HCFX2013 is offline   Reply With Quote
Old 11-09-2013, 09:48 AM   #17
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

Quote:
Originally Posted by Azuri View Post
How many miles have you driven since your oil change?
maybe 50-80
rdkev is offline   Reply With Quote
Old 11-09-2013, 09:50 AM   #18
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

[MENTION=47652]FordService[/MENTION] for the love of all things holy, please help me.
rdkev is offline   Reply With Quote
Old 11-09-2013, 09:52 AM   #19
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,744
Thanked 474 Times in 330 Posts
Default

Quote:
Originally Posted by rdkev View Post
maybe 50-80
Sounds about the right amount of miles to hear some ill effects from a botched oil change. Go have a peak at your oil level it's the easiest thing to trouble shoot by yourself at this exact moment.
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline   Reply With Quote
The Following User Says Thank You to Azuri For This Useful Post:
rdkev (11-09-2013)
Old 11-09-2013, 09:57 AM   #20
Member
 
Join Date: Oct 2012
Location: Tucson, AZ
Posts: 3,801
Thanked 575 Times in 403 Posts
Default

Quote:
Originally Posted by Azuri View Post
Sounds about the right amount of miles to hear some ill effects from a botched oil change. Go have a peak at your oil level it's the easiest thing to trouble shoot by yourself at this exact moment.
I will as soon as I get home. It isn't parked on a level surface at the moment so I should probably wait until it's at some place flat. The tech probably did do something wrong.... to not even put the skid and undercarriage panel back on tells me he was in a rush or just didn't care. I can also see the remnants of oil spillage near the cap to fill the oil. I am so sad right now...
[MENTION=160438]kend[/MENTION] the saga continues.
rdkev is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
My new 2015 Platinum_Dawg General F150 Discussion 9 12-08-2015 10:29 PM
My new truck Platinum_Dawg 2015 - Present Ford F150 18 09-14-2015 08:02 PM
Little to almost no power while towing reader585 Maintenance Shop 2 09-10-2015 08:10 AM
Platinum 5.0 oil color and level Takeda 2015 - Present Ford F150 17 09-05-2015 10:20 PM
New member from VA! VA10 Introductions 0 09-03-2015 09:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 08:21 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.