Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-17-2014, 08:13 PM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2in leveling kit noise

Just recently got a 2 in. Skyjacker level installed by the local shop. I've been noticing that when I'm going 0-30mph or over bumps that my front suspension makes an almost rattling noise, like something is loose. It's not terrible, but it just bothers me. Can anyone help and tell me what might be going on? And what I should do to fix it?
bpelly is offline   Reply With Quote
Old 02-19-2014, 07:15 PM   #2
Junior Member
 
Join Date: May 2012
Posts: 20
Mentioned: 0 Post(s)
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by bpelly View Post
Just recently got a 2 in. Skyjacker level installed by the local shop. I've been noticing that when I'm going 0-30mph or over bumps that my front suspension makes an almost rattling noise, like something is loose. It's not terrible, but it just bothers me. Can anyone help and tell me what might be going on? And what I should do to fix it?
I've had the same issue with 2 trucks in the past week (my 2014 and sons 2012). It turned out to be the sway bars bolts just above the gasket weren't tight allowing the arm to slam up and down. Check yours.
__________________
2014 Eco Silver Platinum, 285/65R20 (34.7x11.5) BFG TAKO, 2"Daystar Kit, truxedo low pro, console vault
bmcqueen is offline   Reply With Quote
Old 02-20-2014, 10:42 AM   #3
Senior Member
 
jvines's Avatar
 
Join Date: Apr 2011
Location: Acworth, GA
Posts: 113
Mentioned: 3 Post(s)
Thanked 15 Times in 12 Posts
Feedback Score: 0 reviews
Default

Mine did the same. One of the uca side bolts was loose.
jvines is offline   Reply With Quote
Old 02-27-2014, 06:03 PM   #4
Junior Member
 
Join Date: Jan 2014
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by bmcqueen View Post
I've had the same issue with 2 trucks in the past week (my 2014 and sons 2012). It turned out to be the sway bars bolts just above the gasket weren't tight allowing the arm to slam up and down. Check yours.
I checked mine and they seem to be tight, so I'm not sure.
bpelly is offline   Reply With Quote
Old 02-27-2014, 07:25 PM   #5
Mark
5 Year Member
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 17,598
Mentioned: 5 Post(s)
Thanked 390 Times in 342 Posts
Feedback Score: 1 reviews
Default

stop by the shop that installed it and have them check it out...i assume they performed an Alignment after the install.
__________________
08 FX4... Flowmaster Exhaust, line-X, Sky Jacker leveling kit. 295/65/20 Nitto trails mounted on 20 X 9 Carol Shelby wheels. AIRAID CAI. Projector/Halo headlamps and LED Tails & 3rd brake lights,custom upper and lower Grill. Edge Evolution. Interior/Exterior LED lighting, NFAB step bars.
techrep is offline   Reply With Quote
Old 03-06-2014, 01:03 PM   #6
Junior Member
 
Join Date: Jan 2014
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by techrep View Post
stop by the shop that installed it and have them check it out...i assume they performed an Alignment after the install.
Yeah, they sent it to my local Ford dealership for alignment after the install.
bpelly is offline   Reply With Quote
Old 03-06-2014, 01:21 PM   #7
Senior Member
 
Join Date: Dec 2013
Location: St. John's NL
Posts: 124
Mentioned: 1 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Default

There is 100's of pages with people with the same issue and its not just people with levels. Its a ford wide problem im picking mine up now and they said they fixed the issue under warranty. They told me they replaced the steering rack and did a alignment ill find out now if it actually works.
Gravelley is offline   Reply With Quote
Old 03-06-2014, 01:30 PM   #8
Senior Member
 
Join Date: Aug 2012
Location: Mid-Michigan
Posts: 954
Mentioned: 0 Post(s)
Thanked 131 Times in 90 Posts
Feedback Score: 0 reviews
Default

mine is doing the same, i manually manipulated the steering shaft from under the hood and i could replicate the clunk.
__________________
2012 Screw*Race Red*Loaded*FX4
Stainless works Chambered cat back
*CAC condensation issue x3*
295/60/20 at II
UPR Products catch can, Raptor Blocks
Half_ton is offline   Reply With Quote
Old 03-06-2014, 02:14 PM   #9
Senior Member
 
Join Date: Dec 2013
Location: St. John's NL
Posts: 124
Mentioned: 1 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
Default

Just got back from ford with mine, they replaced the steering rack, and id a wheel alignment like i said above. The steering and the whole front end feels brand new. Now i just hope its stays that way.
Gravelley is offline   Reply With Quote
Old 03-06-2014, 02:14 PM
 
 
 
Reply


Tags
2 inch leveling kit, leveling kit, noises, problems

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 01:40 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.