Ford F150 Forum - Community of Ford Truck Fans

Ford F150 Forum - Community of Ford Truck Fans (http://www.f150forum.com/)
-   2009 - Present Ford F150 (http://www.f150forum.com/f38/)
-   -   2in leveling kit noise (http://www.f150forum.com/f38/2in-leveling-kit-noise-247501/)

bpelly 02-17-2014 08:13 PM

2in leveling kit noise
 
Just recently got a 2 in. Skyjacker level installed by the local shop. I've been noticing that when I'm going 0-30mph or over bumps that my front suspension makes an almost rattling noise, like something is loose. It's not terrible, but it just bothers me. Can anyone help and tell me what might be going on? And what I should do to fix it?

bmcqueen 02-19-2014 07:15 PM

Quote:

Originally Posted by bpelly (Post 3309180)
Just recently got a 2 in. Skyjacker level installed by the local shop. I've been noticing that when I'm going 0-30mph or over bumps that my front suspension makes an almost rattling noise, like something is loose. It's not terrible, but it just bothers me. Can anyone help and tell me what might be going on? And what I should do to fix it?

I've had the same issue with 2 trucks in the past week (my 2014 and sons 2012). It turned out to be the sway bars bolts just above the gasket weren't tight allowing the arm to slam up and down. Check yours.

jvines 02-20-2014 10:42 AM

Mine did the same. One of the uca side bolts was loose.

bpelly 02-27-2014 06:03 PM

Quote:

Originally Posted by bmcqueen (Post 3313704)
I've had the same issue with 2 trucks in the past week (my 2014 and sons 2012). It turned out to be the sway bars bolts just above the gasket weren't tight allowing the arm to slam up and down. Check yours.

I checked mine and they seem to be tight, so I'm not sure.

techrep 02-27-2014 07:25 PM

stop by the shop that installed it and have them check it out...i assume they performed an Alignment after the install.

bpelly 03-06-2014 01:03 PM

Quote:

Originally Posted by techrep (Post 3331002)
stop by the shop that installed it and have them check it out...i assume they performed an Alignment after the install.

Yeah, they sent it to my local Ford dealership for alignment after the install.

Gravelley 03-06-2014 01:21 PM

There is 100's of pages with people with the same issue and its not just people with levels. Its a ford wide problem im picking mine up now and they said they fixed the issue under warranty. They told me they replaced the steering rack and did a alignment ill find out now if it actually works.

Half_ton 03-06-2014 01:30 PM

mine is doing the same, i manually manipulated the steering shaft from under the hood and i could replicate the clunk.

Gravelley 03-06-2014 02:14 PM

Just got back from ford with mine, they replaced the steering rack, and id a wheel alignment like i said above. The steering and the whole front end feels brand new. Now i just hope its stays that way.


All times are GMT -4. The time now is 01:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com