2011 F-150 Power Sliding Rear Window Problem - Ford F150 Forum - Community of Ford Truck Fans



2011 F-150 Power Sliding Rear Window Problem

Reply
 
 
 
Thread Tools Search this Thread
Old 01-26-2012, 08:26 AM   #1
Member
Thread Starter
 
Join Date: Aug 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2011 F-150 Power Sliding Rear Window Problem

My power sliding rear window is severely slowing down when I open and close my rear sliding window around the half way point. It use to slide easily wide open and closed. Now around the half way point it severely slows down almost to the point where sometimes I can't open it all the way!

Granted it is the winter months and things do freeze up or get cold, what do you think the problem could be? Should I have the dealer look at it? I cleaned the inside and outside of the glass extremely well but of no avail.
Rymanh24 is offline   Reply With Quote
Old 01-26-2012, 08:31 AM   #2
Senior Member
5 Year Member
 
Join Date: Oct 2009
Location: Wilmington, NC
Posts: 1,504
Thanked 27 Times in 16 Posts
Default

Is the track clean as well? Your under warranty so I would let the dealer look at it and see if the motor is defective...
Bob_Mac is offline   Reply With Quote
Old 01-26-2012, 08:34 AM   #3
Member
Thread Starter
 
Join Date: Aug 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It should be clean. The truck is only 4 months old. I can see though when I open it, the top track looks to be hanging the window up. I'm not sure how I am going to tackle that one.
Rymanh24 is offline   Reply With Quote
Old 01-26-2012, 08:37 AM   #4
Senior Member
5 Year Member
 
Join Date: Oct 2009
Location: Wilmington, NC
Posts: 1,504
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by Rymanh24 View Post
It should be clean. The truck is only 4 months old. I can see though when I open it, the top track looks to be hanging the window up. I'm not sure how I am going to tackle that one.
Take it to the dealer...if you mess with it they may blame you for the issue....
Bob_Mac is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What did you regear to? zac692069 2009 - 2014 Ford F150 31 06-02-2016 03:33 PM
Need audio experts! Kalen427 Stereo/Audio 34 01-24-2016 04:54 PM
Replaced front fuel pump; still not working spinningchurro 1987 - 1996 F150 6 10-23-2015 11:01 PM
Hey everyone Brandyn193 Introductions 1 09-04-2015 05:06 PM
Windows Jason Spelts Aftermarket Products, Reviews & Installation 3 09-03-2015 11:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:54 AM.


Copyright 2006 - 2016 F150Forum.com