2010 Lariat Gauges - Ford F150 Forum - Community of Ford Truck Fans



2010 Lariat Gauges

Reply
 
 
 
Thread Tools Search this Thread
Old 10-15-2009, 10:32 AM   #1
Junior Member
5 Year Member
Thread Starter
 
Join Date: Oct 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2010 Lariat Gauges

Gentlemen,
I've recently purchased a 2010 F-150 Supercrew 4x4 Lariat. At startup, all my gauges max out, then return to normal operation. Is this normal. My 2006 did not do this.

Thanks in advance for your response.
booyaf2 is offline   Reply With Quote
Old 10-15-2009, 10:35 AM   #2
Member
 
shrubs2000's Avatar
 
Join Date: Sep 2009
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Guessing Normal. My 2010 FX4 does this too.
shrubs2000 is offline   Reply With Quote
Old 10-15-2009, 11:45 AM   #3
Senior Member
5 Year Member
 
Join Date: Apr 2009
Posts: 788
Thanked 7 Times in 7 Posts
Default

Never paid attention on my '09 KR but if the guages are sweeping, it's nothing out of the ordinary.

Edit: Checked mine and the guages do not sweep at start-up. Maybe this is a new feature for 2010.

Last edited by big_ole_truck; 10-15-2009 at 02:35 PM.
big_ole_truck is offline   Reply With Quote
Old 10-15-2009, 12:19 PM   #4
Junior Member
5 Year Member
 
Join Date: Sep 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Normal, it's the self test
cujet is offline   Reply With Quote
Old 10-15-2009, 03:15 PM   #5
RejectedReject
 
Join Date: Jun 2009
Location: LITH IL
Posts: 695
Thanks: 0
Thanked 12 Times in 5 Posts
Default

A gauge sweep is usually an early indicator of a weak battery.
Ftruck05 is offline   Reply With Quote
Old 10-15-2009, 04:43 PM   #6
Senior Member
 
SFCFX4's Avatar
 
Join Date: Sep 2009
Location: Dallas, Tx
Posts: 541
Thanks: 0
Thanked 4 Times in 2 Posts
Default

The 2010s will sweep the gauges when you start it up, it was the same on the '10 FX4 I test drove. The '09 I got doesn't do that.

Other makes of cars will do this too, such as the Scion tC. I wonder if it's just a computer thing that can be done to the '09s to make them sweep too.
SFCFX4 is offline   Reply With Quote
Old 10-15-2009, 04:47 PM   #7
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My 2010 SuperCrew Lariat does the same thing.
It's normal
kawasakieric is offline   Reply With Quote
Old 10-19-2009, 12:14 AM   #8
awh
Member
5 Year Member
 
awh's Avatar
 
Join Date: Jun 2009
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My '99 use to do that - A weak battery was the cause in it. Once it was replaced everything was A-OK.
awh is offline   Reply With Quote
Old 10-19-2009, 12:23 AM   #9
Senior Member
5 Year Member
 
Join Date: Aug 2009
Posts: 488
Thanks: 0
Thanked 1 Time in 1 Post
Default

my old car does that it was an 06 pontiac g6
travisb05 is offline   Reply With Quote
Old 10-19-2009, 12:28 AM   #10
2010 Lariat
5 Year Member
 
KevinR's Avatar
 
Join Date: Sep 2009
Location: Central, IL
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I would say normal, mine does it as did the other 2010 I test drove.....
KevinR is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wheels, Tires Suspension on 2010 Lariat? johnu Wheels & Tires 4 09-23-2015 05:08 PM
Fuel pressure Hanta 1987 - 1996 F150 2 09-10-2015 07:41 AM
Best bang/buck aftermarket audio GeologyRocks 2009 - 2014 Ford F150 17 09-10-2015 06:33 AM
Transmission temp gauge e4od notsosporty98 1987 - 1996 F150 1 09-08-2015 05:22 PM
2010 Leveling KIt GeologyRocks 2009 - 2014 Ford F150 4 09-05-2015 09:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:14 PM.


Copyright 2006 - 2016 F150Forum.com