problem - Ford F150 Forum - Community of Ford Truck Fans



problem

Reply
 
 
 
Thread Tools Search this Thread
Old 12-01-2007, 09:18 PM   #1
TOGA TOGA TOGA
5 Year Member
Thread Starter
 
92custom's Avatar
 
Join Date: Dec 2006
Location: Hartselle, AL
Posts: 2,183
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem

i got my power wire ran today but my system still aint working, the power light is coming on on the amp but the subs aint workin all my wires are good and tight in the amp and box (inside and outside), any suggestions
92custom is offline   Reply With Quote
Old 12-01-2007, 09:32 PM   #2
Ty
Senior Member
5 Year Member
 
Ty's Avatar
 
Join Date: Nov 2006
Location: Minocqua Wi
Posts: 6,988
Thanks: 0
Thanked 5 Times in 5 Posts
Default

is your power wire hooked up right? have you tried testing it with a multimeter, or even a simple light auto light bulb?
Ty is offline   Reply With Quote
Old 12-02-2007, 12:06 AM   #3
TOGA TOGA TOGA
5 Year Member
Thread Starter
 
92custom's Avatar
 
Join Date: Dec 2006
Location: Hartselle, AL
Posts: 2,183
Thanks: 0
Thanked 0 Times in 0 Posts
Default

it started working
92custom is offline   Reply With Quote
Old 12-02-2007, 12:25 AM   #4
Ty
Senior Member
5 Year Member
 
Ty's Avatar
 
Join Date: Nov 2006
Location: Minocqua Wi
Posts: 6,988
Thanks: 0
Thanked 5 Times in 5 Posts
Default

why?
Ty is offline   Reply With Quote
Old 12-03-2007, 11:17 PM   #5
TOGA TOGA TOGA
5 Year Member
Thread Starter
 
92custom's Avatar
 
Join Date: Dec 2006
Location: Hartselle, AL
Posts: 2,183
Thanks: 0
Thanked 0 Times in 0 Posts
Default

not sure, i was drivin around for about five minutes and it came on, but it aint workin again so i no something is wrong so im goin to get my friend who did all my other stuff to check it out
92custom is offline   Reply With Quote
Old 12-06-2007, 03:50 PM   #6
FULL BLOODED AMERICAN!!!!
 
Triton v8's Avatar
 
Join Date: Apr 2007
Location: Jacksonville, Florida
Posts: 5,179
Thanks: 0
Thanked 1 Time in 1 Post
Default

Check your ground. You'll still have power but a bad ground will cause it not to play.
Triton v8 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
Aluminum Problems wpbritton General F150 Discussion 11 03-20-2016 09:39 PM
Need help! Battery keeps dying! john367 2009 - 2014 Ford F150 42 10-23-2015 03:23 PM
Transmission problems P0720,P0722 azkfx450 2004 - 2008 Ford F150 2 09-11-2015 12:52 PM
New to me truck with problems--please help!! AKJT1215 2004 - 2008 Ford F150 13 09-09-2015 06:01 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:49 AM.


Copyright 2006 - 2016 F150Forum.com