Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Aftermarket Products, Reviews & Installation > Stereo/Audio
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 05-29-2014, 04:40 PM   #1
Junior Member
 
Join Date: May 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Finally upgraded system..

Hey all, I'm new to the forum here and was looking to get some thoughts/opinions on what I just got installed. I have a 2011 lariat super crew that had a factory system. I just had 4 Polk db571 speakers put in and just ordered an amplified MTX thunderform sub to be installed next week. I pretty much have no knowledge about sound systems so I trusted an audio place in my city. Thoughts?
Gansh21 is offline   Reply With Quote
Old 05-29-2014, 08:41 PM   #2
One Clean Machine
 
Toddman34's Avatar
 
Join Date: Sep 2012
Location: St. Louis, MO
Posts: 5,629
Mentioned: 25 Post(s)
Thanked 748 Times in 644 Posts
Feedback Score: 2 reviews
Default

Should sound Great, compared to what Ford installs!
__________________
2012 XLT 4X4 Screw|EcoBoost|
Toddman34 is online now   Reply With Quote
Old 05-29-2014, 11:10 PM   #3
Senior Member
 
Join Date: Dec 2013
Posts: 985
Mentioned: 1 Post(s)
Thanked 127 Times in 110 Posts
Feedback Score: 0 reviews
Default

sounds like a pretty good setup for someone who wants to plug and play
king nothing is offline   Reply With Quote
Old 05-30-2014, 01:30 AM   #4
Junior Member
 
Join Date: May 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Is there a difference in sound quality between the aux input and USB?
Gansh21 is offline   Reply With Quote
Old 05-30-2014, 12:31 PM   #5
Senior Member
 
Join Date: Jul 2011
Location: Casper, WY.
Posts: 1,856
Mentioned: 0 Post(s)
Thanked 121 Times in 117 Posts
Feedback Score: 1 reviews
Default

Quote:
Originally Posted by Gansh21 View Post
Is there a difference in sound quality between the aux input and USB?
yes
__________________
2014 Tuxedo Black F150 XLT Scab 4x4 w/5.0 with SCT tune. JVC's in doors. 2 - 10" Kenwood subs under rear seat powered by JL Audio amp
Wyo11Scab is offline   Reply With Quote
Old 05-31-2014, 11:26 AM   #6
Junior Member
 
Join Date: May 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Wyo11Scab View Post
yes
Which one will be better
Gansh21 is offline   Reply With Quote
Old 05-31-2014, 01:18 PM   #7
Senior Member
 
Join Date: Jul 2011
Location: Casper, WY.
Posts: 1,856
Mentioned: 0 Post(s)
Thanked 121 Times in 117 Posts
Feedback Score: 1 reviews
Default

Quote:
Originally Posted by Gansh21 View Post
Which one will be better
usb
__________________
2014 Tuxedo Black F150 XLT Scab 4x4 w/5.0 with SCT tune. JVC's in doors. 2 - 10" Kenwood subs under rear seat powered by JL Audio amp
Wyo11Scab is offline   Reply With Quote
Old 05-31-2014, 06:07 PM   #8
Senior Member
 
Robert8252's Avatar
 
Join Date: Apr 2013
Location: Indiana
Posts: 233
Mentioned: 0 Post(s)
Thanked 18 Times in 18 Posts
Feedback Score: 0 reviews
Default

Unless you are using lossless audio files there won't be a big difference from USB to AUX, Bluetooth as well. CD is still the best.
Robert8252 is offline   Reply With Quote
Old 08-03-2014, 06:16 PM   #9
Junior Member
 
Join Date: May 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Bump...so I've had this system installed for a little over a month now. It was working awesome until the sub started to cut in and out which the company installed thought it was clipping. He talked to MTX and they concluded that the preamp was defective. Got my preamp sent to me and installed it and it still is doing the same thing. Any other ideas?
Gansh21 is offline   Reply With Quote
Old 08-03-2014, 11:27 PM   #10
Senior Member
 
Join Date: Jul 2011
Location: Casper, WY.
Posts: 1,856
Mentioned: 0 Post(s)
Thanked 121 Times in 117 Posts
Feedback Score: 1 reviews
Default

Quote:
Originally Posted by Gansh21 View Post
Bump...so I've had this system installed for a little over a month now. It was working awesome until the sub started to cut in and out which the company installed thought it was clipping. He talked to MTX and they concluded that the preamp was defective. Got my preamp sent to me and installed it and it still is doing the same thing. Any other ideas?
Have them swap out the sub to test it
__________________
2014 Tuxedo Black F150 XLT Scab 4x4 w/5.0 with SCT tune. JVC's in doors. 2 - 10" Kenwood subs under rear seat powered by JL Audio amp
Wyo11Scab is offline   Reply With Quote
Old 08-03-2014, 11:27 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 04:07 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.