Digital Odometer not working!!! - Ford F150 Forum - Community of Ford Truck Fans



Digital Odometer not working!!!

Reply
 
 
 
Thread Tools Search this Thread
Old 11-25-2007, 01:21 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Digital Odometer not working!!!

I am looking at a 2004 F-150 Lariat, LOADED but it has unknown mileage because the digital odometer is not working. It is a great price for the truck because of the unknown mileage but I would kinda like to know how easy this would be to fix.

Has anyone had this problem? If so how did you fix it and what did it cost.
Jeff2000 is offline   Reply With Quote
Old 11-25-2007, 02:34 AM   #2
Jan 2008 TOTM & Gdreject
 
Squirtbottle09's Avatar
 
Join Date: Sep 2007
Location: College Station, Tx
Posts: 625
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Check the fuse for it. I dont know what it is, but that could be a problem.
Squirtbottle09 is offline   Reply With Quote
Old 11-25-2007, 02:50 AM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found this on another forum and it may be the culprit.

http://www.f150online.com/forums/sho...d.php?t=126765
Jeff2000 is offline   Reply With Quote
Old 02-15-2013, 12:09 AM   #4
Junior Member
 
Join Date: Jul 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Odometer not working

My odometer stopped working on my 2005 F150 XLT Supercrew 5.4l. I stopped by Ford to see if they could lead me to the right area to start looking for the problem. With a nice charge to go with it.

Well here is what I did to resolve the problem myself and it worked.

I took both the positive and negative sides of the battery off. I then removed the three connections from the computer that was attached next to the battery on the firewall. Then I took electric connector contact cleaner and sprayed both side of the connector. I waited 10 minuted and plugged in the connectors and reconnected the battery. Once that was completed I started the truck and everything was working fine. It has been a week since I did this the the computer with no problems.
keithrp7255 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'95 F150 5.0L fuel system woes RetTankMech Drivetrain 4 07-15-2016 10:17 PM
Rear lights don't work when lights are on. readyoarnot Electrical 4 02-09-2016 06:29 PM
Justifying the cost of the 'second' vehicle AndyFX4 2009 - 2014 Ford F150 46 09-19-2015 05:38 PM
My First Truck kalison 2015 - Present Ford F150 6 09-06-2015 03:59 PM
Speedo issue!?!? smwann 2015 - Present Ford F150 4 09-06-2015 02:06 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:54 AM.


Copyright 2006 - 2016 F150Forum.com