Been a Rough Day - Ford F150 Forum - Community of Ford Truck Fans



Been a Rough Day

Reply
 
 
 
Thread Tools Search this Thread
Old 10-13-2012, 08:55 PM   #1
WDE
Thread Starter
 
04_lariat_4x4's Avatar
 
Join Date: Sep 2011
Posts: 2,123
Thanked 18 Times in 17 Posts
Default

Been at the lake since yesterday relaxing with buddies, an drove my 04 lariat here, didn't have any problems. It sat still overnight, no one messed with it, and we just went to drive and it was dead with the electronics going haywire. Even the tailgate light bar was staying on when I had all the lights turned off. So we jumped it off and it started, and I let it run a good while. Turned it off and later tried to start it again and it had the same problem. I've been having to jump it off alot lately, but have been having the electronics go crazy each time. I know it probably needs a new battery, but could my alternator be going bad?
04_lariat_4x4 is offline   Reply With Quote
Old 10-13-2012, 09:15 PM   #2
Member
 
Join Date: Sep 2012
Location: ND
Posts: 65
Thanked 4 Times in 4 Posts
Default

Check your battery terminal connections. I have had that issue in the past with a bad ground terminal on the battery. That would explain the crazy stuff. Jumping it doesn't make too much sense, but you could go have your battery tested at places like autozone.
Burrich is offline   Reply With Quote
Old 10-13-2012, 09:18 PM   #3
One Bad MoFoMoCo Owner
 
sullyman's Avatar
 
Join Date: Jul 2012
Location: Texas Hill Country
Posts: 2,219
Thanked 392 Times in 258 Posts
Default

As stated above, it's most likely the battery ground post, or it's where the ground wire off the battery connects to the truck.
sullyman is offline   Reply With Quote
Old 10-13-2012, 09:20 PM   #4
Senior Member
5 Year Member
 
Join Date: Jul 2011
Location: Tonopah. AZ.
Posts: 2,845
Thanked 319 Times in 217 Posts
Default

you just answerd your own question put a load test on the battery and at the same time check charging voltage. A weak or bad battery can cause all kinds of wierd s**t with the electronics
bubbabud is offline   Reply With Quote
Old 10-13-2012, 09:59 PM   #5
WDE
Thread Starter
 
04_lariat_4x4's Avatar
 
Join Date: Sep 2011
Posts: 2,123
Thanked 18 Times in 17 Posts
Default

Sorry guys this was probably a pointless post, been drinking all day and got angry and just needed to vent. And I wasn't planning on driving by the way, just to clear that up.
04_lariat_4x4 is offline   Reply With Quote
Old 10-14-2012, 11:25 AM   #6
Junior Member
 
Join Date: Oct 2012
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 04_lariat_4x4 View Post
Sorry guys this was probably a pointless post, been drinking all day and got angry and just needed to vent. And I wasn't planning on driving by the way, just to clear that up.
i love drinking all day and venting lol!
Shane Wilson is offline   Reply With Quote
Old 10-14-2012, 05:06 PM   #7
Senior Member
 
MattDad379's Avatar
 
Join Date: Sep 2012
Location: Mount Pleasant, Pennsylvania
Posts: 124
Thanked 2 Times in 2 Posts
Default

Check to make sure all your connections are tight such as battery and alternator. I had a similar issue long time ago on my old truck and the bolt was loose on my alternator. Tightened all the wires and bolts and problem stopped.
MattDad379 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
2010 5.4L 3V Rough Idle - Help Ottawavalleylad 2009 - 2014 Ford F150 11 06-23-2016 02:43 PM
Aluminum Problems wpbritton General F150 Discussion 11 03-20-2016 09:39 PM
Installed my winch today Fischer88 2009 - 2014 Ford F150 47 03-01-2016 09:00 PM
Rust purdue616 2009 - 2014 Ford F150 4 09-03-2015 08:21 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:34 PM.


Copyright 2006 - 2016 F150Forum.com